Bug 1007708 - [RFE] Enable qemu-img to support VMDK version 3
Summary: [RFE] Enable qemu-img to support VMDK version 3
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: qemu-kvm
Version: 6.5
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: rc
: ---
Assignee: Fam Zheng
QA Contact: Virtualization Bugs
URL:
Whiteboard:
: 1029852 (view as bug list)
Depends On:
Blocks: 1007710 1090783 1092940 1092941
TreeView+ depends on / blocked
 
Reported: 2013-09-13 07:49 UTC by Sibiao Luo
Modified: 2019-07-11 07:46 UTC (History)
17 users (show)

Fixed In Version: qemu-kvm-0.12.1.2-2.420.el6
Doc Type: Enhancement
Doc Text:
Clone Of:
: 1007710 1090783 1092940 1092941 (view as bug list)
Environment:
Last Closed: 2014-10-14 06:51:07 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1490 normal SHIPPED_LIVE qemu-kvm bug fix and enhancement update 2014-10-14 01:28:27 UTC
Launchpad 1253465 None None None Never

Description Sibiao Luo 2013-09-13 07:49:47 UTC
Description of problem:
Install a image in ESXi host, export it into a VMDK format image with vSphere client(Version 5.1.0) and then copy it out in localhost. But fail to check the vmdk image info using use 'qemu-img info $image', and fail to convert the vmdk image into qcow2/raw format via qemu-img. Every time we have to use vmware-vdiskmanager to convert or check the info.

BTW, if this issue can't be fixed currently, it can be deferred to rhel6.6 or close it CANT fixed directly. But i think it's very useful for our QEMU users to implement this function.

Version-Release number of selected component (if applicable):
host info:
# uname -r && rpm -q qemu-kvm-rhev
2.6.32-414.el6.x86_64
qemu-kvm-rhev-0.12.1.2-2.401.el6.x86_64

How reproducible:
100%

Steps to Reproduce:
1.# qemu-img info sluo-esx5.1-rhel6.5-x86_64-disk1.vmdk
'image' uses a vmdk feature which is not supported by this qemu version: VMDK version 3
Could not open 'sluo-esx5.1-rhel6.5-x86_64-disk1.vmdk': Wrong medium type
2.# qemu-img convert -f vmdk sluo-esx5.1-rhel6.5-x86_64-disk1.vmdk -O raw sluo-esx5.1-rhel6.5-x86_64-disk1.raw
'image' uses a vmdk feature which is not supported by this qemu version: VMDK version 3
Could not open 'sluo-esx5.1-rhel6.5-x86_64-disk1.vmdk': Wrong medium type
Could not open 'sluo-esx5.1-rhel6.5-x86_64-disk1.vmdk'

Actual results:

Expected results:

Additional info:
# qemu-img create -f vmdk sluo.vmdk 1G
Formatting 'sluo.vmdk', fmt=vmdk size=1073741824 compat6=off zeroed_grain=off 
# qemu-img info sluo.vmdk 
image: sluo.vmdk
file format: vmdk
virtual size: 1.0G (1073741824 bytes)
disk size: 12K

Comment 5 Ademar Reis 2013-12-17 18:59:35 UTC
*** Bug 1029852 has been marked as a duplicate of this bug. ***

Comment 7 Fam Zheng 2014-01-07 01:00:43 UTC
Yes. There is only a tip about backup software supporting VMDK v3 from VMware:

http://kb.vmware.com/kb/2064959

Upstream does support reading, and we are working on backporting this to RHEL.

Comment 8 Evgheni Dereveanchin 2014-01-07 10:47:37 UTC
Thank you for updating this. Read capability should be enough for V2V migrations - we just read the VMDK and convert it to QCOW2/RAW/etc. What about 2TB+ volumes? I assume there is no documentation on this and no upstream support.

Comment 9 Miroslav Rezanina 2014-01-08 03:49:21 UTC
*** Bug 1029852 has been marked as a duplicate of this bug. ***

Comment 10 Fam Zheng 2014-01-09 02:04:24 UTC
(In reply to Evgheni Dereveanchin from comment #8)
> What
> about 2TB+ volumes? I assume there is no documentation on this and no
> upstream support.

The sparse formats should work just well, but there may be some bugs with a big flat, do you have a specific case that's not working? If so feel free to file a bug.

Fam

Comment 11 Miroslav Rezanina 2014-01-27 07:51:55 UTC
Fix included in qemu-kvm-0.12.1.2-2.420.el6

Comment 13 Sibiao Luo 2014-06-17 07:48:04 UTC
Verify this issue with vSphere client(Version 5.1.0) on qemu-kvm-rhev-0.12.1.2-2.424.el6.x86_64.
host info:
# uname -r && rpm -q qemu-kvm-rhev
2.6.32-448.el6.x86_64
qemu-kvm-rhev-0.12.1.2-2.424.el6.x86_64

Steps and results:
1.Install a image in ESXi host, export it into a vmdk v3 image with vSphere client(Version 5.1.0) and then copy it out in localhost.
# qemu-img info sluo-rhel6.5-64bit-vsphere5.1.0-disk1.vmdk
image: sluo-rhel6.5-64bit-vsphere5.1.0-disk1.vmdk
file format: vmdk
virtual size: 10G (10737418240 bytes)
disk size: 2.0G
2.# qemu-img convert -p -f vmdk sluo-rhel6.5-64bit-vsphere5.1.0-disk1.vmdk -O qcow2 sluo-rhel6.5-64bit-vsphere5.1.0-disk1.qcow2
    (100.00/100%)
# qemu-img info sluo-rhel6.5-64bit-vsphere5.1.0-disk1.qcow2
image: sluo-rhel6.5-64bit-vsphere5.1.0-disk1.qcow2
file format: qcow2
virtual size: 10G (10737418240 bytes)
disk size: 4.9G
cluster_size: 65536
3.# qemu-img convert -p -f vmdk sluo-rhel6.5-64bit-vsphere5.1.0-disk1.vmdk -O raw sluo-rhel6.5-64bit-vsphere5.1.0-disk1.raw
    (100.00/100%)
# qemu-img info sluo-rhel6.5-64bit-vsphere5.1.0-disk1.raw
image: sluo-rhel6.5-64bit-vsphere5.1.0-disk1.raw
file format: raw
virtual size: 10G (10737418240 bytes)
disk size: 4.8G

Base on above, this issue has been fixed correctly, move to VERIFIED status.

Best Regards,
sluo

Comment 14 errata-xmlrpc 2014-10-14 06:51:07 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1490.html


Note You need to log in before you can comment on or make changes to this bug.