Bug 109302 - Abiword fails to start / X error
Summary: Abiword fails to start / X error
Status: CLOSED DUPLICATE of bug 105624
Alias: None
Product: Fedora
Classification: Fedora
Component: abiword (Show other bugs)
(Show other bugs)
Version: 1
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-11-06 18:01 UTC by Mikko Huhtala
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 18:59:47 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Mikko Huhtala 2003-11-06 18:01:37 UTC
Description of problem:

Abiword fails to start and produces an X error complaining about
'insufficient resoures' instead.

Version-Release number of selected component (if applicable):

abiword-2.0.1-1
XFree86-4.3.0-42 (driver nv on a GeForce 3 card)

How reproducible:
Always

Steps to Reproduce:
1. Log in
2. Launch Abiword from either a terminal or the menu
  
Actual results:

The following error message:

The program 'AbiWord' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadAlloc (insufficient resources for operation)'.
  (Details: serial 2466 error_code 11 request_code 53 minor_code 0)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error()
function.)


Expected results:

Successfully started Abiword.

Additional info:

The system is a freshly installed Fedora Core 1. No NVidia driver is
in use, only the default driver from the XFree86 project. The Abiword
package is missing files, see bug 109261. The missing files do not, at
a first glance, seem to be the cause of this problem.

Comment 1 Christopher Stone 2003-11-06 20:57:05 UTC
Hi, the solution to this problem is to start abiword with a geometry
setting.

For example: abiword --geometry 800x600

Then quit abiword, and it will remember your geometry settings and all
should be peachy keen again.

Comment 2 Jeremy Katz 2003-11-06 23:47:35 UTC

*** This bug has been marked as a duplicate of 105624 ***

Comment 3 Red Hat Bugzilla 2006-02-21 18:59:47 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.