Bug 105624 - segs on startup
Summary: segs on startup
Status: CLOSED DUPLICATE of bug 140321
Alias: None
Product: Red Hat Linux Beta
Classification: Retired
Component: abiword   
(Show other bugs)
Version: beta2
Hardware: All
OS: Linux
low
high
Target Milestone: ---
Assignee: Caolan McNamara
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
: 109302 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-09-26 03:14 UTC by Luis Villa
Modified: 2005-10-31 22:00 UTC (History)
2 users (show)

Fixed In Version: FC3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-25 09:59:20 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Luis Villa 2003-09-26 03:14:09 UTC
This works fine on a local RH9 box with the abiword-provided packages, or over X
from that selfsame box. But when I run on 9.0.93+all rawhide updates, I get
this, after splash screen and partial display of the UI: 

[louie@localhost louie]$ AbiWord-2.0
*** attempt to put segment in horiz list twice
*** attempt to put segment in horiz list twice
The program 'AbiWord' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadAlloc (insufficient resources for operation)'.
  (Details: serial 2546 error_code 11 request_code 53 minor_code 0)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)

GDB is not showing me the love tonight, though, maybe tomorrow. Thought I'd file
in the meantime and see if maybe it's not just me.

Comment 1 Jeremy Katz 2003-09-26 04:09:37 UTC
Hrmm, works fine for me here on my laptop and also works for me on my desktop at
work.  The X error is potentially telling -- what resolution/bit depth are you
running and which X driver?

Will try to poke on a fresh install, too

Comment 2 Jeremy Katz 2003-10-21 20:29:52 UTC
Works fine on a fresh install with i865 video running at 1024x768/24bpp as well.

Which X server are you using?

Comment 3 Bojan Smojver 2003-10-23 04:24:08 UTC
Problem on ATI Radeon (generic) for me. Works fine on ATI Rage 128 Pro Ultra.
These are two different machines, of course. Go figure...

Comment 4 Bojan Smojver 2003-10-23 04:26:14 UTC
Version should be changed to Beta 3, as that's the latest version where it still
happens.

Comment 5 Jeremy Katz 2003-10-23 19:29:01 UTC
Can you get a backtrace of the segfault?

Comment 6 Bojan Smojver 2003-10-23 20:58:31 UTC
Sorry, it just says "No stack." My guess is that it is due to the nature of the
error - Abiword shuts down because of the errors elsewhere. Anything else I can try?

Comment 7 Jeremy Katz 2003-11-06 23:47:37 UTC
*** Bug 109302 has been marked as a duplicate of this bug. ***

Comment 8 Christopher Stone 2003-11-07 03:06:18 UTC
ugh, as I stated in the dup bug posted above, this problem is easily
fixed by starting abiword with a geometry setting:

$ abiword --geometry 800x600

Once you do that, it will be fixed.

Comment 9 Elijah Newren 2003-11-12 20:15:33 UTC
This bug also exists in the AbiWord bugzilla database at
  http://bugzilla.abisource.com/show_bug.cgi?id=5623

I added tkmame's suggestion to that bug.  Oh, and thanks tkmame!  It
worked like a charm for me!

Comment 10 Caolan McNamara 2004-07-23 06:52:44 UTC
Should be all ok in abiword now, certainly can't reproduce it with
FC2/FC3.

Comment 11 Caolan McNamara 2004-11-25 09:58:04 UTC

*** This bug has been marked as a duplicate of 140321 ***


Note You need to log in before you can comment on or make changes to this bug.