Bug 109310 - Cant get into Dell Utility Partition after install of Fedora
Summary: Cant get into Dell Utility Partition after install of Fedora
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: grub
Version: 1
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
: 109312 109318 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-11-06 19:35 UTC by Adam Julius
Modified: 2007-11-30 22:10 UTC (History)
0 users

(edit)
Clone Of:
(edit)
Last Closed: 2003-11-06 23:46:14 UTC


Attachments (Terms of Use)

Description Adam Julius 2003-11-06 19:35:51 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; .NET 
CLR 1.1.4322)

Description of problem:
I have a Dell Dimension 8300 which has a FAT partition for Dell 
Utility which has a diagnostics program.  I installed Fedora Core 1.  
If I press the appropriate function key to get into the Dell Utility 
Partition upon turning on the computer, it goes into GRUB and I can 
only choose between the OS's that are part of Grub and if I try to go 
into Windows XP Pro, for example it gives an error message upon 
trying to boot since the computer was expecting to go right into the 
Dell Utility Partition.  

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Turn on Dell computer
2. Press F12 to get into setup screen
3. Select option to boot into utility partition
    

Additional info:

Comment 1 Jeremy Katz 2003-11-06 19:41:04 UTC
You probably need to add the (possibly hidden) utility partition to
grub so that you can select to boot it.  If you do that, does it work?

That, or Dell is expecting the MBR to be "their's", in which case, you
need to have installed GRUB to the boot partition instead of the to
the MBR so that the MBR would remain under BIOS control.

Comment 2 Jeremy Katz 2003-11-06 19:45:48 UTC
*** Bug 109312 has been marked as a duplicate of this bug. ***

Comment 3 Adam Julius 2003-11-06 20:06:29 UTC
*** Bug 109318 has been marked as a duplicate of this bug. ***

Comment 4 Adam Julius 2003-11-06 21:30:04 UTC
I added the Partition to GRUB and it works fine now.  You can get in 
via the bios by then selecting the partition in the boot manager 
(added step) or directly from the bootmanager itself without going 
through the bios.  

Comment 5 Jeremy Katz 2003-11-06 23:46:14 UTC
There's no real way to detect this unfortunately -- but it basically
means my guess is correct.


Note You need to log in before you can comment on or make changes to this bug.