Bug 1093128 - [GSS](6.3.0) Remote client transaction timeout values are overwritten by hardcoded values
Summary: [GSS](6.3.0) Remote client transaction timeout values are overwritten by hard...
Status: CLOSED CURRENTRELEASE
Alias: None
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: EJB
Version: 6.1.1
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ER6
: EAP 6.3.0
Assignee: Ivo Studensky
QA Contact: Jan Martiska
Russell Dickenson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 1093752 1159058
TreeView+ depends on / blocked
 
Reported: 2014-04-30 16:56 UTC by Stephen Fikes
Modified: 2018-12-09 17:47 UTC (History)
5 users (show)

(edit)
Previous releases of JBoss EAP 6 carried an issue that may have resulted in remote client transactions spanning multiple servers timing out earlier or later than expected.

The issue arised because timeout values are not propagated across servers correctly, leaving the system to rely on the hardcoded timeout value (300 seconds).

This issue is resolved in JBoss EAP 6.3.0.
Clone Of:
: 1093752 (view as bug list)
(edit)
Last Closed: 2014-06-28 15:25:07 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 1134833 None None None 2016-04-29 20:41 UTC
JBoss Issue Tracker WFLY-2789 Major Resolved Remote client transaction timeout values are overwrote by hardcoded values 2017-06-28 02:49 UTC

Description Stephen Fikes 2014-04-30 16:56:44 UTC
Description of problem:
See https://issues.jboss.org/browse/WFLY-2789

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Ivo Studensky 2014-05-27 10:58:48 UTC
PR sent:
https://github.com/jbossas/jboss-eap/pull/1369

Comment 2 Jan Martiska 2014-06-10 11:34:22 UTC
Verified in EAP 6.3.0.ER7.

Comment 3 Jan Martiska 2014-07-02 08:23:59 UTC
Hi Scott, I changed the doc to reflect that this is a bugfix, not a known issue in EAP 6.3.0. Could you make sure this change gets reflected in the next build of release notes? Thanks.

Comment 4 Stephen Fikes 2016-04-29 20:28:11 UTC
The resolution of this issue was to change the hardcoded timeout from 300 seconds (5 minutes) to Integer.MAX_VALUE.

Comment 5 Stephen Fikes 2016-04-29 20:29:08 UTC
See also https://bugzilla.redhat.com/show_bug.cgi?id=1265300 for a subsequent refinement.


Note You need to log in before you can comment on or make changes to this bug.