Bug 1093752 - [GSS](6.2.x) Remote client transaction timeout values are overwritten by hardcoded values
Summary: [GSS](6.2.x) Remote client transaction timeout values are overwritten by hard...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: EJB
Version: 6.1.1
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: CR1
: EAP 6.2.4
Assignee: Ivo Studensky
QA Contact: Jan Martiska
Russell Dickenson
URL:
Whiteboard:
: 1056585 (view as bug list)
Depends On: 1093128
Blocks: eap62-cp04-blockers 1093753 1159058
TreeView+ depends on / blocked
 
Reported: 2014-05-02 14:30 UTC by Stephen Fikes
Modified: 2019-09-12 07:52 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Previous releases of JBoss EAP 6 carried an issue that resulted in remote client transactions spanning multiple servers timing out earlier or later than expected. The issue arose because timeout values were not propagated across servers correctly, leaving the system to rely on the hardcoded timeout value (300 seconds) The hardcoded timeouts have been removed in this release and transactions now time out as and when expected.
Clone Of: 1093128
: 1093753 1159058 (view as bug list)
Environment:
Last Closed: 2014-08-07 12:12:17 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat One Jira Issue Tracker WFLY-2789 Major Closed Remote client transaction timeout values are overwrote by hardcoded values 2018-12-05 14:50:42 UTC

Description Stephen Fikes 2014-05-02 14:30:34 UTC
+++ This bug was initially created as a clone of Bug #1093128 +++

Description of problem:
See https://issues.jboss.org/browse/WFLY-2789

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Ivo Studensky 2014-05-27 08:47:26 UTC
PR sent:
https://github.com/jbossas/jboss-eap/pull/1368

Comment 2 Ivo Studensky 2014-05-27 08:52:43 UTC
An explanation of the fix can be seen here:
https://bugzilla.redhat.com/show_bug.cgi?id=1056585#c1

Comment 3 Brad Maxwell 2014-05-29 19:22:17 UTC
*** Bug 1056585 has been marked as a duplicate of this bug. ***

Comment 4 Jan Martiska 2014-06-17 12:15:55 UTC
Verified in 6.2.4.CR1.

Comment 5 Scott Mumford 2014-06-18 23:49:48 UTC
Copied release note text from bug 1093128.

Comment 6 Stephen Fikes 2017-02-13 18:33:57 UTC
The 300 second timeout was changed (as part of the work for this BZ) to INTEGER.MAX_VALUE [1] but this led to a further issue [2] resolved in current EAP 6.4 cumulative patches.

[1] https://github.com/wildfly/wildfly/pull/6186/files
[2] https://bugzilla.redhat.com/show_bug.cgi?id=1265300


Note You need to log in before you can comment on or make changes to this bug.