Bug 109393 - strange interaction between acpi / rhgb
strange interaction between acpi / rhgb
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Dave Jones
: 109505 (view as bug list)
Depends On:
  Show dependency treegraph
Reported: 2003-11-07 08:34 EST by Anderson Silva
Modified: 2015-01-04 17:03 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2004-09-29 15:35:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Anderson Silva 2003-11-07 08:34:38 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1) Opera 
7.21  [en]

Description of problem:
If I turn on acpi on grub, 6 out of 10 boots the X (gdm) envirnoment 
doesn't come up... somewhere along the boot (init) process the whole 
machine freezes up.

I tried adding: pci=noacpi on grub, still had the same problem, I 
tried apm=off, I tried turning off dpms on X, I tried even turning 
acpid off, but it computer would always freeze up.

If I turn acpi=off on grub the computer works like a charm. 

The weird thing is that it doesn't happen all the time, usually, 
after a freeze (with acpi on), the next reboot will work, and I can 
see my battery status working properly.

I had RH 9 running on kernel 2.4.22 for 3 weeks now, and never had a 
problem, so I know it is not something wrong with the Dell BIOS, 
which by the way is version A023

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.add acpi=on on grub.conf
3.and watch it freeze up

Actual Results:  computer freezes... I even try pinging it, but 
nothing happens, it is a complete lock up.

Expected Results:  X (gdm) should start

Additional info:

I am running a DELL Inspiron 5100, BIOS A023, with a PCMCIA DWL-650 
wireless network card, ATI Radeon Mobile 7500, 512 MB of RAM
Comment 1 Anderson Silva 2003-11-09 13:57:04 EST
I have done more work on this, and after recompiling the kernel that 
comes with Fedora 1 (2.4.22) with ACPI support in the kernel (not as a 
module). The system worked fine, but then I realized that I had to 
re-compile pcmcia-cs, I downloaded the the lastest source from 
sourceforge, and after compiling it and installing it... boom! The 
laptop started freezing up again.

So, whatever this problem is has to do with pcmcia-cs and acpi 
support. and like I said before, that worked fine on RH 9.
Comment 2 Anderson Silva 2003-11-11 08:41:57 EST
More information... this time I have some good news.

ACPI is working 10 out 10 right now with PCMCIA, but I had to turn 
off the rhgb (redhat boot screen)... for some reason that is 
affecting ACPI and making the laptop to freeze up.
Comment 3 Dave Jones 2003-11-20 14:37:36 EST
That's really bizarre, as rhgb isn't doing anything particularly special.
Comment 4 satya 2003-12-03 11:39:51 EST
I'm having the same problem on my Dell Latitude d600.
Laptop freezes in graphical startup, but not in text.
Only happens when acpi=on in grub.
Comment 5 satya 2003-12-07 19:30:05 EST
is this the same as Bug #109869 ?

if so, apparently, unplugging pcmcia cards during boot also
(temporarily) solves the problem.  I'ven't tried it yet, though.
Comment 6 Len Brown 2004-03-24 03:10:38 EST
does rhgb + acpi still hang when running an updated kernel, say FC2?
Comment 7 Anderson Silva 2004-03-24 06:12:12 EST
using fedora 1 with kernel 2.6... it did... not sure with FC2, 
waiting for final release.
Comment 8 Len Brown 2004-03-24 14:34:20 EST
how recent was the 2.6 kernel that still fails?
did removing the pcmcia card until after login help?
Comment 9 Anderson Silva 2004-03-24 14:43:53 EST
I understand that taking my pcmcia card solves the problem... but 
that is not a real solution. I can boot windows, red hat 9, or any 
other linux version with my pcmcia plugged... fedora shouldn't be any 

I ran kernel 2.6.0 and 2.6.1 - I have tried any new versions lately.
Comment 10 Anderson Silva 2004-03-24 14:44:46 EST
errata: I meant... I haveN'T tried any other new version.
Comment 11 Dave Jones 2004-06-18 19:00:38 EDT
*** Bug 109505 has been marked as a duplicate of this bug. ***
Comment 12 David Lawrence 2004-09-29 15:35:58 EDT
Thanks for the bug report. However, Red Hat no longer maintains this version of
the product. Please upgrade to the latest version and open a new bug if the problem

The Fedora Legacy project (http://fedoralegacy.org/) maintains some older releases, 
and if you believe this bug is interesting to them, please report the problem in
the bug tracker at: http://bugzilla.fedora.us/
Comment 13 Sergio Monteiro Basto 2004-09-29 17:18:38 EDT
> If I turn acpi=off on grub the computer works like a charm.

try "acpi=on nolapic" and see it if works like a charm.

if it yes , you are another apic victim, you have to disable local
apic seems linux and windows ?! work well without them 

Note You need to log in before you can comment on or make changes to this bug.