Bug 109452 - imap-devel packages not provided
imap-devel packages not provided
Status: CLOSED DUPLICATE of bug 101858
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: imap (Show other bugs)
i386 Linux
medium Severity low
: ---
: ---
Assigned To: John Dennis
Depends On:
  Show dependency treegraph
Reported: 2003-11-07 17:51 EST by Joseph Tate
Modified: 2007-11-30 17:06 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-02-21 13:59:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
php.spec minus unixODBC and imap, plus mcal (19.27 KB, text/plain)
2004-02-23 15:33 EST, Rich Graves
no flags Details

  None (edit)
Description Joseph Tate 2003-11-07 17:51:03 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5)
Gecko/20031007 Firebird/0.7

Description of problem:
imap-devel packages are provided neither on the RHN WS 3 channel, nor
on the installation CDs.  It can be built from the SRPM.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
Comment 1 dff 2003-12-15 16:02:45 EST

*** This bug has been marked as a duplicate of 101858 ***
Comment 2 Ryan Finnie 2004-02-16 06:25:06 EST
Sorry, I just have to put in my two cents here.  Please consider
supporting imap-devel in future releases.  Many people build their own
apache/php installations from source, and imap-devel is needed to
compile php with the --with-imap flag.  (Hey, that's how I arrived at
this bug report.)

Again, just a suggestion.
Comment 3 Rich Graves 2004-02-23 14:15:23 EST
Seconded. I can understand deprecating unixODBC and the like, but
imap-devel/c-client is embedded in loads of stuff.
Comment 4 John Dennis 2004-02-23 14:31:30 EST
Just as a heads up, those of you who are advocating for imap-devel to
be included by appending to this bug report you should be aware that
since this bug has been marked as a duplicate and closed your voices
may not be heard. Folks here tend not look at duplicate or closed bugs.

Don, I'm at a loss for why this is a duplicate of bug 101858, this
seems to be another matter altogether.
Comment 5 Rich Graves 2004-02-23 15:33:49 EST
Created attachment 97960 [details]
php.spec minus unixODBC and imap, plus mcal

If you just want to add a loadable php module, you can do it with something
like the attached, which removes imap and unixODBC support from the compile.

You will end up with a new php-mcal-4.3.2-8.ent.brandeis.i386.rpm that is
compatible with RedHat's base php package. I.e., just install php-mcal, and
keep using RedHat's compile of everything else (including imap and unixODBC).
Comment 6 Rich Graves 2004-02-23 16:40:27 EST
John, noted. Personally I do see the relevance of bug 101858. I'm glad
I know about that bug now because it provides a central place to look
for such things. Another place to look is

My later response and this is to help community members who stumble
across this the same way I did. I've often found workarounds in
bugzilla that RedHat support was unaware of.

I think a better answer to people with php extension problems is
mentioned in "php-devel is missing from the unified build tree," bug
id 109697. If people were allowed to compile individual PHP modules
without recompiling all of PHP, we'd never have reached this point.
Comment 7 Ryan Finnie 2004-02-23 18:49:23 EST
John: Thanks for the comment.  Where do you think we should take this
up; the taroon list perhaps?  Also, I see why Donald marked it a dupe
of the generic "Taroon isn't self-supporting" bug, but this discussion
has kinda moved it into a new realm.

rcgraves: I see where you are coming from, but I was interested in
compiling apache/php by hand (sorry, I've never really liked ANY
distro's default apache setup, so I prefer to do it myself), and
WANTED imap support.

My original point still stands, which rcgraves mentioned first: uwash
c-client (imap-devel) is used in a lot of places, and should really be
available on the CDs/RHN.
Comment 10 Red Hat Bugzilla 2006-02-21 13:59:50 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.