Bug 101858 - (TaroonRebuild) Packages do not necessarily rebuild on a full install
Packages do not necessarily rebuild on a full install
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: distribution (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: dff
:
: 101752 101797 101821 101828 101829 101970 107328 109452 109453 109494 111452 111651 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-08-07 14:41 EDT by Bill Nottingham
Modified: 2014-03-16 22:37 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-08-07 14:41:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill Nottingham 2003-08-07 14:41:24 EDT
Taroon isn't intended to be fully self-hosting in the packages shipped with it;
some of the -devel packages are removed  to limit ABI support liability (keep
customers/ISVs from using libraries that we don't want to live with forever).
Comment 1 Bill Nottingham 2003-08-07 16:03:22 EDT
*** Bug 101752 has been marked as a duplicate of this bug. ***
Comment 2 Bill Nottingham 2003-08-07 16:03:33 EDT
*** Bug 101828 has been marked as a duplicate of this bug. ***
Comment 3 Bill Nottingham 2003-08-07 16:04:44 EDT
*** Bug 101829 has been marked as a duplicate of this bug. ***
Comment 4 Bill Nottingham 2003-08-07 16:07:14 EDT
*** Bug 101821 has been marked as a duplicate of this bug. ***
Comment 5 Matt Wilson 2003-08-08 10:18:48 EDT
*** Bug 101970 has been marked as a duplicate of this bug. ***
Comment 6 Mike A. Harris 2003-08-12 06:15:50 EDT
*** Bug 101797 has been marked as a duplicate of this bug. ***
Comment 7 Bill Nottingham 2003-10-16 21:36:09 EDT
*** Bug 107328 has been marked as a duplicate of this bug. ***
Comment 8 dff 2003-12-15 16:02:47 EST
*** Bug 109452 has been marked as a duplicate of this bug. ***
Comment 9 dff 2003-12-15 16:03:39 EST
*** Bug 109453 has been marked as a duplicate of this bug. ***
Comment 10 dff 2003-12-15 16:04:06 EST
*** Bug 109494 has been marked as a duplicate of this bug. ***
Comment 11 dff 2003-12-15 16:04:46 EST
*** Bug 111452 has been marked as a duplicate of this bug. ***
Comment 12 dff 2003-12-15 16:05:32 EST
*** Bug 111651 has been marked as a duplicate of this bug. ***
Comment 13 wdc 2004-03-12 17:40:01 EST
While limiting ABI exposure is a reasonable principle, it is
disingenuous to say that's the reason why tcl and libwnck packages are
missing.

They're prerequisites for GNOME and Anaconda. I don't THINK the plan
is to desupport GNOME and Anaconda.

Many of these -devel packages BETTER get re-insterted QUICKLY, and an
OPEN and INFORMED review process of what gets removed needs to take
place to maintain Red Hat's credibility here.

-William Cattey
Comment 14 wdc 2004-06-09 16:56:20 EDT
Through out-of-band communication I learned that many dev packages
were getting added back into RHE.

Sure enough, Update 2 has many dev packages added back in.  The ones
that we care about are there.  I'm adding this comment in case others
find this bug and wonder what the final disposition was.

-wdc

Note You need to log in before you can comment on or make changes to this bug.