This service will be undergoing non-disruptive maintenance at 07:20 UTC, 2018-12-14. It is expected to last approximately 30 minutes
Bug 109478 - No schema for mail aliases (rfc822-MailMember.schema) present
Summary: No schema for mail aliases (rfc822-MailMember.schema) present
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: openldap (Show other bugs)
(Show other bugs)
Version: 1
Hardware: i386 Linux
medium
low
Target Milestone: ---
Assignee: Nalin Dahyabhai
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-11-08 10:29 UTC by Roel Gloudemans
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-12-19 16:42:05 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Roel Gloudemans 2003-11-08 10:29:30 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1)
Gecko/20031030

Description of problem:
On my RedHat 9 you could add mail aliases to the LDAP directory when
using LDAP for authentication etc.

When migrating the LDAP directory from RH9 to Fedora I ran into the
following problem:

The objectclass nisMailAlias and rfc822MailMember attribute are no
longer present. I had to take the rfc822-MailMember.schema file from
the /etc/openldap/schema/redhat directory of a RH9 box (and add it to
the slapd.conf file) to enable storage of mail aliases

(The PADL.com conversion scripts also fail)

Version-Release number of selected component (if applicable):
openldap-2.1.22-8

How reproducible:
Always

Steps to Reproduce:
1.slapcat of a LDAP directory containing mail aliases
2.slapadd of the LDIF file on a Fedora box
3.
    

Actual Results:  Error message

Expected Results:  No errors and a filled LDAP directory

Additional info:

Comment 1 Chan Min Wai 2003-12-19 16:21:15 UTC
I think this bug is similar to bug 109656.

Comment 2 Chan Min Wai 2003-12-19 16:23:15 UTC
Oop Sorry
According to changelog
* Sat Sep 13 2003 Nalin Dahyabhai <nalin@redhat.com> 2.1.22-6
  - drop rfc822-MailMember.schema, merged into upstream misc.schema at
some point

So this might be the solution.

Comment 3 Roel Gloudemans 2003-12-19 16:42:05 UTC
You're right. Adding 

include /etc/openldap/schema/misc.schema

to slapd.conf 

also solves the problem. Question is if this should be done by default
(or at least included in the docs)

Comment 4 Paul Gear 2004-01-01 22:43:34 UTC
Add my vote for making this the default, since it preserves
compatibility with previous behaviour.


Note You need to log in before you can comment on or make changes to this bug.