Bug 1094986 - Content: Should not be able to try and sync a repo with no repourl
Summary: Content: Should not be able to try and sync a repo with no repourl
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Content Management
Version: 6.0.3
Hardware: Unspecified
OS: Unspecified
unspecified
medium vote
Target Milestone: Unspecified
Assignee: Partha Aji
QA Contact: Kedar Bidarkar
URL: http://projects.theforeman.org/issues...
Whiteboard:
: 1120595 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-05-06 20:50 UTC by Corey Welton
Modified: 2019-09-26 14:31 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-09-11 12:25:06 UTC


Attachments (Terms of Use)
sync now button is greyed when no feed exists. (51.68 KB, image/png)
2014-08-11 14:07 UTC, Kedar Bidarkar
no flags Details


Links
System ID Priority Status Summary Last Updated
Foreman Issue Tracker 6651 None None None 2016-04-22 15:33:39 UTC

Description Corey Welton 2014-05-06 20:50:09 UTC
Description of problem:
User can create a product repo that contains no repourl.  When user attempts to save this, save is successful, and subsequent attempts to sync produce an error.  We should either disallow creation of repo w/o url, or disable sync on such repos.

Version-Release number of selected component (if applicable):

Satellite-6.0.3-RHEL-6-20140430.4
How reproducible:


Steps to Reproduce:
1.  Create a product, "testproduct"
2.  Attempt to create a repo within "testproduct", called "testrepo"  do NOT provide a repourl
3.  Attempt to sync.

Actual results:
Error in UI

Expected results:
We shouldn't let users save incomplete repos OR
We should disable sync button on repos that are obviously incomplete.

Additional info:

Comment 2 Corey Welton 2014-05-07 01:01:56 UTC
[16:51] < jsherrill> cswiii: regarding  https://bugzilla.redhat.com/show_bug.cgi?id=1086355, a repo with no feed makes perfect sense when uploading rpms or puppet modules directly
[16:51] < jsherrill> cswiii: however you are correct, you shouldn't be able to try to sync it

Comment 3 Brad Buckingham 2014-06-25 14:22:16 UTC
The solution for this issue should probably address multiple levels:
- server-side denial
- ui buttons disabled/hidden on product/repo pgs

Note, sync management page currently doesn't show feedless repos (as desired).

Comment 4 Partha Aji 2014-07-16 19:42:02 UTC
Created redmine issue http://projects.theforeman.org/issues/6651 from this bug

Comment 5 Bryan Kearney 2014-07-24 20:01:59 UTC
Moving to POST since upstream bug http://projects.theforeman.org/issues/6651 has been closed
-------------
Partha Aji
Applied in changeset commit:katello|a06bb95372c64468af5101b3b3d67ec2630b283b.

Comment 7 Kedar Bidarkar 2014-08-11 14:07:08 UTC
Created attachment 925761 [details]
sync now button is greyed when no feed exists.

Comment 8 Kedar Bidarkar 2014-08-11 14:09:52 UTC
Tested with sat6-GA-snap4.

Now we no longer can sync repos with no feed-url as the sync button is now greyed, until we add a feed-url.

Comment 9 Kedar Bidarkar 2014-08-11 14:13:32 UTC
Just realized, about another scenario, where in 

a) after creating a repo without a feed-url, if we move to the products page and then sync.

b) In that case it still appears like we are allowing sync of repos without feed-url.

I think the best thing would be not to allow, the users to save incomplete repos.

Comment 12 Brad Buckingham 2014-09-05 12:59:48 UTC
*** Bug 1120595 has been marked as a duplicate of this bug. ***

Comment 13 Bryan Kearney 2014-09-11 12:25:06 UTC
This was delivered with Satellite 6.0 which was released on 10 September 2014.


Note You need to log in before you can comment on or make changes to this bug.