Bug 1095081 - Reinstalling rhevh7.0 hang on disk partitioning and creating file system
Summary: Reinstalling rhevh7.0 hang on disk partitioning and creating file system
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-node
Version: 3.5.0
Hardware: Unspecified
OS: Unspecified
urgent
high
Target Milestone: ---
: 3.5.0
Assignee: Ryan Barry
QA Contact: Virtualization Bugs
URL:
Whiteboard: node
: 1136300 1136313 (view as bug list)
Depends On: rebase-ovirt-node-3.1
Blocks: rhevh-7.0 rhev35betablocker rhev35rcblocker rhev35gablocker
TreeView+ depends on / blocked
 
Reported: 2014-05-07 05:42 UTC by haiyang,dong
Modified: 2016-02-10 20:08 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-02-11 20:56:29 UTC
oVirt Team: Node


Attachments (Terms of Use)
attached Screenshot for Installing RHEV-H (8.38 KB, image/png)
2014-05-07 05:42 UTC, haiyang,dong
no flags Details
attached Screenshot for auto install hang on (13.87 KB, image/png)
2014-05-07 05:44 UTC, haiyang,dong
no flags Details
screenshot for installing rhevh7 (6.29 KB, application/octet-stream)
2014-09-05 03:15 UTC, haiyang,dong
no flags Details
attached ovirt-node.log (5.34 KB, text/plain)
2014-09-05 09:29 UTC, haiyang,dong
no flags Details
attached ovirt.log (1.20 KB, text/plain)
2014-09-05 09:30 UTC, haiyang,dong
no flags Details
attached ovirt.log of rhev-hypervisor7-7.0-20140918.0.iso (1.62 KB, text/plain)
2014-09-19 11:32 UTC, haiyang,dong
no flags Details
attached ovirt-node.log of rhev-hypervisor7-7.0-20140918.0.iso (5.49 KB, text/plain)
2014-09-19 11:33 UTC, haiyang,dong
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2015:0160 normal SHIPPED_LIVE ovirt-node bug fix and enhancement update 2015-02-12 01:34:52 UTC
oVirt gerrit 31544 master MERGED Fix the installer for EL7 and general logic changes Never
oVirt gerrit 32534 master MERGED Revert logic changes in ovirt-functions.in Never
oVirt gerrit 33088 master MERGED Unmount partitions before we mkfs them Never

Description haiyang,dong 2014-05-07 05:42:12 UTC
Created attachment 893102 [details]
attached Screenshot for Installing RHEV-H

Description of problem:
Installing rhevh7 hang on (2/5) Partitioning and Creating File System on progress page.
(Seen Installing RHEV-H.png)


Version-Release number of selected component (if applicable):
rhevh-7.0-20140424.0.iso 
ovirt-node-3.1.0-0.2.20140424gitbfdfc00.el7


How reproducible:
100%

Steps to Reproduce:


Actual results:

Expected results:

Additional info:

Comment 1 haiyang,dong 2014-05-07 05:44:29 UTC
Created attachment 893103 [details]
attached Screenshot for auto install hang on

Also auto install hang on (1/7) Performing automatic disk partitioning.(seen auto install hang on.png)

Comment 3 Fabian Deutsch 2014-05-21 07:13:11 UTC
Hey,

could you please provide more informations about the hardware.
Especially the number of drives available, bus type, and the selected devices?

Please also provide the common RHEV- logfiles.

Comment 4 haiyang,dong 2014-05-21 07:44:50 UTC
(In reply to Fabian Deutsch from comment #3)
> Hey,
> 
> could you please provide more informations about the hardware.
> Especially the number of drives available, bus type, and the selected
> devices?
Hey Fabian,

You should reproduce this issue easily, not only could reproduce in special 
hardware env.

> 
> Please also provide the common RHEV- logfiles.
Also due to the system was hang Partitioning and Creating File System on progress page,  so i couldn't get logfiles from system for you.
Sorry.

Comment 5 Fabian Deutsch 2014-05-21 11:37:12 UTC
(In reply to haiyang,dong from comment #4)
> (In reply to Fabian Deutsch from comment #3)
> > Hey,
> > 
> > could you please provide more informations about the hardware.
> > Especially the number of drives available, bus type, and the selected
> > devices?
> Hey Fabian,
> 
> You should reproduce this issue easily, not only could reproduce in special 
> hardware env.

That is actually my problem. I can not reproduce this in my VM setups.
Otherwise I'd have noticed it during smoke testing.

So please provide some more details on what kind of VM etc was used.

Comment 6 haiyang,dong 2014-05-23 02:07:34 UTC
(In reply to Fabian Deutsch from comment #5)

> 
> That is actually my problem. I can not reproduce this in my VM setups.
> Otherwise I'd have noticed it during smoke testing.
> 
> So please provide some more details on what kind of VM etc was used.

Hey Fabian,

I know the reason why you couldn't reproduce this bug.this is due to you use clean disk to install rhevh7

Please do the follow steps to reproduce it:
1. Clean install rhevh-7.0-20140424.0.iso 
2. After clean install rhevh7 success, then select "Reinstall.." to install 
it again.

After 2, you should meet this issue in progress_page

Comment 7 Fabian Deutsch 2014-05-23 09:39:02 UTC
Hey Haiyang,

ah - Its about reinstallation. Thanks for this.

Comment 8 haiyang,dong 2014-09-05 03:15:53 UTC
Created attachment 934662 [details]
screenshot for installing rhevh7

Test version:
rhev-hypervisor7-7.0-20140904.0.el7ev
ovirt-node-3.1.0-0.10.20140904gitb828c37.el7.noarch

Reinstalling rhevh7.0 failed to set install bootloader.(Seen Screenshot for installing rhevh7.png)

so need to re-assigned it again.

Comment 9 haiyang,dong 2014-09-05 03:42:29 UTC
(In reply to haiyang,dong from comment #8)
> Created attachment 934662 [details]
> screenshot for installing rhevh7
> 
> Test version:
> rhev-hypervisor7-7.0-20140904.0.el7ev
> ovirt-node-3.1.0-0.10.20140904gitb828c37.el7.noarch
> 
> Reinstalling rhevh7.0 failed to set install bootloader.(Seen Screenshot for
> installing rhevh7.png)
> 
> so need to re-assigned it again.

add Steps to Reproduce in here:
1. clean install rhev-hypervisor7-7.0-20140904.0.el7ev -success
2. Reinstall rhev-hypervisor7-7.0-20140904.0.el7ev - Failed to set install bootloader.(Seen Screenshot for installing rhevh7.png)
3. after reinstall rhevh7.0 failed to set install bootloader.Then
Reinstall rhev-hypervisor7-7.0-20140904.0.el7ev again - success.

Due to it failed in step2, so this bug didn't fix thoroughly.

Comment 10 Fabian Deutsch 2014-09-05 09:19:25 UTC
Dong, could you please attach /var/log/ovirt.log and /var/log/ovirt-node.log?

Comment 11 haiyang,dong 2014-09-05 09:29:44 UTC
Created attachment 934721 [details]
attached ovirt-node.log

Comment 12 haiyang,dong 2014-09-05 09:30:19 UTC
Created attachment 934723 [details]
attached ovirt.log

Comment 14 haiyang,dong 2014-09-19 06:20:24 UTC
Test version:
rhev-hypervisor7-7.0-20140918.0.iso(this 3.4.z build uses the ovirt-node codebase for 3.5)
ovirt-node-3.1.0-0.13.20140918gitdda78cb.el7.noarch

Reinstall rhev-hypervisor7-7.0-20140918.0.iso via cdrom:
1. clean install rhev-hypervisor7-7.0-20140918.0.iso -success
2. Reinstall rhev-hypervisor7-7.0-20140918.0.iso  - success


Reinstall rhev-hypervisor7-7.0-20140918.0.iso via pxe:
1. clean install rhev-hypervisor7-7.0-20140918.0.iso -success
2. Reinstall rhev-hypervisor7-7.0-20140918.0.iso - Failed to set install bootloader.
3. after reinstall rhevh7.0 failed to set install bootloader.Then
Reinstall rhev-hypervisor7-7.0-20140918.0.iso again - success.

due to still failed in step2 via pxe,so this bug didn't fix thoroughly.
so need to re-assigned it again.

Comment 15 haiyang,dong 2014-09-19 11:32:53 UTC
Created attachment 939232 [details]
attached ovirt.log of rhev-hypervisor7-7.0-20140918.0.iso

Comment 16 haiyang,dong 2014-09-19 11:33:22 UTC
Created attachment 939234 [details]
attached ovirt-node.log of rhev-hypervisor7-7.0-20140918.0.iso

Comment 17 Ryan Barry 2014-09-19 12:48:28 UTC
I'm not around an environment where I can text PXE today, but this appears to be a different bug.

Can I please see the output of '/proc/mounts |grep live' when you pxeboot to reinstall?

Comment 18 Ying Cui 2014-09-29 03:59:47 UTC
(In reply to Ryan Barry from comment #17)
> I'm not around an environment where I can text PXE today, but this appears
> to be a different bug.
> 
> Can I please see the output of '/proc/mounts |grep live' when you pxeboot to
> reinstall?

# cat /proc/mounts |grep liv
/dev/loop0 /run/initramfs/live iso9660 ro,relatime 0 0
/dev/mapper/live-rw / ext2 ro,seclabel,noatime 0 0
/dev/loop0 /dev/.initramfs/live iso9660 ro,relatime 0 0
/dev/loop0 /live iso9660 ro,relatime 0 0
/dev/mapper/TOSHIBA_DT01ACA100_33A7V28MS3 /liveos ext2 rw,seclabel,relatime,stripe=4 0 0

but this issue in comment 14 is fixed in build rhev-hypervisor7-7.0-20140926.0.iso - ovirt-node-3.1.0-0.17.20140925git29c3403.el7.noarch yet.

Here for reinstall, reinstall process is completed successful, but there is another issue after reinstall, see bug #1147217, so I am blocking to verify this bug because I can not check vgs after reinstall.

Comment 20 Fabian Deutsch 2014-09-30 11:38:57 UTC
*** Bug 1136300 has been marked as a duplicate of this bug. ***

Comment 21 Fabian Deutsch 2014-09-30 11:39:00 UTC
*** Bug 1136313 has been marked as a duplicate of this bug. ***

Comment 22 haiyang,dong 2014-10-08 12:24:00 UTC
Test version:
rhev-hypervisor7-7.0-20141006.0.el7ev.noarch
ovirt-node-3.1.0-0.20.20141006gitc421e04.el7.noarch

Test result:
1. Reinstall rhev-hypervisor7-7.0-20141006.0.el7ev via cdrom -Pass
2. Reinstall rhev-hypervisor7-7.0-20141006.0.el7ev via pxe -Pass

so this bug has been fixed, change the status into "VERIFIED".

Comment 25 errata-xmlrpc 2015-02-11 20:56:29 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2015-0160.html


Note You need to log in before you can comment on or make changes to this bug.