Bug 109515 - Difficulties with 2 Soundcards
Difficulties with 2 Soundcards
Status: CLOSED DUPLICATE of bug 115198
Product: Fedora
Classification: Fedora
Component: kudzu (Show other bugs)
1
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
David Lawrence
:
Depends On: 115198
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-08 16:46 EST by Harald Glatt
Modified: 2014-03-16 22:40 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:59:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Output from lspci (2.02 KB, text/plain)
2003-11-08 16:52 EST, Harald Glatt
no flags Details
Output from dmesg (10.55 KB, text/plain)
2003-11-08 16:53 EST, Harald Glatt
no flags Details
Output from cat /etc/modules.conf (704 bytes, text/plain)
2003-11-10 12:08 EST, Harald Glatt
no flags Details
Output from cat /etc/modules.conf (the new file) (509 bytes, text/plain)
2003-11-10 14:40 EST, Harald Glatt
no flags Details

  None (edit)
Description Harald Glatt 2003-11-08 16:46:08 EST
I am having difficulties using 2 soundcards...

One of them is a NVIDIA Onboard NForce 2 Audio and the other one is a
PCI Creative Soundblaster Audigy 2 ZS...

Kudzu detected 2 Soundcards and added them to /etc/sysconfig/hwconf
but no audio driver is being loaded.

When I manually modprobe i810_audio (for the nvidia card) or modprobe
audigy (for the creative) it works perfect - it's just not getting
loaded by default for some strange reason...

Also the redhat-config-soundcard program doesn`t work... It crashes
upon startup with this information:

--- kudzu crash message ---
Traceback (most recent call last):
  File
"/usr/share/redhat-config-soundcard/redhat-config-soundcard.py", line
44, in ?
    app = soundcard.childWindow()
  File "/usr/share/redhat-config-soundcard/soundcard.py", line 162, in
__init__
   
self.primaryDeviceMenu.set_active(self.cardList.index(self.soundcardBackend.getDefaultCard()))
ValueError: list.index(x): x not in list
--- kudzu crash message end ---


Here are the AUDIO specific sections from the /etc/sysconfig/hwconf file:

--- /etc/sysconfig/hwconf AUDIO stuff ---
class: AUDIO
bus: PCI
detached: 0
driver: unknown
desc: "nVidia Corporation|nForce MultiMedia audio [Via VT82C686B]"
vendorId: 10de
deviceId: 006b
subVendorId: 1043
subDeviceId: 0c11
pciType: 1
pcibus:  0
pcidev:  5
pcifn:  0
-
class: AUDIO
bus: PCI
detached: 0
driver: i810_audio
desc: "nVidia Corporation|nForce2 AC97 Audio Controler (MCP)"
vendorId: 10de
deviceId: 006a
subVendorId: 1043
subDeviceId: 8095
pciType: 1
pcibus:  0
pcidev:  6
pcifn:  0
-
class: AUDIO
bus: PCI
detached: 0
driver: audigy
desc: "Creative Labs|SB Audigy"
vendorId: 1102
deviceId: 0004
subVendorId: 1102
subDeviceId: 2002
pciType: 1
pcibus:  1
pcidev:  8
pcifn:  0
--- /etc/sysconfig/hwconf AUDIO stuff end---

I do not know for sure why the audio drivers aren't started up at
bootup and why the redhat-config-soundcard doesn't work... I'm not
sure whether this bug is due to kudzu... 

This is a fresh Fedora Core 1 (Yarrow) install... (about 1 hour old)

If something isn't clear or I should post more log files or something
just tell me, I'll provide any info I can ;)

Version-Release number of selected component (if applicable):
kudzu-1.1.36-1
Comment 1 Harald Glatt 2003-11-08 16:52:05 EST
Created attachment 95834 [details]
Output from lspci
Comment 2 Harald Glatt 2003-11-08 16:53:25 EST
Created attachment 95835 [details]
Output from dmesg
Comment 3 Harald Glatt 2003-11-08 16:53:50 EST
uname -a Output:

Linux hachre 2.4.22-1.2115.nptl #1 Wed Oct 29 15:31:21 EST 2003 i686
athlon i386 GNU/Linux

Comment 4 Bill Nottingham 2003-11-10 11:55:12 EST
What's your /etc/modules.conf look like?
Comment 5 Harald Glatt 2003-11-10 12:08:54 EST
Created attachment 95880 [details]
Output from cat /etc/modules.conf
Comment 6 Bill Nottingham 2003-11-10 14:27:09 EST
If you change the aliases from sound-slot-{1,2,3} to
sound-slot-{0,1,2} do things behave more sanely?
Comment 7 Harald Glatt 2003-11-10 14:40:06 EST
Wow, this fixed the issue...

The modules for both soundcards are beeing loaded at startup now and
the redhat-config-sound works flawless now!!

I changed /etc/modules.conf like you told me to...
Afterwards I rebooted and started redhat-config-sound when the system
was back up...
It detected both soundcards and seems to have changed the
/etc/modules.conf again. It dropped the 3rd sound card... I will do a
new attachment in a few secs after this post...

Everything works ok now, but which program did the fault to name those
devices wrong in the /etc/modules.conf during install?
Comment 8 Harald Glatt 2003-11-10 14:40:48 EST
Created attachment 95885 [details]
Output from cat /etc/modules.conf (the new file)
Comment 9 Bill Nottingham 2003-11-10 15:55:58 EST
The last entry (sound-slot-2/3) is for a USB audio device, FWIW.
If it's not attached, it won't get written.

It's probably a kudzu bug somewhere that sound-slot-0 was skipped.
Comment 10 Harald Glatt 2003-11-10 16:02:39 EST
Strange thing, well at least its fixed for me now...
Comment 11 Peter Backlund 2004-03-09 18:09:24 EST
Dupe of 115198
Comment 12 Toni Willberg 2004-03-09 18:15:59 EST
The bug is actually in system-config-soundcard, the component should
be changed. 

I set this depending on 115198 which describes the actualy bug.
Comment 13 Bill Nottingham 2004-03-09 22:28:07 EST

*** This bug has been marked as a duplicate of 115198 ***
Comment 14 Red Hat Bugzilla 2006-02-21 13:59:52 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.