Bug 115198 - redhat-config-soundcard crash when launched. two soundcards
redhat-config-soundcard crash when launched. two soundcards
Status: CLOSED DUPLICATE of bug 81843
Product: Fedora
Classification: Fedora
Component: redhat-config-soundcard (Show other bugs)
1
All Linux
medium Severity high
: ---
: ---
Assigned To: Bastien Nocera
:
: 109515 116518 117910 (view as bug list)
Depends On:
Blocks: 109515
  Show dependency treegraph
 
Reported: 2004-02-08 10:02 EST by Patrice Dumas
Modified: 2007-11-30 17:10 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:01:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Patrice Dumas 2004-02-08 10:02:59 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; fr; rv:1.4.1) Gecko/20031114

Description of problem:
When calling redhat-config-soundcard it crashes. I have two
soundcards. A soundblaster live! and a chipset integrated on the
mother board (a SIS). I want to use the sblive!. When kudzu detected
the sis chipset I chosed to ignore it, and I also chosed to configure
the sb live!. 

As this may be related, I report a problem with sound: My soundcard
doesn't work at boot. I have these lines in /var/log/messages:
Feb  8 15:47:42 localhost modprobe: modprobe: Can't locate module
sound-slot-0
Feb  8 15:47:42 localhost modprobe: modprobe: Can't locate module
sound-service-0-3
After I have done, as root, a 
[root@localhost root]# modprobe emu10k1
The sound works.

Now I show my modules, the lspci output and then the command output.

[root@localhost root]# cat /etc/modules.conf
alias sound-slot-1 emu10k1
post-install sound-slot-1 /bin/aumix-minimal -f /etc/.aumixrc -L
>/dev/null 2>&1 || :
pre-remove sound-slot-1 /bin/aumix-minimal -f /etc/.aumixrc -S
>/dev/null 2>&1 || :
alias usb-controller usb-ohci

[root@localhost root]# lspci
00:00.0 Host bridge: Silicon Integrated Systems [SiS] 735 Host (rev 01)
00:01.0 PCI bridge: Silicon Integrated Systems [SiS] SiS 530 Virtual
PCI-to-PCI bridge (AGP)
00:02.0 ISA bridge: Silicon Integrated Systems [SiS] 85C503/5513
00:02.2 USB Controller: Silicon Integrated Systems [SiS] USB 1.0
Controller (rev 07)
00:02.3 USB Controller: Silicon Integrated Systems [SiS] USB 1.0
Controller (rev 07)
00:02.5 IDE interface: Silicon Integrated Systems [SiS] 5513 [IDE]
(rev d0)
00:02.7 Multimedia audio controller: Silicon Integrated Systems [SiS]
Sound Controller (rev a0)
00:0d.0 Multimedia audio controller: Creative Labs SB Live! EMU10k1
(rev 06)
00:0d.1 Input device controller: Creative Labs SB Live! MIDI/Game Port
(rev 06)
00:11.0 Communication controller: PCTel Inc HSP MicroModem 56 (rev 01)
01:00.0 VGA compatible controller: nVidia Corporation NV5 [RIVA
TNT2/TNT2 Pro] (rev 11)

[root@localhost root]# redhat-config-soundcard 
Traceback (most recent call last):
  File
"/usr/share/redhat-config-soundcard/redhat-config-soundcard.py", line
44, in ?
    app = soundcard.childWindow()
  File "/usr/share/redhat-config-soundcard/soundcard.py", line 162, in
__init__
   
self.primaryDeviceMenu.set_active(self.cardList.index(self.soundcardBackend.getDefaultCard()))
ValueError: list.index(x): x not in list

I have similar lines in /var/log/messages. It seems that the soundcard
is also tested at boot and it fails alike.
Hope it is enough info.

Pat

Version-Release number of selected component (if applicable):
redhat-config-soundcard-1.0.8-2

How reproducible:
Always

Steps to Reproduce:
1. as root, launch redhat-config-soundcard
2.
3.
    

Actual Results:  [root@localhost root]# redhat-config-soundcard
Traceback (most recent call last):
  File
"/usr/share/redhat-config-soundcard/redhat-config-soundcard.py", line
44, in ?
    app = soundcard.childWindow()
  File "/usr/share/redhat-config-soundcard/soundcard.py", line 162, in
__init__
   
self.primaryDeviceMenu.set_active(self.cardList.index(self.soundcardBackend.getDefaultCard()))
ValueError: list.index(x): x not in list


Expected Results:  Something else with a gui to configure my soundcard.

Additional info:
Comment 1 Christoph Wickert 2004-02-09 16:48:14 EST
Exactly the same behavior here.
I have 2 soundcards: Intel i810 onboard and working fine and
Soundblaster live! 5.1. (emu10k1).

I have been using 2 soundcards before (2nd was a Soundblaster 128 PCI)
and everything worked fine, so I think this Problem is related to the
emu10k1 chipset(?).

# lspci
00:00.0 Host bridge: Silicon Integrated Systems [SiS] 735 Host (rev 01)
00:01.0 PCI bridge: Silicon Integrated Systems [SiS] SiS 530 Virtual
PCI-to-PCI bridge (AGP)
00:02.0 ISA bridge: Silicon Integrated Systems [SiS] 85C503/5513
00:02.2 USB Controller: Silicon Integrated Systems [SiS] USB 1.0
Controller (rev 07)
00:02.3 USB Controller: Silicon Integrated Systems [SiS] USB 1.0
Controller (rev 07)
00:02.5 IDE interface: Silicon Integrated Systems [SiS] 5513 [IDE]
(rev d0)
00:02.7 Multimedia audio controller: Silicon Integrated Systems [SiS]
Sound Controller (rev a0)
00:09.0 Ethernet controller: Realtek Semiconductor Co., Ltd.
RTL-8139/8139C/8139C+ (rev 10)
00:0b.0 Network controller: AVM Audiovisuelles MKTG & Computer System
GmbH A1 ISDN [Fritz] (rev 02)
00:0d.0 Multimedia audio controller: Creative Labs SB Live! EMU10k1
(rev 07)
00:0d.1 Input device controller: Creative Labs SB Live! MIDI/Game Port
(rev 07)
00:11.0 Multimedia video controller: Brooktree Corporation Bt848 Video
Capture (rev 12)
01:00.0 VGA compatible controller: nVidia Corporation NV5 [RIVA
TNT2/TNT2 Pro] (rev 15)
Comment 2 Patrice Dumas 2004-02-20 03:53:16 EST
This seems to be fixed in fedora core 2 test I just tried.
Comment 3 Brent Fox 2004-02-20 11:04:30 EST
Patrice: Hmm, ok.  I don't recall fixing that, but if it's working
now, I'm not going to complain.  Please reopen this bug if you see
this happen again on FC2.
Comment 4 Peter Backlund 2004-02-25 04:21:45 EST
I've seen this happen on FC2 test1, with this setup:

[root@h152n2fls33o1121 root]# lspci |grep audio
0000:00:05.0 Multimedia audio controller: C-Media Electronics Inc
CM8738 (rev 10)
0000:00:0d.0 Multimedia audio controller: Ensoniq ES1371 [AudioPCI-97]
(rev 08)

(The C-Media card is onboard)

I've traced the python source back to what I believe is the error: in
system-config-soundcard/soundcardBackend.py, getDefaultCard() on line
136, self.cardList is traversed until module == deafultModule. The
value of deafultModule is read from modprobe.conf, and if there is no
defaultModule, None is returned. This causes the error when trying to
read index of None in system-config-soundcard/soundcard.py. So, I
suppose Anaconda has failed to populate modprobe.conf at installation
time? One workaround, which would be good practice in any case, is to
add the line 

return self.cardList[0]

at the end of getDefaultModule(), so that if the for-loop ends without
finding a match, whatever module is first in the list is returned,
instead of None.
Comment 5 Toni Willberg 2004-03-09 18:09:33 EST
*** Bug 117910 has been marked as a duplicate of this bug. ***
Comment 6 Toni Willberg 2004-03-09 18:13:00 EST
lspci |grep audio

00:05.0 Multimedia audio controller: C-Media Electronics Inc CM8738
(rev 10)
00:0b.0 Multimedia audio controller: Ensoniq 5880 AudioPCI (rev 02)


I debugged a little, seems that self.soundcardBackend.getDefaultCard()
returns "None" for me.

This system is a upgrade, perhaps something got messed while upgrading.
Comment 7 Bill Nottingham 2004-03-09 22:28:10 EST
*** Bug 109515 has been marked as a duplicate of this bug. ***
Comment 8 Brent Fox 2004-03-11 15:58:57 EST
Should be fixed with system-config-soundcard-1.2.7-3 in Rawhide.
Comment 9 Brent Fox 2004-03-11 15:59:15 EST
*** Bug 116518 has been marked as a duplicate of this bug. ***
Comment 10 Daniel Jensen 2004-07-24 20:59:47 EDT
Not fixed, I've had this problem in FC2. I had to remove all mention
of my integrated audio from hwconf and modprobe.conf for
system-config-soundcard (1.2.8-1) to work with my Audigy.
Comment 11 Patrice Dumas 2004-08-16 18:21:32 EDT
With system-config-soundcard-1.2.8-1, on a fedora core development
updated from a fedora core 1 I have this issue. Still with
[root@chapelle ~]# lspci | grep audio
00:02.7 Multimedia audio controller: Silicon Integrated Systems [SiS]
Sound Controller (rev a0)
00:0d.0 Multimedia audio controller: Creative Labs SB Live! EMU10k1
(rev 06)

After I add the line 
alias sound-slot-0 snd-emu10k1
in my /etc/modprobe.conf there no crash anymore.

I reopen the bug, but maybe it should be opened for
system-config-soundcard
Comment 12 Bastien Nocera 2004-09-19 09:15:12 EDT

*** This bug has been marked as a duplicate of 81843 ***
Comment 13 Red Hat Bugzilla 2006-02-21 14:01:08 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.