Bug 109517 - <linux/timex.h> has a syntax error
Summary: <linux/timex.h> has a syntax error
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: glibc-kernheaders
Version: 1
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact:
URL:
Whiteboard:
: 110085 (view as bug list)
Depends On:
Blocks: FC3BugWeekTracker
TreeView+ depends on / blocked
 
Reported: 2003-11-08 22:29 UTC by Jeremy Fitzhardinge
Modified: 2007-11-30 22:10 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2004-09-29 18:37:18 UTC
Type: ---


Attachments (Terms of Use)
Fixes missing start of comment line (432 bytes, patch)
2004-06-10 14:56 UTC, Tarjei Knapstad
no flags Details | Diff

Description Jeremy Fitzhardinge 2003-11-08 22:29:15 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1)
Gecko/20031030

Description of problem:
/usr/include/linux/timex.h has a missing /* on line 56 - the comment just
starts without a comment-start delimiter.  This causes a syntax error
for anything using this header.

Version-Release number of selected component (if applicable):
glibc-kernheaders-2.4-8.36

How reproducible:
Always

Steps to Reproduce:
1.compile something with #include <linux/timex.h>
2.
3.
    

Actual Results:  Syntax error:
/usr/include/linux/timex.h:56: error: syntax error before "and"


Expected Results:  Correct compilation.

Additional info:

Comment 1 Dimitri Papadopoulos 2003-12-17 18:07:01 UTC
Valgrind 2.1.0 doesn't compile on Fedora Core 1 because of this bug.

Comment 2 Matt Phillips 2004-01-12 17:41:47 UTC
+1 
Chronyd also doesn't compile on FC1 because of this bug... 

Comment 3 Bryce 2004-02-16 19:50:17 UTC
Why is this bug still open? Thats 2 months for a typo in a header
file. (missing '/' for the comment field) While the fix is trivial,
I'm surprised no one has squashed this.

This was originally in glibc-kernheaders-2.4-8.36 (arjan)
That package is now know as glibc-headers-2.3.2-101.4 (jakub)

Please reassign to Jakub. (jakub@redhat.com)

Cheers

Phil (aka Bryce)
=--=


Comment 4 Aleksey Nogin 2004-02-25 06:25:59 UTC
*** Bug 110085 has been marked as a duplicate of this bug. ***

Comment 5 Aleksey Nogin 2004-02-25 06:27:44 UTC
This seems to be fixed in glibc-kernheaders-2.4-8.43 (Raw Hide).

Comment 6 Philippe Rigault 2004-05-26 19:58:20 UTC
> This was originally in glibc-kernheaders-2.4-8.36 (arjan) 
> That package is now know as glibc-headers-2.3.2-101.4 (jakub) 
 
This is not so clear to me. Could you clarify ? 
 
The incorrect file is /usr/include/linux/timex.h and belongs to 
glibc-kernheaders: 
  $ rpm -qf /usr/include/linux/timex.h 
  glibc-kernheaders-2.4-8.36 
 
There is another timex.h file in /usr/include/sys that belongs to 
glibc-headers: 
  # rpm -qf /usr/include/sys/timex.h 
  glibc-headers-2.3.2-101.4 
but these are very different files, and there is noyhing wrong with 
the latter. 
 
Moreover, glibc-kernheaders are needed by glibc-headers. 
  $ rpm -e --test glibc-kernheaders 
  error: Failed dependencies: 
        kernel-headers is needed by (installed) 
glibc-headers-2.3.2-101.4 
        kernel-headers >= 2.2.1 is needed by (installed) 
glibc-headers-2.3.2-101.4 
 
 
 

Comment 7 Tarjei Knapstad 2004-06-10 14:56:38 UTC
Created attachment 101030 [details]
Fixes missing start of comment line

Comment 8 Tarjei Knapstad 2004-06-10 14:59:35 UTC
[Argh, forgot to add my comment, sorry.]

Well, this is getting really old. Time to patch it and spin an update
glibc-kernheaders package I think.

Comment 9 Marcin Garski 2004-09-29 18:37:18 UTC
Thanks for the bug report.
This bug doesn't seem to be present any more in current versions.


Note You need to log in before you can comment on or make changes to this bug.