Bug 1095332 - Repo sync progress do not go to 100% for rpm download when rpms are overlapping with an already synced repo
Summary: Repo sync progress do not go to 100% for rpm download when rpms are overlappi...
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Pulp
Classification: Retired
Component: rpm-support   
(Show other bugs)
Version: 2.4 Beta
Hardware: Unspecified Unspecified
medium
low
Target Milestone: ---
: 2.4.0
Assignee: Sayli Karmarkar
QA Contact: Preethi Thomas
URL:
Whiteboard:
Keywords: Triaged
: 1098264 (view as bug list)
Depends On:
Blocks: 950743
TreeView+ depends on / blocked
 
Reported: 2014-05-07 13:26 UTC by Preethi Thomas
Modified: 2015-03-23 01:12 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-09 06:54:54 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Preethi Thomas 2014-05-07 13:26:12 UTC
Description of problem:

If you have synced a repo and syncing a 2nd repo that has overlapping packages with the first repo, then the progress for rpm never gets to 100%

Version-Release number of selected component (if applicable):
[root@ibm-x3250m4-04 ~]# rpm -qa pulp-server
pulp-server-2.4.0-0.11.beta.fc20.noarch

How reproducible:


Steps to Reproduce:
1.create & sync  
pulp-admin rpm repo create --repo-id rhel7-htb --feed https://cdn.redhat.com/content/htb/rhel/server/7/x86_64/os/

2. create & sync

pulp-admin rpm repo create --repo-id rhel7 --feed https://cdn.redhat.com/content/beta/rhel/everything/7/x86_64/os/ 

3.

Actual results:


[root@ibm-x3250m4-04 ~]# pulp-admin rpm repo sync run --repo-id rhel7
+----------------------------------------------------------------------+
                    Synchronizing Repository [rhel7]
+----------------------------------------------------------------------+

This command may be exited via ctrl+c without affecting the request.


Downloading metadata...
[-]
... completed

Downloading repository content...
[================                                  ] 33%
RPMs:       3993/8528 items
Delta RPMs: 0/0 items

... completed

Downloading distribution files...
[==================================================] 100%
Distributions: 0/0 items
... completed

Importing errata...
[-]
... completed

Importing package groups/categories...
[\]
... completed


Task Succeeded



[-]
Waiting to begin...
Publishing Distribution files
[-]
... completed

Publishing RPMs
[==================================================] 100%
8528 of 8528 items
... completed

Publishing Delta RPMs
[-]
... completed

Publishing Errata
[-]
... completed

Publishing Comps file
[==================================================] 100%
98 of 98 items
... completed

Publishing Metadata.
[-]
... completed

Copying files to master directory
[\]
... completed

Publishing via http
... skipped

Publishing via https
[-]
... completed


Task Succeeded




Expected results:


Additional info:

Comment 1 Sayli Karmarkar 2014-05-15 23:00:15 UTC
*** Bug 1098264 has been marked as a duplicate of this bug. ***

Comment 2 Sayli Karmarkar 2014-05-22 22:53:25 UTC
https://github.com/pulp/pulp_rpm/pull/500/

Comment 3 Preethi Thomas 2014-05-28 21:30:12 UTC
Seeing 0% 

[root@ibm-x3250m4-04 ~]# rpm -qa pulp-server
pulp-server-2.4.0-0.18.beta.el6.noarch
[root@ibm-x3250m4-04 ~]# 

[root@ibm-x3250m4-04 ~]# pulp-admin rpm repo sync run --repo-id rhel6-4+----------------------------------------------------------------------+
                   Synchronizing Repository [rhel6-4]
+----------------------------------------------------------------------+

This command may be exited via ctrl+c without affecting the request.


Downloading metadata...
[-]
... completed

Downloading repository content...
[                                                  ] 0%
RPMs:       0/11132 items
Delta RPMs: 0/0 items

... completed

Downloading distribution files...
[==================================================] 100%
Distributions: 7/7 items
... completed

Importing errata...
[|]
... completed

Importing package groups/categories...
[|]
... completed


Task Succeeded



Initializing repo metadata
[-]
... completed

Publishing Distribution files
[-]
... completed

Publishing RPMs
[==================================================] 100%
11132 of 11132 items
... completed

Publishing Delta RPMs
[-]
... completed

Publishing Errata
[==================================================] 100%
1988 of 1988 items
... completed

Publishing Comps file
[==================================================] 100%
212 of 212 items
... completed

Publishing Metadata.
[-]
... completed

Closing repo metadata
[-]
... completed

Publishing files to web
[\]
... completed


Task Succeeded


[root@ibm-x3250m4-04 ~]#

Comment 4 Randy Barlow 2014-05-29 18:07:29 UTC
This was fixed in pulp-2.4.0-0.19.beta.

Comment 5 Preethi Thomas 2014-07-01 19:32:42 UTC
verified
[root@mgmt3 ~]# rpm -qa pulp-server
pulp-server-2.4.0-0.23.beta.el6.noarch
[root@mgmt3 ~]# 

[root@mgmt3 ~]# pulp-admin rpm repo sync run --repo-id rhel63
+----------------------------------------------------------------------+
                   Synchronizing Repository [rhel63]
+----------------------------------------------------------------------+

A sync task is already in progress for this repository. Its progress will be
tracked below.

This command may be exited via ctrl+c without affecting the request.


Downloading metadata...
[-]
... completed

Downloading repository content...
[==================================================] 100%
RPMs:       8921/8921 items
Delta RPMs: 0/0 items

... completed

Downloading distribution files...
[==================================================] 100%
Distributions: 7/7 items
... completed

Importing errata...
[|]
... completed

Importing package groups/categories...
[|]
... completed


Task Succeeded



Initializing repo metadata
[-]
... completed

Publishing Distribution files
[-]
... completed

Publishing RPMs
[==================================================] 100%
8921 of 8921 items
... completed

Publishing Delta RPMs
... skipped

Publishing Errata
[==================================================] 100%
1476 of 1476 items
... completed

Publishing Comps file
[==================================================] 100%
212 of 212 items
... completed

Publishing Metadata.
[-]
... completed

Closing repo metadata
[-]
... completed

Generating sqlite files
... skipped

Publishing files to web
[/]
... completed

Writing Listings File
[-]
... completed


Task Succeeded

Comment 6 Randy Barlow 2014-08-09 06:54:54 UTC
This has been fixed in Pulp 2.4.0-1.


Note You need to log in before you can comment on or make changes to this bug.