Bug 109538 - Installer crashes during upgrade from Red Hat 9 (uncaught exception)
Summary: Installer crashes during upgrade from Red Hat 9 (uncaught exception)
Status: CLOSED DUPLICATE of bug 109462
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel   
(Show other bugs)
Version: 1
Hardware: i686
OS: Linux
medium
high
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-11-09 04:58 UTC by Daniel Lipsitt
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 18:59:53 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda error dump (542.31 KB, text/plain)
2003-11-09 05:00 UTC, Daniel Lipsitt
no flags Details
save of log crash (644.00 KB, text/plain)
2003-11-11 16:18 UTC, Hernan Espinoza
no flags Details

Description Daniel Lipsitt 2003-11-09 04:58:12 UTC
Description of problem: 
Upgrading a Dell Inspiron 8100 laptop from Red Hat 9. 
 
About 70% of the way through the transfer of the system image from 
the CD to my hard disk, I get an error message to the effect that 
the copy could not be completed and that I am "probably out of disk 
space." Since I know that I have at least 700MB on the / partition 
(more than the size of the iso image), I dismiss the error and try 
clicking next to begin the upgrade again. This is where the 
exception occurs. 
 
Version-Release number of selected component (if applicable): 
 
 
How reproducible: 
Always 
 
Steps to Reproduce: 
1. select upgrade 
2. select update boot loader 
3. click begin upgrade 
4. error message "probably out of disk space" during transfer of 
system image to disk, click ok to dismiss 
5. click next to begin upgrade again 
     
 
Actual Results:  crash 
 
Expected Results:  I would expect a message about how much disk 
space is needed and how much is available if a full disk is indeed 
the problem. Also, the "next" button should be disabled if an error 
has occurred and it is not really possible to continue 
 
 
 
Additional info: 
 
There is a message on virtual console 2: 
"-/bin/sh: relocation error: -/bin/sh: symbol version GLIBC_2.0 not 
defined in file libc.so.6 with link time reference" 
 
If I drop into the python debug shell after the exception and try to 
exec anything in a shell with a command like: 
 
os.system("ls") 
 
I get the same error. If I boot from the cd in recovery mode, I do 
not get shell errors. 
 
The traceback says: 
 
  File "/usr/lib/anaconda/packages.py", line 669, in doPreInstall 
    f = open(instPath + "/etc/mtab", "w+") 
IOError: [Errno 2] No such file or directory: 
'/mnt/sysimage/etc/mtab' 
 
There is a comment in the source at that line about problems with 
old mtabs.

Comment 1 Daniel Lipsitt 2003-11-09 05:00:22 UTC
Created attachment 95843 [details]
anaconda error dump

Comment 2 Petr Suchomel 2003-11-10 16:34:39 UTC
Have same problem when updating from Fedora test3 on one machine.
Having ~2.5 GB of free disc space, the same fails appeared couple
time. Not possible to proceed. On other machine works without problem.

Comment 3 Jeremy Katz 2003-11-10 21:27:30 UTC
Does booting with 'linux allowcddma' help at all?

Comment 4 Daniel Lipsitt 2003-11-10 22:41:24 UTC
Yes, allowcddma gets me past the point where failure occurred 
before, and installation now appears to be proceeding normally. 
Also, the shell is now available and functioning on tty2. 

Comment 5 Hernan Espinoza 2003-11-11 16:18:04 UTC
Created attachment 95908 [details]
save of log crash

Comment 6 Hernan Espinoza 2003-11-11 16:19:19 UTC
Have same problem when updating from RH9 on one machine Dell Precision
330.



Comment 7 Hernan Espinoza 2003-11-11 16:48:15 UTC
with option allowcddma the installation process works correctly in the
machine dell precision 330.
Thanks.

Comment 8 Dave Jones 2003-11-17 20:17:17 UTC

*** This bug has been marked as a duplicate of 109462 ***

Comment 9 Red Hat Bugzilla 2006-02-21 18:59:53 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.