Bug 109462 - IDE CD DMA failures.
IDE CD DMA failures.
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
1
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
:
: 107280 109361 109438 109538 109554 109600 109615 109657 109674 110013 110411 111133 111332 111872 112182 (view as bug list)
Depends On:
Blocks: 106685
  Show dependency treegraph
 
Reported: 2003-11-07 20:41 EST by Jonathon Walker
Modified: 2015-01-04 17:03 EST (History)
22 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-29 15:36:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jonathon Walker 2003-11-07 20:41:30 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5)
Gecko/20031007 Firebird/0.7

Description of problem:
During installation (both Upgrade and new Install) during the
"transferring install image to hard disk" the installer encounters a
problem writing and has to abort the installation.  This issue is not
unique to Fedora core, as I have encountered it with other RPM based
Linux distributions.  This occurs reproducibly on the athlon "I-buddie
XP" Desknote laptop.  This issue does not occur with the 0.95 release
"Severn".  The installer will report an error transferrinf the Install
image to the hard drive, and suggest the possibility that the disk may
be full, regardless of the actual amount of free disk space.   (e.g.
the problem occurs even on a clean 10 gigabyte partition).

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Boot from the Fedora Core 1.0 (Yarrow) CD on a Desknote I-Buddie XP
2.Select either the Upgrade or Install Option
3.The installer will report an error transferrinf the Install image to
the hard drive, and suggest the possibility that the disk may be full,
regardless of the actual free spaceon the partition.
    

Actual Results:  The installer reports an error transferring the
image, and allows for reboot or retry. Retries yield similar results. 

Expected Results:  The installer should have been able to transfer the
image to the Hard drive, and continued with the OS installation.

Additional info:

The computer which this issue seems to afflict is an ATHLON I-Buddie
XP.  It the motherboard is by ECS, but I cannot find any specific info
on the hard drive or IDE controller.
Comment 1 Need Real Name 2003-11-08 09:11:46 EST
Also affect FSC Amilo D 8830 (P4 2.8Ghz)

Comment 2 Need Real Name 2003-11-08 09:22:24 EST
Typo 8830 is 8820.
Comment 3 Need Real Name 2003-11-08 09:33:16 EST
Typo 8830 is 8820.
Comment 4 Dan Hollis 2003-11-09 05:19:20 EST
i get the exact same problem installing on a Shuttle SB52G2 XPC with
160gb harddisk.

I thought that 512mb DDR, 1gb swap, and 159gb / is enough to install
Fedora, but the installer seems to think otherwise.

This is a critical, showstopper bug that needs to be fixed asap.
Comment 5 Need Real Name 2003-11-09 17:48:30 EST
I have exactly the same problem with Athlon XP 2000+, ECS K7S5AL Pro
and WD 800JB (5GB clean partition), 512MB SDRAM, 1024MB swap. This bug
really sucks.
Comment 6 Jeremy Katz 2003-11-09 19:05:17 EST
Does booting with 'linux allowcddma' make things work?
Comment 7 Need Real Name 2003-11-10 06:35:51 EST
For me, anaconda did not even start without allowcddma (see bug
109438). With allowcddma it goes flawlessly until it tries to copy
install image to hard disk.
Comment 8 Jana Persson 2003-11-10 09:37:59 EST
I get the same message and install image fails to transfer. This is 
an Intel box though, a Siemens desktop, 1.5 GHz. I'm trying to do a 
clean installation, used to have RH 8 on it, up until a couple of 
moments ago.

One of the tty's logs "No pcic controller detected" on the last line. 
This is the tty with output from isys.py. I don't know what this 
means or whether it is relevant. No other consoles log anything 
resembling an error message.

Comment 9 Ronny Buchmann 2003-11-10 10:01:25 EST
I think this bug is the same as reported on fedora-list.
(see
http://www.redhat.com/archives/fedora-list/2003-November/msg01308.html
"Can install Severn, but not YARROW!")

Booting with "mem=xxxM" where xxx is half your real memory should help.
I can confirm this for my system (Epox EP-4PDA2+, P4-2.4, 2x256M DDR400).

Physically removing one stick was also reported to "fix" this issue.

Additionally I don't have a shell on 2nd console, which could be related.

I also have this "No pcic controller detected" message.
Comment 10 Need Real Name 2003-11-10 11:13:14 EST
linux allowcddma helped me bypass the install image copy problem. 
Comment 11 Ignacio Galmarino 2003-11-11 10:32:15 EST
when i try to install fedora core 1 everything works ok. But after
formating the harddisk the installer try to tranfer the install image
and finish with this error:

"Error transferring install image to hard drive - probably out of disk
space"

i found that its related to DMA and some Intel chipsets. So when the
installer ask you to select the installation type (graphical, text,
rescue, etc) you have to append

ide=nodma

if you want a graphical installation ... type: linux ide=nodma

it works ... but its really slow. When the installation finish and the
machine is restarted you have to remove this option from
/etc/grub.conf to speed up your machine

Ignacio
Comment 12 Need Real Name 2003-11-12 07:11:45 EST
The ide=nodma did not work for me. On the other hand the allowcddma 
did.
Comment 13 Jana Persson 2003-11-12 08:31:52 EST
The "linux mem=256M" (half the actual RAM size) directive suggested 
by Ronny Buchmann worked for me. My box has 2 sticks of 256 MB PC2100 
DDR SDRAM. 

I did not try any of the DMA options mentioned above. But I could if 
requested to.
Comment 14 Dan Hollis 2003-11-12 19:07:25 EST
ide=nodma worked for me, but the install took about 90 minutes, where
it normally takes 20.
Comment 15 tim gray 2003-11-15 10:19:54 EST
Compaq Armada E500, Compaq EVO laptops and DELL lattitude (intel P4
2.4Ghz) this happens on also...

But it happens at random times in the install, sometimes it get's to
the second disc, sometimes the first disc.


Almost EVERY laptop I have tried fedora core 1 on has failed this way.
this is a CRITICAL bug and needs to be addressed right away and have
new ISO's released
Comment 16 Dave Jones 2003-11-17 15:09:10 EST
*** Bug 109674 has been marked as a duplicate of this bug. ***
Comment 17 Dave Jones 2003-11-17 15:14:04 EST
*** Bug 109361 has been marked as a duplicate of this bug. ***
Comment 18 Dave Jones 2003-11-17 15:14:28 EST
*** Bug 109554 has been marked as a duplicate of this bug. ***
Comment 19 Dave Jones 2003-11-17 15:15:42 EST
*** Bug 109657 has been marked as a duplicate of this bug. ***
Comment 20 Dave Jones 2003-11-17 15:16:38 EST
*** Bug 109615 has been marked as a duplicate of this bug. ***
Comment 21 Dave Jones 2003-11-17 15:17:20 EST
*** Bug 109538 has been marked as a duplicate of this bug. ***
Comment 22 Peter van Egdom 2003-11-17 17:35:49 EST
On a NEC PowerMate P4 2.4Ghz/512MB/SiS 650/SIS5513 IDE controller with
a normal install (pressing <Enter>, without the option "linux
allowcddma"), I experience the following problems :

- <Shift+Print Screen> does not work during a graphical installation.

- After Anaconda has been started and going to virtual console #2, the
following error is seen : "/bin/sh -> relocation error bin/sh, symbol
version glibc not defined in file libc.so.6 with link time reference.

- Error message on virtual console #1 "Error loading new keyboard
description".

When booting with the option "linux allowcddma" these problems are fixed.

On a HP Vectra VLI8 'Anaconda' does not start without the option
"linux allowcddma".
Comment 23 Dave Jones 2003-11-20 13:17:03 EST
*** Bug 107280 has been marked as a duplicate of this bug. ***
Comment 24 Dave Jones 2003-11-20 13:17:24 EST
*** Bug 106685 has been marked as a duplicate of this bug. ***
Comment 25 Dave Jones 2003-11-20 13:18:40 EST
*** Bug 109438 has been marked as a duplicate of this bug. ***
Comment 26 Dave Jones 2003-11-21 16:29:15 EST
*** Bug 110411 has been marked as a duplicate of this bug. ***
Comment 27 Philippe Rigault 2003-12-15 17:18:28 EST
*** Bug 112182 has been marked as a duplicate of this bug. ***
Comment 28 Dave Jones 2003-12-16 10:05:21 EST
*** Bug 109600 has been marked as a duplicate of this bug. ***
Comment 29 Dave Jones 2003-12-16 10:07:58 EST
*** Bug 110013 has been marked as a duplicate of this bug. ***
Comment 30 Dave Jones 2003-12-16 18:53:39 EST
*** Bug 111133 has been marked as a duplicate of this bug. ***
Comment 31 Fuji TSO 2003-12-26 10:11:25 EST
FWIW, I just ran into this on a Dell 1650, IDE CDROM and Perc 3 RAID. 
I would have intermittent failures of anaconda to start, and the 
installation would always fail copying the install image. With 
allowcddma, I had one failure of anaconda to start, but once I got 
past that the installation completed successfully. 
Comment 32 Tim Currie 2004-01-02 21:13:17 EST
I have a Dell Insprion 8600; booting with "linux allowcddma" worked
for me.
Comment 33 Terry Davis 2004-01-05 15:19:25 EST
I attempted to upgrade from RH9 to FC1.  I have a dell poweredge 
1650.  I booted with 'linux text allowcddma' and it worked.  Upgrade 
took 28 minutes.  So no slow down there.

Good luck!
Comment 34 James Lehmer 2004-02-17 18:37:47 EST
This also fixed my problem, which exhibited itself as follows:

1) Default boot, would get past the prompt for checking CD media and 
would die with "exec of anaconda failed: Permission denied: install 
exited abnormally".

2) Booting with "linux text" would then show it failing in the same 
place with the message "/usr/bin/python2.2: relocation 
error: /lib/libm.so.6: symbol __cxa_finalize, version GLIBC_2.1.3 not 
defined in file libc.so.6 with link time reference".

Booting with "linux text allowcddma" fixed the problem.

Environment:

Dell PowerEdge 300, 2x 800MHz Pentium III SMP, 512MB RAM, 120GB and 
30GB IDE HDDs
Comment 35 Brian P 2004-03-13 03:07:34 EST
ide=nodma worked just fine for me. Running a Dell Dimension 2400, 
Pentium 4 2.4GHz, 768MB RAM, 40GB and 30GB IDE HDDs. Dual booting 
with Windows XP Home.
Note: It would also hang if I didn't run the Media Check.
Comment 36 Eric D. Hendrickson 2004-03-23 15:39:07 EST
I have a Dell PowerEdge 1650 where I tried to install Fedora Core 1 
this morning.  This is a dual 1.1Ghz Intel box (NOT athlon!).  The 
install kept failing during the "copying image to disk" phase with 
the message that my disk is probably full, which is totally bogus.

Installing with "linux allowcddma" solved the problem for me.
Comment 37 Troy Brown 2004-03-27 14:09:08 EST
I also received this error while upgrading from RH9 to Fedora Core 
1.  After typing "linux allowcddma" everything worked fine.  I am 
running on a Dell PowerEdge 2650.  I am running I686 and got this 
error.  Same solution fixed it.
Comment 38 Dave Jones 2004-06-19 10:46:14 EDT
*** Bug 111332 has been marked as a duplicate of this bug. ***
Comment 39 Dave Jones 2004-06-19 10:48:00 EDT
*** Bug 111872 has been marked as a duplicate of this bug. ***
Comment 40 Nahuel Alejandro Ramos 2004-08-18 16:23:20 EDT
I could install my FC1 using "linux text allowcddma". I tried "linux
allowcddma" to enter to the graphics interface but did not work.
Comment 41 David Lawrence 2004-09-29 15:36:36 EDT
Thanks for the bug report. However, Red Hat no longer maintains this version of
the product. Please upgrade to the latest version and open a new bug if the problem
persists.

The Fedora Legacy project (http://fedoralegacy.org/) maintains some older releases, 
and if you believe this bug is interesting to them, please report the problem in
the bug tracker at: http://bugzilla.fedora.us/
Comment 42 Stefan Müller 2004-10-12 08:56:18 EDT
I had the same problem with an AMD Opteron 240 and ASUS Board.
in my case "linux allowcddma" worked well.

Note You need to log in before you can comment on or make changes to this bug.