Bug 109574 - errors reported by gpm under mc and aumix when using Eterm (b/liblow.c(376)]:)
errors reported by gpm under mc and aumix when using Eterm (b/liblow.c(376)]:)
Product: Fedora
Classification: Fedora
Component: gpm (Show other bugs)
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Eido Inoue
Depends On:
  Show dependency treegraph
Reported: 2003-11-09 14:29 EST by Need Real Name
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version: 1.20.1-43
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2004-02-26 19:28:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
strace -f aumix -o aumix.log search for 'liblow.c' message (76.03 KB, text/plain)
2003-11-09 14:33 EST, Need Real Name
no flags Details

  None (edit)
Description Need Real Name 2003-11-09 14:29:58 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1)

Description of problem:
When, on fedora C1, you compiled Eterm, then run mc, instead ot the
hint line you read a message like: "b/liblow.c(376)]:"

when you run aumix, it's even worse you read: "
16333 write(2, "*** err [lib/liblow.c(267)]:\n", 29) = 29  16333
write(2, "strncmp/isdigit/option.consolena"..., 41) = 41 16333
write(2, "*** err [lib/liblow.c(376)]:\n", 29) = 29  16333 write(2,
"Oh, oh, it\'s an error! possibly "..., 39) = 39

This error doesn't happen when you run those programs under xterm.

So i searched through all my libs for that liblow message and found
out it was in libgpm. Something must be wrong there. This error
happens also when gpm is *not* running.

Version-Release number of selected component (if applicable):
gpm-1.20.1-38  mc-4.6.0-6  aumix-2.8-6

How reproducible:

Steps to Reproduce:
1. Download, --rebuild & install
2. Download, --rebuild & install
3. run Eterm
4. under Eterm run mc or aumix, read the error

Actual Results:  Errors are shown on the program launch, doesn't hurt
in mc, but screen is scrambled in aumix

Expected Results:  No errors.

Additional info:

I couldn't dig it more out, i don't really see the relation between
gpm & those other software, i'm open to any hint. Also couldn't find
anybody else with the same setup, but i assume it happens everywhere.
Comment 1 Need Real Name 2003-11-09 14:33:39 EST
Created attachment 95853 [details]
strace -f aumix -o aumix.log     search for 'liblow.c' message
Comment 2 Need Real Name 2003-11-09 14:39:14 EST
i forgot to mention, Eterm requires imlib2, this lib was installed
using apt-get & freshrpms.net
Comment 3 Need Real Name 2003-11-09 14:51:38 EST
This error doesn't appear when using the previously compiled Eterm with
from redhat9 on fedC1.  So i confirm it's a problem somwhere in gpm.

Comment 4 Eido Inoue 2003-11-10 16:38:41 EST
gpm has been specifically compiled to have enhanced mc support, which
is different from previous versions. It shouldn't be outputing
debugging diagnostic though.

The diagnostic messages would appear because the libgpm is still used
even though gpm is not running.

To clarify, if the debugging output is removed, both progs behave as

How does mc work inside of other terminals such as gnome-terminal?
Comment 5 Need Real Name 2003-11-10 20:40:27 EST
aumix and mc works fine under xterm and gnome-terminal (nothing
printed or shown in strace), this happens only in the homecompiled Eterm.

I've searched through the src.rpm (and thus the source code too) to
disable libgpm output, i've only found where it was used:
src/lib/report-lib.c  seems to be the code that prints the error on
the screen (on stderr), but there are no switch to disable it.

So i tried this:
aumix 2>/dev/null   indeed the printed errors on stderr aren't visible
anymore, but, disabling the errors shouldn't really fix them? :)
Comment 6 Ondrej Svejda 2003-11-11 10:36:43 EST
I'm getting the same error under the following circumstances:

- when connecting from Putty.
  Error written by mc and links (2.1pre13). Other programs not tested.
- on text console when programs are executed from mc.
  Error written by links, aumix, pinfo.

Doesn't matter if gpm is started or not.
Comment 7 Steven Shiau 2004-01-24 10:57:14 EST
I comfirmed that I encountered the same problem in FC1, I use dialog,
but the output message contains (check bug #109468)
*** err [lib/liblow.c(267)]:
strncmp/isdigit/option.consolename failed
*** err [lib/liblow.c(376)]:
Oh, oh, it's an error! possibly I die! 
while in RH9 dialog works very well.
How can I fix this ?
Comment 8 Ondrej Svejda 2004-01-30 10:41:22 EST
Adding write permissions to /dev/gpmctl fixes the problem.
Comment 9 Steven Shiau 2004-01-30 22:34:57 EST
Adding write permissions to /dev/gpmctl does NOT work for me...
I change the permission of my /dev/gpmctl permission to be
srwx-w--w-    1 root     root            0 Jan 31 11:19 /dev/gpmctl=
Both root and normal user run "dialog" will still produce the 
*** err [lib/liblow.c(267)]:
strncmp/isdigit/option.consolename failed
*** err [lib/liblow.c(376)]:
Oh, oh, it's an error! possibly I die! 

in my tmp file, where only "3" is what I want.
Comment 10 Ondrej Svejda 2004-01-31 16:22:37 EST
Sorry, I was too quick. Write permissions on gpmctl fixes only aumix
(and only if aumix is not run from mc).
Comment 11 jo 2004-02-17 00:49:07 EST
Make this on the shell:

export TERM=eterm

To go Up and Down in mc use ctrl-n and ctrl-p!
Comment 12 Eido Inoue 2004-02-26 19:28:11 EST
fixed with latest gpm against fc2

Note You need to log in before you can comment on or make changes to this bug.