Bug 109576 - Crashes after adding usb nic
Crashes after adding usb nic
Status: CLOSED DUPLICATE of bug 106332
Product: Fedora
Classification: Fedora
Component: kudzu (Show other bugs)
1
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-09 15:14 EST by Ted Kaczmarek
Modified: 2014-03-16 22:40 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:59:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Bugbuddy log (4.65 KB, text/plain)
2003-11-09 15:15 EST, Ted Kaczmarek
no flags Details

  None (edit)
Description Ted Kaczmarek 2003-11-09 15:14:09 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5)
Gecko/20031030 Epiphany/1.0.4

Description of problem:
The neat crashes are still alive and well :-)


Version-Release number of selected component (if applicable):
redhat-config-network-1.3.10-1,  rhpl-0.121-1

How reproducible:
Always

Steps to Reproduce:
1. Connect Linksys USB nic to Fedora on laptop that has internal 8139too  
2. run neat(redhat-config-network)
3. poof
    

Actual Results:  Crashes.

Expected Results:  Network configuration dialog starts.

Additional info:

Also seing kudzu errors, not sure what is to blame.
[root@cr1itl130 root]# service kudzu start
Checking for new hardware/etc/init.d/kudzu: line 97:  6287
Segmentation fault      /usr/sbin/kudzu $KUDZU_ARGS -t 30
                                                           [FAILED]
Updating /etc/fstab  

Also modules mapping messes up if booted with the usb nic card.
Have to reverse eth0 and eth1 to get both nics to work.
Comment 1 Ted Kaczmarek 2003-11-09 15:15:36 EST
Created attachment 95854 [details]
Bugbuddy log
Comment 2 Matt 2003-11-09 21:48:12 EST
I have the same problems with redhat-config-network and kudzu.  Both 
kudzu and redhat-config-network crash with a segmentation fault 
error message.  After installing fedora, I remember kudzu running 
one time on the initial boot.  It never ran again after that, just 
the seg fault.  Redhat-config-network, however, does execute in a 
non-X console. 
Comment 3 Matt 2003-11-10 19:40:07 EST
I installed a vanilla 2.6-test kernel and kudzu and config-network 
work perfectly... 
Comment 4 Ted Kaczmarek 2003-11-10 20:36:16 EST
As in kernel.org? Last time I tried a test kernel and rebooted in
older one I had to esfck my install back. Was test 7 if memory serves
me right.
Comment 5 Matt 2003-11-11 15:08:50 EST
Yep, I installed it from the source tar...took just a slight bit of 
tweaking to get the initscripts to work right, but I found a 
tutorial on the web, which I am sure you have found one by now.  
2.6.0-test9, seems to work just fine, the biggest problem I had was 
figuring out what needed to be loaded as a module to avoid breaking 
scripits as much as possible.  Apparently, just USB core drivers and 
stuff like that. 
Comment 6 Harald Hoyer 2003-11-25 10:13:17 EST
how does r-c-n crash? segmentation fault? python exception?
Comment 7 Ted Kaczmarek 2003-11-25 21:31:38 EST
Every time ,if you add usb nic card after booting, and then run r-c-n.
But based upon other posts it would appear to be kernel related. I
will try with 2.6 next change I get.
Comment 8 Harald Hoyer 2003-11-26 05:27:47 EST
how does r-c-n crash? with a segmentation fault or a python exception?
try to run it from a terminal:

$ redhat-config-network

Does it say "segmentation fault" or "python traceback" ??

-ENEEDMOREINFO
Comment 9 Ted Kaczmarek 2003-11-29 23:56:43 EST
Segmentation fault      /usr/sbin/kudzu $KUDZU_ARGS -t 30

The above is from my original entry in the additional info section.

A small suggestion, when any changes are made via the gui, purge the
default profiles and recreate them. Sure a little overhead, but I
suspect would it would prevent a plethora of problems. 

Also what would you think of running kudzu only on initial installs.
If someone adds some hardware maybe some option during boot to run
kudzu if they so desired. Otherwise whats the point of doing hardware
discovery on every boot. Hell one should know if they added some
hardware or module support shouldn't they :-)

Otherwise I think the gui is a great interface, and I do lots of
testing and network changes so I tend to come across more undocumented
features than most.

I will add a rule to my mail program to forward all bugzilla to my
work account, this should improve my response times, thanks for your
patience.


Comment 10 Ulrich Raich 2003-12-01 04:55:16 EST
Having the same segfault problems with r-c-n and kuzdu and I confirm
that with kernel2.6-test9 the problems go away. I will have to modify
my adsl driver (for the sagem f800) for 2.6 however in order to get a
working system back. Is there anything I can do to help? Run r-c-n 
or kuzdu under gdb?
Comment 11 Harald Hoyer 2003-12-01 05:52:08 EST
kudzu with a gdb traceback would be cool... or the coredump of your
kudzu... you can mail me the kudzu coredump directly, if you don't
want to put it in bugzilla.
# ulimit -Sc 0
helps.
Comment 12 Harald Hoyer 2003-12-01 05:54:48 EST
reassigning to component kudzu
Comment 13 Bill Nottingham 2004-02-04 01:16:20 EST

*** This bug has been marked as a duplicate of 106332 ***
Comment 14 Red Hat Bugzilla 2006-02-21 13:59:54 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.