This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 106332 - kudzu seg faults on startup
kudzu seg faults on startup
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kudzu (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
David Lawrence
:
: 106333 109576 110433 114071 115199 116271 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-05 20:29 EDT by Rick Sutphin
Modified: 2014-03-16 22:39 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-02-26 21:23:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
gdb backtrace for kudzu (885 bytes, text/plain)
2003-10-06 19:14 EDT, Rick Sutphin
no flags Details
strace for kudzu (132.62 KB, text/plain)
2003-10-06 19:15 EDT, Rick Sutphin
no flags Details
ls -l /etc/sysconfig/network-scripts (2.29 KB, text/plain)
2003-10-07 18:22 EDT, Rick Sutphin
no flags Details
gdb -q /usr/sbin/kudzu (782 bytes, text/plain)
2003-10-07 18:23 EDT, Rick Sutphin
no flags Details
/sbin/lspci > lspci (1.01 KB, text/plain)
2003-10-07 20:16 EDT, Rick Sutphin
no flags Details
hwconf of the hardware that seemed to be causing problem + workaround patch (975 bytes, patch)
2003-12-03 03:20 EST, Norm Brake
no flags Details | Diff

  None (edit)
Description Rick Sutphin 2003-10-05 20:29:23 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030624

Description of problem:
kudzu seg faults on startup (both warm boot and cold boot). At first I was
getting 2745 segmentation fault, I then downloaded kudzu and refreshed it. I
then got 2933 segmentation fault.

I restarted the computer and entered interactive startup so I could write down
the error message. During interactive start up I get 3052 segmentation fault.

I found no references to kudzu in /var/log/messages, /var/log/dmesg, or
/var/log/boot/log

Hardware is as follows:
MSI K7T266 Pro motherboard
VIA KT266 chipset
Creative Labs Sound Blaster Live (EMU10k1)
NVidia GeForce 400 64 meg video card
AMDtek comet based ethernet card


Version-Release number of selected component (if applicable):
kudzu-1.1.20.1-1

How reproducible:
Always

Steps to Reproduce:
1.start up system, either cold boot, or warm boot
2.
3.
    

Actual Results:  /etc/rc5.d/S05kudzu : 3052 segmentation fault /usr/sbin/kudz
$KUDZU_ARGS -t 30


Expected Results:  Kudzu should exit normally after checking for new hardware.

Additional info:

Ximian evolution, and hardware browser are also crashing, though  I do not know
if these bugs are in anyway related.
Comment 1 Bill Nottingham 2003-10-06 01:32:42 EDT
If you run it under gdb, what's the backtrace?
Comment 2 Bill Nottingham 2003-10-06 18:05:48 EDT
*** Bug 106333 has been marked as a duplicate of this bug. ***
Comment 3 Rick Sutphin 2003-10-06 19:14:22 EDT
Created attachment 94965 [details]
gdb backtrace for kudzu
Comment 4 Rick Sutphin 2003-10-06 19:15:04 EDT
Created attachment 94966 [details]
strace for kudzu
Comment 5 Rick Sutphin 2003-10-06 19:20:09 EDT
Attached is the backtrace you requested. I also attached the strace. To produce
these files I did the following:
1. changed default runlevel to 3
2. rebooted computer
3. logged in as root
4. ran script then gdb
5. ran script then strace
Comment 6 Bill Nottingham 2003-10-06 21:45:37 EDT
Can you attach the output of 'ls -l /etc/sysconfig/network-scripts'?

Also, if you could install kudzu-1.1.31-1 and kudzu-debuginfo-1.1.31-1 from
http://people.redhat.com/notting/kudzu/, and get a backtrace from having
both of those installed, that might help as well.
Comment 7 Rick Sutphin 2003-10-07 18:22:33 EDT
Created attachment 94997 [details]
ls -l /etc/sysconfig/network-scripts
Comment 8 Rick Sutphin 2003-10-07 18:23:09 EDT
Created attachment 94998 [details]
gdb -q /usr/sbin/kudzu
Comment 9 Rick Sutphin 2003-10-07 18:31:16 EDT
Bill,

I am not sure I did this correctly, but the files you requested are attached. I
used the following procedure to create these files.

1. installed the required files as follows:
   a) rpm -Uhv kudzu-1.1.31-1.i386.rpm
   b) rpm -Uhv kudzu-debuginfo-1.1.31-1.rpm
2. changed default runlevel to 3
3. rebooted computer
4. ls -l /etc/sysconfig/network-scripts > network-scripts
5. script; gdb -q /usr/sbin/kudzu

I was not sure if I needed to do anything different to utilize the kudzu.debug
file. Please let me know if you need this re done differently.

Thanks,
Rick
Comment 10 Bill Nottingham 2003-10-07 18:58:59 EDT
Can you attach the output of lspci?
Comment 11 Rick Sutphin 2003-10-07 20:16:03 EDT
Created attachment 95007 [details]
/sbin/lspci > lspci
Comment 12 Rick Sutphin 2003-10-07 20:17:04 EDT
Bill,

Here is the output of lspci you requested. Hope this helps.

Rick
Comment 13 Norm Brake 2003-12-03 03:20:31 EST
Created attachment 96307 [details]
hwconf of the hardware that seemed to be causing problem + workaround patch

I have the same problem.  I tracked it down to a strcmp() on a NULL ptr.
I made the code skip the strcmp() if the pointer was NULL and kudzu identified
a new piece of hardware which I figure was triggering the problem.

The /etc/sysconfig/hwconf section for that hardware and the patch I used to get
past the segfault are attached.
Comment 14 Moritz Barsnick 2004-01-23 03:28:15 EST
I have recently described the same phenomenon in Bug #114071. Thanks 
to Norm's patch, I have been able to eliminate my segmentation faults 
and get kudzu to run. (Thank you, Norm!)

I have posted an updated patch which applies against kudzu-1.1.40 in 
the report for Bug #114071 as attachment 97205 [details]. I hope this goes 
upstream soon.  :)
Comment 15 Bill Nottingham 2004-02-04 01:13:17 EST
*** Bug 114071 has been marked as a duplicate of this bug. ***
Comment 16 Bill Nottingham 2004-02-04 01:16:03 EST
*** Bug 110433 has been marked as a duplicate of this bug. ***
Comment 17 Bill Nottingham 2004-02-04 01:16:23 EST
*** Bug 109576 has been marked as a duplicate of this bug. ***
Comment 18 Bill Nottingham 2004-02-04 01:43:03 EST
Please try the kudzu-1.1.36.1-1 packages at:
 http://people.redhat.com/notting/kudzu/

These may resolve some of your issues.
Comment 19 Harald Hoyer 2004-02-09 04:14:22 EST
*** Bug 115199 has been marked as a duplicate of this bug. ***
Comment 20 Harald Hoyer 2004-02-25 05:00:37 EST
*** Bug 116271 has been marked as a duplicate of this bug. ***
Comment 21 Moritz Barsnick 2004-02-26 03:17:48 EST
As far as I'm concerned (comment #14), the new packages fix this 
issue for me. Feel free to close the bug if you think this is 
appropriate.

Thanks,
Moritz
Comment 22 Patrice Dumas 2004-02-26 08:42:32 EST
It works for me too.
Comment 23 Bill Nottingham 2004-02-26 21:23:59 EST
Marking as closed in rawhide. The update will be pushed to final in
the next week or so.
Comment 24 John Flanagan 2004-05-12 01:09:33 EDT
An errata has been issued which should help the problem described in this bug report. 
This report is therefore being closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files, please follow the link below. You may reopen 
this bug report if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2004-068.html

Note You need to log in before you can comment on or make changes to this bug.