Bug 109592 - fontconfig package should require newer freetype
fontconfig package should require newer freetype
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: fontconfig (Show other bugs)
1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Owen Taylor
:
: 113322 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-09 17:02 EST by Peter Oliver
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-19 13:12:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter Oliver 2003-11-09 17:02:51 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5)
Gecko/20031016 Galeon/1.3.10

Description of problem:
Running "rpm -q --requires fontconfig" mentions
    freetype >= 2.1.2-7

However, I was running freetype-2.1.3-6, and found that gdmchooser
failed once I upgraded to fontconfig-2.2.1-6.1.

Unfortunately, the exact error message has scrolled off my terminal,
but it was an undefined symbol error or something like that.

Upgrading to freetype-2.1.4-5 cured the problem.

Version-Release number of selected component (if applicable):
2.2.1-6.1

How reproducible:
Didn't try

Steps to Reproduce:
1. Take a RHL 9 system.
2. Use yum to install XFree86 from Fedora Core.
3. Watch it pull in a newer fontconfig but not a newer freetype.
    

Additional info:
Comment 1 Owen Taylor 2004-04-19 11:50:50 EDT
*** Bug 113322 has been marked as a duplicate of this bug. ***
Comment 2 Owen Taylor 2004-04-19 13:12:10 EDT
* Mon Apr 19 2004 Owen Taylor <otaylor@redhat.com> 2.2.1-9
- Require recent freetype (#109592, Peter Oliver)
Comment 3 John Flanagan 2004-09-02 01:42:03 EDT
An errata has been issued which should help the problem 
described in this bug report. This report is therefore being 
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files, 
please follow the link below. You may reopen this bug report 
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2004-410.html

Note You need to log in before you can comment on or make changes to this bug.