Bug 109697 - php-devel is missing from the unified build tree.
php-devel is missing from the unified build tree.
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: distribution (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: dff
: FutureFeature
: 115951 (view as bug list)
Depends On:
  Show dependency treegraph
Reported: 2003-11-10 20:49 EST by Matthew Galgoci
Modified: 2007-11-30 17:06 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2004-09-01 22:37:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Matthew Galgoci 2003-11-10 20:49:46 EST
php-devel is missing from the unified build tree.
Comment 1 Joe Orton 2003-11-11 04:20:44 EST
What do you mean by "unified build tree" exactly?  php-devel is not
included in RHEL3.
Comment 3 Joe Orton 2003-11-11 14:42:18 EST
So by "unified build tree" you mean the "tree produced by rebuilding
all the source RPMs".  To be clear: the php-devel binary RPM is not
included in any of the RHEL3 variants.

The lack of -devel packages in the shipped OS is a PM decision: we
don't ship things we don't support, AIUI.
Comment 4 Matthew Galgoci 2003-12-19 14:56:32 EST
How are people expected to build applications on top of RHEL if we don't
even produce -devel packages?
Comment 5 Need Real Name 2004-01-28 13:45:07 EST
Agreed...  I can't build third party modules for php on RHEL without the php-devel 
tools and therefore cannot get my php applications to work on RHEL and therefore 
RHEL is for all intensive purposes broken to me.    This makes no sense!  I know.  
While you're at it why don't you not ship GCC because people could build applications 
you don't want to support too.  Or CPAN because people might download perl 
modules you don't want to support.  Or openssl-devel because people might compile ssl 
applications you might not want to support. 
I can't even build php-devel from the php SRPM because it requires imap-devel and 
unixODBC-devel which are not shipped either. 
PLEASE add php-devel to the distrobution so we can make use of PHP modules!.  At 
least post a resonalbe workaround. 
Comment 6 Turadg Aleahmad 2004-01-28 20:06:47 EST
Without "phpize" contained in php-devel, we can't even use many PEAR 
modules.  This is ridiculous.
Comment 7 Joe Orton 2004-02-02 05:12:32 EST
There are packages including php-devel available for testing purposes
from: http://people.redhat.com/jorton/Taroon-php/ - please post any
feedback with these (good or bad) here.

Comment 8 Turadg Aleahmad 2004-02-02 13:50:46 EST
I've installed these on our development and production servers.  No 

Comment 9 Dmitry S. Makovey 2004-02-13 10:23:52 EST
this workaround doesn't make any sence since our organization picked 
redhat mainly because of erratas and support on packages we regularly 
use. php-devel is one of them - building php from sources defeats the 
purpose of employing redhat in our organization.
So to work with RHEL I need to build lots of packages myself (just 
stepped on yesterday: php-devel, imap-devel, perl-TimeDate) and have 
no support for them. That definately puts us in position of 
resignating from RH services. 
I consider absence of -devel packages as a BIG BUG which needs to be 
fixed. One way to fix it I can see - produce "unsopported packages" 
CD which will include packages "not officially" supported by RH but 
with same versions as corresponding non-devel packages. Otherwise 
this distro is really useless for us.
Comment 10 Joe Orton 2004-02-17 06:33:14 EST
*** Bug 115951 has been marked as a duplicate of this bug. ***
Comment 11 Steve 2004-02-24 13:45:32 EST
I just installed that package on our production IMP server, no problems. 

I'd like to echo the sentiments expressed here. Removing ALL devel packages from the EL 
line is a little extreme. We need to be able to build applications. I ran into the same 
problem with mysql. For EL 3.0, the client rpm was available but not the server. What the 
hell use is that? 
Comment 12 nathan r. hruby 2004-03-09 12:15:58 EST
Pine.  Adding METOO

Chances of seeing php-devel-unsupported in Taroon Update 2?  Really
*not* wanting to wait till RHEL-4 :)
Comment 13 Joe Orton 2004-03-09 12:21:54 EST
Just a reminder for newcomers to the bug (and not attempting to
detract from the desire for php-devel to become a supported part of
RHEL); there are test packages at:
http://people.redhat.com/jorton/Taroon-php/ which include php-devel;
testing welcome.
Comment 14 nathan r. hruby 2004-03-09 12:31:45 EST
AFIK, due to the lack of other -devel packages one cannot still
rebuild the src.rpm.  Would it be possible to add defines and ifdefs
in the specfile for these (much the way oracle is setup now ) so we
can do a rebuild without having to change the specfile?  I know it's
messy, but easier than getting the other -devel packages needed I
think  :)

[nathan@mike rpms]$ rpmbuild --rebuild php-4.3.2-10.ent.src.rpm
Installing php-4.3.2-10.ent.src.rpm
error: Failed build dependencies:
	imap-devel is needed by php-4.3.2-10.ent
	postgresql-devel is needed by php-4.3.2-10.ent
	unixODBC-devel is needed by php-4.3.2-10.ent
[nathan@mike rpms]$ 

FWIW, I'm an edu user and while we have full boat support contracts
now, when we reup our contracts we will probbably take the EDU pricing
route which means no support, just updates.  Cheaper yes, but it does
take the wind out of the "don't ship it cause you don't support it"
sails :)  

Also, you may just want to drop imap support wholesale as php's IMAP
support is based on UW's c-client which seems to be in the process of
being dropped from RH products due to licensing issues.  There was a
nice long thread about this on fedora-devel a few weeks ago, as they
jsut made this change.
Comment 15 August Zajonc 2004-03-20 15:42:48 EST
Great to see a testing version is available. Works for me without any
problems so far. 

Just to confirm that this it is incredibly painful situation to not
have php-devel as part of the package set. 

I'm not concerned with Redhat supporting packages I develop on top of
php, but to not be able to develop on php? We just get ourselves in a
situation where we have to take php-devel from other distributions (a
recommendation out there).

Please look at including php-devel in a future update. 

Comment 16 Mario Lorenz 2004-04-16 09:17:50 EDT
The Beta channel still does not have php-devel - I take it that
this bug will not be fixed with the upcomming updates then ?

I'm also kinda missing the SNMP extension also is missing.

I understand that Red Hat does not want to support everything, for
various reasons. Would it be an acceptable policy if Red Hat would in
the future just not ship unsupported packages, so that a rebuild will
yield them (where the rebuild voids (the void) waranty anyway)? This
way people could use unsupported extensions, and still retain maximum
compatibility, as opposed to being forced to build an alltogether new
Comment 17 Chris Adams 2004-04-20 16:40:53 EDT
PHP hasn't changed at all in the RHEL 3 U2 beta - does this mean that
Red Hat is still going to leave out php-devel in the update?

Even if RH isn't going to ship the *-devel packages, most of the
corresponding .src.rpm files will build the -devel pacakges with a
simple rebuild (so I don't have to rip out the RHEL packages just to
get a compatible -devel package).  For no good reason, even this
option was stripped out of the php.spec file (so I've wasted an
afternoon building other required -devel packages before realizing this).

I pitched RHEL to my boss as a suitable replacement for RHL servers,
but  the lack of -devel packages makes it difficult to use on our
servers; I'm beginning to wonder if we made the right choice.
Comment 18 Joe Orton 2004-04-20 19:39:39 EDT
The php-4.3.2-11.ent package in the U2 beta *does* build the -devel
subpackage when rebuilt from source, I can say that much.
Comment 19 Chris Adams 2004-04-20 19:59:55 EDT
I downloaded the RHEL3-U2-Beta-RC-re0330.0-i386-es-disc*-ftp.iso CD
images, and they have the same php*-4.3.2-8.ent.i386.rpm packages as
the original RHEL3 ES release.  It looks like the individual package
download has some different packages than the CD images.
Comment 20 Joe Orton 2004-04-20 20:03:52 EDT
Sorry, yes: the -11.ent package was pushed to RHN Beta channel since
the ISOs were made.
Comment 21 Need Real Name 2004-05-30 00:53:56 EDT
When will the php-devel be officially supported??  This is becoming 
really annoying and I'm this close to go back to MS Windows 2003. I 
hope redhat is listening... 

sigh :-(
Comment 23 Milan Kerslager 2004-06-09 17:45:37 EDT
php-4.3.2-11.ent since 2004-05-11 (RHBA-2004:169) has php-devel
package so closing bug as CURRENTRELEASE. If anybody has a problem
related to this bug, please reopen.
Comment 24 Joe Orton 2004-06-09 17:49:04 EDT
php-devel is not included in that RHBA nor in U2; this bug is for
tracking the inclusion of php-devel in RHEL3 proper, not what happens
when you rebuild the source RPM.
Comment 25 Milan Kerslager 2004-06-09 17:53:16 EDT
Yes, I see. Sorry for the confusion. This is very uncomfortable
because we are not able to build PHP extension for our application and
we have to touch RHEL system the way the customer dislike.
Comment 26 Joe Orton 2004-06-09 18:00:57 EDT
We're planning to include php-devel in U3.
Comment 28 Donald E. Foss 2004-07-08 10:32:58 EDT
I wanted to add that the rpms from
http://people.redhat.com/jorton/Taroon-php/ have worked perfectly for
us both in development and production.  I sincerely hope that it gets
included in the next RHEL update.
Comment 29 Jay Turner 2004-09-01 22:37:08 EDT
An errata has been issued which should help the problem 
described in this bug report. This report is therefore being 
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files, 
please follow the link below. You may reopen this bug report 
if the solution does not work for you.


Note You need to log in before you can comment on or make changes to this bug.