Bug 109734 - Install fails on bad package, when it should continue
Install fails on bad package, when it should continue
Status: CLOSED DUPLICATE of bug 68376
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
1
All Linux
medium Severity high
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-11 10:17 EST by Hacksaw
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:59:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hacksaw 2003-11-11 10:17:49 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5)
Gecko/20031007 Firebird/0.7

Description of problem:
I was upgrading my RH 9 install with Core 1. I was on disk 3. The
installer reported some problem with the kernel source package and
said it couldn't continue.

Aaaaaargh! You can't abort once you have changed the disk, not on a
package like that. I could see aborting on really important packages
like the kernel or really important libs such as glibc. In fact, those
should be carefully checked before you even try to upgrade. The kernel
source is a failure the user can recover from easily. 

What should have happened is it should have reported the error, tossed
any packages that were dependant on it, and continued on with the
rest. It was almost done.

A newbie user would be wringing his hands right now, wondering whether
his machine was hosed. (Thankfully, I tried it on a machine I could
afford to hose.)


Version-Release number of selected component (if applicable):


How reproducible:
Didn't try

Steps to Reproduce:
1. Install or upgrade
2. Have a package that fails due to bad media or some other corruption
3.
    

Actual Results:  Installer aborted with a message regarding a
non-critical package, and rebooted

Expected Results:  Installer should have continued, leaving out bad
package and those packages dependant on it.

Additional info:

In case it's a real corruption in the iso's, failure from the log:

Upgrading kernel-source-2.4.22-1.2115.nptl.i386.
error: unpacking of archive failed on file
/usr/src/linux-2.4.22-1.2115.nptl/fs/reiserfs/super.c;3fb
0cf1b: cpio: MD5 sum mismatch
Comment 1 Michael Lee Yohe 2003-11-12 10:39:21 EST
I think that if there are no dependencies on a package that is
considered bad, Anaconda should continue.  If there are dependencies,
see if there is anything that is mandatory for system operation that
will be broken and proceed as determined.
Comment 2 Brent Fox 2004-03-12 16:32:29 EST

*** This bug has been marked as a duplicate of 68376 ***
Comment 3 Red Hat Bugzilla 2006-02-21 13:59:56 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.