Bug 68376 - Bad rpms during install handled badly - want SKIP option
Bad rpms during install handled badly - want SKIP option
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
8.0
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
: 30029 71487 74139 109734 118206 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-07-09 12:25 EDT by udippel
Modified: 2007-04-18 12:44 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-03-24 12:01:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description udippel 2002-07-09 12:25:53 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.0 (X11; Linux i686; U;) Gecko/20020408

Description of problem:
During install, while extracting from disk3, there was no more progress for
almost 30 minutes; no change of rpm to be inflated. The mouse was active. But
there was no chance to stop the current rpm from being installed.
Agreed, disk3 turned out to 'fail' the media test.
Though, I propose that when an error occurs, the user should have more
alternatives than power-off. An erroneous rpm could be skipped (and installed
later, after reboot), e.g. instead of freezing all inputs (except mouse), which
means start from scratch.

Version-Release number of selected component (if applicable):


How reproducible:
Didn't try

Steps to Reproduce:
1. insert install disk containing errors
2.
3.
	

Actual Results:  a program that cannot be inflated will be skipped.


Expected Results:  The users can continue on their own; and have some control
over the procedure (skip current, pause, etc)

Additional info:
Comment 1 Jackie Meese 2002-07-28 23:35:51 EDT
PLEASE do this.  I've wanted this on the RH install since back in 4.2.  If there
is a scratch on the CD or anything, the whoe thing starts over with the same
problem next time.  Just add a "SKIP" optin and a warning that you must install
be hand to avoid dependency problems, maybe even give a command line to run
after install.
Comment 2 Michael Fulbright 2002-08-14 14:55:32 EDT
*** Bug 71487 has been marked as a duplicate of this bug. ***
Comment 3 Michael Fulbright 2002-09-16 17:17:11 EDT
*** Bug 74139 has been marked as a duplicate of this bug. ***
Comment 4 Jeremy Katz 2003-01-03 02:12:35 EST
Deferring to a future release.  We should allow for ejecting and replacing the
CD with a new one if you hit a problem package during the installation now, though.
Comment 5 Jeremy Katz 2003-01-03 02:13:02 EST
*** Bug 30029 has been marked as a duplicate of this bug. ***
Comment 6 Jeremy Katz 2003-03-24 12:01:29 EST
A skip option requires significant changes in many ways and doesn't make sense
for many packages (eg, if glibc fails to install a skip button isn't going to
help at all).  We now catch every case that we can of a package failure before
trying to install the package and allow you to replace the CD in cases where you
have problems.
Comment 7 Brent Fox 2004-03-12 16:32:32 EST
*** Bug 109734 has been marked as a duplicate of this bug. ***
Comment 8 Brent Fox 2004-03-15 10:33:35 EST
*** Bug 118206 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.