Bug 109803 - timeconfig influenced by umask
timeconfig influenced by umask
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: redhat-config-date (Show other bugs)
1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
:
: 109356 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-11 17:48 EST by Ulrich Drepper
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-01-08 16:47:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Explicitly call chmod() (1.08 KB, patch)
2003-11-11 17:50 EST, Ulrich Drepper
no flags Details | Diff

  None (edit)
Description Ulrich Drepper 2003-11-11 17:48:53 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6b)
Gecko/20031110 Firebird/0.7+

Description of problem:
When generating the /etc/localtime output file timeconfig is
influenced by the umask used.  This is bad if it prevents reading by
group or other.

Version-Release number of selected component (if applicable):
redhat-config-date-1.5.25-1

How reproducible:
Always

Steps to Reproduce:
1.su
2.umask 077
3.run timeconfig
    

Actual Results:  /etc/localtime has more 0600.

Expected Results:  Show have mode 0644.

Additional info:
Comment 1 Ulrich Drepper 2003-11-11 17:50:00 EST
Created attachment 95916 [details]
Explicitly call chmod()

The obviously correct way it to call chmod() explicitly.  The attached patch is
tested but given my python expperience this doesn't mean much.
Comment 2 Brent Fox 2004-01-08 16:47:47 EST
Patch looks fine to me.  Applied and committed.  Should appear in
system-config-date-1.7.1-1.  Thanks for the patch.
Comment 3 Brent Fox 2004-01-12 17:07:49 EST
*** Bug 109356 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.