Bug 1098201 - [abrt] pyhoca-gui: _file.py:330:to_profile_id:X2GoProfileException: The sessions config file contains multiple session profiles with name: nbecker7
Summary: [abrt] pyhoca-gui: _file.py:330:to_profile_id:X2GoProfileException: The sessi...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: pyhoca-gui
Version: 20
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Orion Poplawski
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:f2b30dd6dbcd03f3ab1fe7b200a...
: 1135507 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-05-15 13:16 UTC by Neal Becker
Modified: 2014-11-17 06:28 UTC (History)
2 users (show)

Fixed In Version: pyhoca-gui-0.5.0.0-1.fc20
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-11-17 06:28:56 UTC


Attachments (Terms of Use)
File: backtrace (1.78 KB, text/plain)
2014-05-15 13:16 UTC, Neal Becker
no flags Details
File: environ (2.02 KB, text/plain)
2014-05-15 13:16 UTC, Neal Becker
no flags Details

Description Neal Becker 2014-05-15 13:16:18 UTC
Description of problem:
1st time trying pyhoca-gui (have used x2goclient before)
On icon in tray, left click, then try to connect to existing session

Version-Release number of selected component:
pyhoca-gui-0.4.0.9-1.fc20

Additional info:
reporter:       libreport-2.2.2
cmdline:        pyhoca-gui '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' ''
dso_list:       python-x2go-0.4.0.9-1.fc20.noarch
executable:     /usr/bin/pyhoca-gui
kernel:         3.14.3-200.fc20.x86_64
runlevel:       N 5
type:           Python
uid:            1000

Truncated backtrace:
_file.py:330:to_profile_id:X2GoProfileException: The sessions config file contains multiple session profiles with name: nbecker7

Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/pyhoca/wxgui/frontend.py", line 784, in OnSessionAuthenticate
    if self.session_profiles.get_profile_config(profile_name)['directrdp']:
  File "/usr/lib/python2.7/site-packages/x2go/backends/profiles/_file.py", line 213, in get_profile_config
    _profile_id = profile_id or self.check_profile_id_or_name(profile_id_or_name)
  File "/usr/lib/python2.7/site-packages/x2go/backends/profiles/_file.py", line 456, in check_profile_id_or_name
    _profile_id = self.to_profile_id(profile_id_or_name)
  File "/usr/lib/python2.7/site-packages/x2go/backends/profiles/_file.py", line 330, in to_profile_id
    raise X2GoProfileException('The sessions config file contains multiple session profiles with name: %s' % profile_name)
X2GoProfileException: The sessions config file contains multiple session profiles with name: nbecker7

Local variables in innermost frame:
_profile_ids: ['20131224085249847', '20140403135324010']
self: X2GoIniFile(_cached_profile_ids=['20131224085249847', '20140403135324010', '20140416095719622'],_cached_profile_names=[u'New session', u'nbecker7', u'nbecker7'],_profile_metatypes={'20140416095719622': u'KDE Desktop', '20131224085249847': u'KDE Desktop', '20140403135324010': u'KDE Desktop'},_profiles_need_profile_id_renewal=[],config_files=['/home/nbecker/.x2goclient/sessions'],defaultValues={},iniConfig=<ConfigParser.SafeConfigParser instance at 0x239ccf8>,logger=<x2go.log.X2GoLogger object at 0x239e5d0>,session_profiles=['20131224085249847', '20140403135324010', '20140416095719622'],user_config_file=/home/nbecker/.x2goclient/sessions)
profile_name: u'nbecker7'
p: '20140416095719622'

Comment 1 Neal Becker 2014-05-15 13:16:22 UTC
Created attachment 895930 [details]
File: backtrace

Comment 2 Neal Becker 2014-05-15 13:16:24 UTC
Created attachment 895931 [details]
File: environ

Comment 3 Orion Poplawski 2014-05-15 17:11:11 UTC
Filed upstream.

http://bugs.x2go.org/cgi-bin/bugreport.cgi?bug=500

Comment 4 Orion Poplawski 2014-09-04 14:11:43 UTC
*** Bug 1135507 has been marked as a duplicate of this bug. ***

Comment 5 Fedora Update System 2014-10-20 15:30:59 UTC
pyhoca-gui-0.5.0.0-1.fc20, pyhoca-cli-0.5.0.0-1.fc20, python-x2go-0.5.0.0-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/pyhoca-gui-0.5.0.0-1.fc20,pyhoca-cli-0.5.0.0-1.fc20,python-x2go-0.5.0.0-1.fc20

Comment 6 Fedora Update System 2014-10-21 10:25:47 UTC
Package pyhoca-gui-0.5.0.0-1.fc20, pyhoca-cli-0.5.0.0-1.fc20, python-x2go-0.5.0.0-1.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing pyhoca-gui-0.5.0.0-1.fc20 pyhoca-cli-0.5.0.0-1.fc20 python-x2go-0.5.0.0-1.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-13341/pyhoca-gui-0.5.0.0-1.fc20,pyhoca-cli-0.5.0.0-1.fc20,python-x2go-0.5.0.0-1.fc20
then log in and leave karma (feedback).

Comment 7 Fedora Update System 2014-11-17 06:28:56 UTC
pyhoca-gui-0.5.0.0-1.fc20, pyhoca-cli-0.5.0.0-1.fc20, python-x2go-0.5.0.0-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.