Bug 109834 - mkboodisk creates incorrect syslinux.cfg file
mkboodisk creates incorrect syslinux.cfg file
Status: CLOSED DUPLICATE of bug 116446
Product: Red Hat Linux
Classification: Retired
Component: mkbootdisk (Show other bugs)
9
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Peter Vrabec
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-12 02:19 EST by Daniel Robitaille
Modified: 2007-04-18 12:59 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:59:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel Robitaille 2003-11-12 02:19:08 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i586; en-US; rv:1.5)
Gecko/20031007 Firebird/0.7

Description of problem:
mkbootdisk creates a floppy disk that is unbootable due to a syxtax
error in the created file syslinux.cfg

Version-Release number of selected component (if applicable):
mkbootdisk-1.5.1-1

How reproducible:
Always

Steps to Reproduce:
1. /sbin/mkbootdisk --device /dev/fd0 2.4.20-20.9
2. reboot computer with newly created bootable floppy
3.
    

Actual Results:  The computer experienced a kernal panic while trying
to boot using the newly created bootable floppy.

Additional info:

It seems the syslinux.cfg file created by the mkbootdisk script
contains a syntax error in the append line:

[root@localhost root]# cat /mnt/floppy/syslinux.cfg
default linux
prompt 1
display boot.msg
timeout 100
label linux
        kernel vmlinuz
        append initrd=initrd.img ro hdb=ide-scsi
ro hdb=ide-scsi root=/dev/hda7


If the append line is manually edited to make it back into one single
line without the extra bit about "ro" and "hdb=ide=scsi", the bootable
floppy works perfectly.

The problem is possibly linked to the fact that my / partition is
labelled "/1" as seen by my /etc/fstab file:

[root@localhost root]# cat /etc/fstab
LABEL=/1                /                       ext3    defaults     
  1 1
none                    /dev/pts                devpts  gid=5,mode=620
 0 0
none                    /proc                   proc    defaults     
  0 0
none                    /dev/shm                tmpfs   defaults     
  0 0
/dev/hda6               swap                    swap    defaults     
  0 0
/dev/cdrom              /mnt/cdrom              udf,iso9660
noauto,owner,kudzu,ro 0 0
/dev/fd0                /mnt/floppy             auto   
noauto,owner,kudzu 0 0
/dev/hda5               /mnt/redhat             ext3    noauto       
  0 0
/dev/hda1               /mnt/win_c              vfat   
noauto,iocharset=iso8859-1,codepage=850,umask=0 0 0
/dev/sda1               /mnt/removable          auto
user,iocharset=iso8859-1,codepage=850,noauto,umask=0,exec 0 0
Comment 1 Peter Vrabec 2004-10-12 10:28:52 EDT

*** This bug has been marked as a duplicate of 116446 ***
Comment 2 Red Hat Bugzilla 2006-02-21 13:59:57 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.