Bug 1098358 - [abrt] Run mail formatter in the main thread
Summary: [abrt] Run mail formatter in the main thread
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: evolution
Version: 7.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Matthew Barnes
QA Contact: Desktop QE
URL:
Whiteboard:
: 1119719 (view as bug list)
Depends On:
Blocks: 1113520
TreeView+ depends on / blocked
 
Reported: 2014-05-16 00:13 UTC by vinay
Modified: 2018-12-05 18:36 UTC (History)
6 users (show)

Fixed In Version: evolution-3.8.5-25
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-03-05 06:37:15 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:0305 normal SHIPPED_LIVE evolution bug fix update 2015-03-05 11:36:15 UTC
GNOME Bugzilla 724023 None None None Never

Description vinay 2014-05-16 00:13:04 UTC
Description of problem: evolution-3.8.5-21.el7: evolution killed by SIGSEGV

Issue is not reproducible


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info: 

Backtrace from core dump

(gdb) bt
#0  0x00007f3287075a08 in g_sequence_iter_get_sequence (iter=<optimized out>) at gsequence.c:1184
#1  0x00007f328952c567 in iter_is_valid (iter=0x7f31deffc890, list_store=0x2ef6b70) at gtkliststore.c:410
#2  0x00007f328952db0b in gtk_list_store_set_valist (list_store=0x2ef6b70, iter=0x7f31deffc890, var_args=var_args@entry=0x7f31deffc7b0) at gtkliststore.c:1149
#3  0x00007f328952dc34 in gtk_list_store_set (list_store=<optimized out>, iter=iter@entry=0x7f31deffc890) at gtkliststore.c:1195
#4  0x00007f3290329f41 in e_attachment_store_add_attachment (store=store@entry=0x2ef6b70, attachment=0x32718c0) at e-attachment-store.c:210
#5  0x00007f325f9952ad in emfe_attachment_format (extension=<optimized out>, formatter=0x7f3244008720, context=0x7f31d801f1a0, part=0x7f31d8006850, stream=0x7f31d80232a0, cancellable=0x340f2c0)
    at e-mail-formatter-attachment.c:150
#6  0x00007f325f991305 in e_mail_formatter_format_as (formatter=formatter@entry=0x7f3244008720, context=context@entry=0x7f31d801f1a0, part=part@entry=0x7f31d8006850, 
    stream=stream@entry=0x7f31d80232a0, as_mime_type=<optimized out>, as_mime_type@entry=0x0, cancellable=cancellable@entry=0x340f2c0) at e-mail-formatter.c:953
#7  0x00007f325f9951b6 in emfe_attachment_format (extension=<optimized out>, formatter=0x7f3244008720, context=0x7f31d801f1a0, part=0x7f31d801a000, stream=0x7f326002d0c0, cancellable=0x340f2c0)
    at e-mail-formatter-attachment.c:271
#8  0x00007f325f991305 in e_mail_formatter_format_as (formatter=formatter@entry=0x7f3244008720, context=context@entry=0x7f31d801f1a0, part=part@entry=0x7f31d801a000, 
    stream=stream@entry=0x7f326002d0c0, as_mime_type=<optimized out>, cancellable=cancellable@entry=0x340f2c0) at e-mail-formatter.c:953
#9  0x00007f325f9915c6 in mail_formatter_run (formatter=0x7f3244008720, context=0x7f31d801f1a0, stream=0x7f326002d0c0, cancellable=0x340f2c0) at e-mail-formatter.c:405
#10 0x00007f325f990df6 in e_mail_formatter_format_sync (formatter=formatter@entry=0x7f3244008720, parts=parts@entry=0x7f31d8002b60, stream=0x7f326002d0c0, 
    flags=E_MAIL_FORMATTER_HEADER_FLAG_COLLAPSABLE, mode=E_MAIL_FORMATTER_MODE_NORMAL, cancellable=cancellable@entry=0x340f2c0) at e-mail-formatter.c:795
#11 0x00007f32696256c0 in handle_mail_request (res=0x7f3260040ae0, object=<optimized out>, cancellable=0x340f2c0) at e-mail-request.c:170
#12 0x00007f32875f783f in run_in_thread (job=<optimized out>, c=0x340f2c0, _data=0x33f97a0) at gsimpleasyncresult.c:871
#13 0x00007f32875e5406 in io_job_thread (task=<optimized out>, source_object=<optimized out>, task_data=0x30c4100, cancellable=<optimized out>) at gioscheduler.c:89
#14 0x00007f32876048c5 in g_task_thread_pool_thread (thread_data=0x2b37410, pool_data=<optimized out>) at gtask.c:1242
#15 0x00007f32870810fc in g_thread_pool_thread_proxy (data=<optimized out>) at gthreadpool.c:309
#16 0x00007f3287080745 in g_thread_proxy (data=0x30f5a30) at gthread.c:798
#17 0x00007f328c75edf3 in start_thread (arg=0x7f31deffd700) at pthread_create.c:308
#18 0x00007f3286d483dd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:113
(gdb) q

Comment 1 Milan Crha 2014-05-19 05:58:08 UTC
Thanks for a bug report. I guess this is related to this upstream bug report:
https://bugzilla.gnome.org/show_bug.cgi?id=724023

It contains a fix too.

Comment 2 RHEL Product and Program Management 2014-05-27 05:47:11 UTC
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.

Comment 4 David Jaša 2014-08-26 08:53:48 UTC
*** Bug 1119719 has been marked as a duplicate of this bug. ***

Comment 7 errata-xmlrpc 2015-03-05 06:37:15 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-0305.html


Note You need to log in before you can comment on or make changes to this bug.