Bug 1119719 - evolution killed by SIGABRT
Summary: evolution killed by SIGABRT
Keywords:
Status: CLOSED DUPLICATE of bug 1098358
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: evolution
Version: 7.0
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Matthew Barnes
QA Contact: Desktop QE
URL:
Whiteboard: abrt_hash:3438264ab3058c0668f32328c44...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-15 11:01 UTC by David Jaša
Modified: 2014-08-26 08:53 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-26 08:53:48 UTC


Attachments (Terms of Use)
File: backtrace (171.82 KB, text/plain)
2014-07-15 11:01 UTC, David Jaša
no flags Details
File: cgroup (172 bytes, text/plain)
2014-07-15 11:01 UTC, David Jaša
no flags Details
File: core_backtrace (130.28 KB, text/plain)
2014-07-15 11:01 UTC, David Jaša
no flags Details
File: dso_list (33.33 KB, text/plain)
2014-07-15 11:01 UTC, David Jaša
no flags Details
File: environ (1.48 KB, text/plain)
2014-07-15 11:01 UTC, David Jaša
no flags Details
File: limits (1.29 KB, text/plain)
2014-07-15 11:01 UTC, David Jaša
no flags Details
File: maps (160.68 KB, text/plain)
2014-07-15 11:01 UTC, David Jaša
no flags Details
File: open_fds (759 bytes, text/plain)
2014-07-15 11:01 UTC, David Jaša
no flags Details
File: proc_pid_status (1.09 KB, text/plain)
2014-07-15 11:01 UTC, David Jaša
no flags Details
File: var_log_messages (37.34 KB, text/plain)
2014-07-15 11:01 UTC, David Jaša
no flags Details
File: binary (32.98 KB, application/octet-stream)
2014-07-15 11:01 UTC, David Jaša
no flags Details
File: sosreport.tar.xz (6.96 MB, application/octet-stream)
2014-07-15 11:01 UTC, David Jaša
no flags Details
backported patch (4.86 KB, patch)
2014-07-16 14:23 UTC, Milan Crha
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
GNOME Bugzilla 724023 None None None Never

Description David Jaša 2014-07-15 11:01:00 UTC
Version-Release number of selected component:
evolution-3.8.5-22.el7_0.1

Additional info:
reporter:       libreport-2.1.11
backtrace_rating: 4
cmdline:        evolution
crash_function: g_hash_table_resize
executable:     /usr/bin/evolution
kernel:         3.10.0-123.1.2.el7.x86_64
runlevel:       N 5
type:           CCpp
uid:            16189

Truncated backtrace:
Thread no. 1 (10 frames)
 #6 g_hash_table_resize at ghash.c:565
 #7 g_hash_table_maybe_resize at ghash.c:594
 #8 g_hash_table_remove_internal at ghash.c:1277
 #9 remove_binding_qdata at gbinding.c:221
 #10 weak_unbind at gbinding.c:246
 #11 weak_refs_notify at gobject.c:2470
 #13 handle_mail_request at e-mail-request.c:201
 #14 run_in_thread at gsimpleasyncresult.c:871
 #15 io_job_thread at gioscheduler.c:89
 #16 g_task_thread_pool_thread at gtask.c:1242

Comment 1 David Jaša 2014-07-15 11:01:03 UTC
Created attachment 918130 [details]
File: backtrace

Comment 2 David Jaša 2014-07-15 11:01:05 UTC
Created attachment 918131 [details]
File: cgroup

Comment 3 David Jaša 2014-07-15 11:01:07 UTC
Created attachment 918132 [details]
File: core_backtrace

Comment 4 David Jaša 2014-07-15 11:01:08 UTC
Created attachment 918133 [details]
File: dso_list

Comment 5 David Jaša 2014-07-15 11:01:10 UTC
Created attachment 918134 [details]
File: environ

Comment 6 David Jaša 2014-07-15 11:01:11 UTC
Created attachment 918135 [details]
File: limits

Comment 7 David Jaša 2014-07-15 11:01:13 UTC
Created attachment 918136 [details]
File: maps

Comment 8 David Jaša 2014-07-15 11:01:14 UTC
Created attachment 918137 [details]
File: open_fds

Comment 9 David Jaša 2014-07-15 11:01:15 UTC
Created attachment 918138 [details]
File: proc_pid_status

Comment 10 David Jaša 2014-07-15 11:01:17 UTC
Created attachment 918139 [details]
File: var_log_messages

Comment 11 David Jaša 2014-07-15 11:01:19 UTC
Created attachment 918140 [details]
File: binary

Comment 12 David Jaša 2014-07-15 11:01:51 UTC
Created attachment 918141 [details]
File: sosreport.tar.xz

Comment 14 Milan Crha 2014-07-16 08:41:47 UTC
I think a change from [1] should help here. Do you want a test package with that patch included, or you'll create one on your own?

[1] https://bugzilla.gnome.org/show_bug.cgi?id=724023

Comment 15 David Jaša 2014-07-16 09:25:12 UTC
(In reply to Milan Crha from comment #14)
> I think a change from [1] should help here. Do you want a test package with
> that patch included, or you'll create one on your own?
> 
> [1] https://bugzilla.gnome.org/show_bug.cgi?id=724023

I could try the package but as I don't have an actual reproducer [*], I'll be fine with fix included in 7.1 :)

[*] this crash happened when evo was in background

Comment 16 Milan Crha 2014-07-16 12:01:22 UTC
Then maybe just have it installed and see whether the crash will reoccur during the normal usage? The crash might happen when the preview panel was updating its content, for whatever reason it triggered it.

Comment 17 David Jaša 2014-07-16 12:23:05 UTC
Milan, please build the package, thank you.

Comment 18 Milan Crha 2014-07-16 14:23:12 UTC
Created attachment 918438 [details]
backported patch

for evolution;

This is a backported patch. The upstream patch did not apply cleanly, I forgot of it.

evolution-3.8.5-22.el7_0.1.1 contains the patch, it's currently available at:
https://brewweb.devel.redhat.com/taskinfo?taskID=7705503

Comment 19 Milan Crha 2014-08-25 17:13:14 UTC
Did this help? If yes, then we can mark this as a duplicate of bug #1098358, where I added a similar patch to evolution-3.8.5-25.

Comment 20 David Jaša 2014-08-26 08:53:48 UTC
Yes, I didn't encounter the crash since.

*** This bug has been marked as a duplicate of bug 1098358 ***


Note You need to log in before you can comment on or make changes to this bug.