Bug 109840 - System Freezes after changing to radeon 9600 driver.
System Freezes after changing to radeon 9600 driver.
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: XFree86 (Show other bugs)
1
i386 Linux
medium Severity high
: ---
: ---
Assigned To: X/OpenGL Maintenance List
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-12 02:50 EST by keith
Modified: 2007-11-30 17:10 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-09 19:02:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
lspci (9.17 KB, text/plain)
2003-11-13 14:23 EST, cervajs
no flags Details
xfree86 log, before log to the system (36.38 KB, text/plain)
2003-11-13 14:32 EST, cervajs
no flags Details
lspci -vvn (9.02 KB, text/plain)
2003-11-15 14:10 EST, Tacitus
no flags Details
XFree86.0.log (45.55 KB, text/plain)
2003-11-15 14:11 EST, Tacitus
no flags Details
/var/log/messages (44.34 KB, text/plain)
2003-11-15 14:12 EST, Tacitus
no flags Details

  None (edit)
Description keith 2003-11-12 02:50:47 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1)
Gecko/20030225

Description of problem:
When I install Fedora core 1 it won't automatically find my graphic
card.  It's a Radeon 9600 pro.  When I enter the configuration for the
desktop and manually change it to the correct driver, and then restart
X, the system freezes while starting KDE or Gnome and will not
recover.  Remains this way even upon restart.  

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.right click on desktop to configure 
2.select Radeon 9600 pro driver in lieu of generic probed driver
3.restart X
    

Actual Results:  system freezes

Additional info:
Comment 1 Karsten Hopp 2003-11-12 07:16:13 EST
x3270 (a terminal mostly used for mainframe access) is the wrong 
component. Changing to XFree86 
Comment 2 Mike A. Harris 2003-11-12 07:58:08 EST
Using the file attachment link below, attach your XFree86 log file
from after attempting to use the "radeon" driver with this card.

Please also attach /var/log/messages and the output of:

    lspci -vvn

This information will be helpful for troubleshooting this problem.

Thanks very much for reporting this issue.
Comment 3 keith 2003-11-12 09:40:45 EST
I'm afraid I can't get that information for you.  The nature of the
problem is I can't log in to Fedora no matter what I do.  It
litterally locks my computer up every time I turn it on.  I did go to
rescue mode and tried to get those things.

-the XFree86 log file.  I don't know where it is, but it returns
"fatal server error" whenever I try to access it from the rescue shell.

-/var/log/messages "no such file or directory"

-lspci -vvn, got a huge message for this, but can't attach it because
it's trapped inside Linux!
Comment 4 cervajs 2003-11-13 14:23:55 EST
Created attachment 95952 [details]
lspci
Comment 5 cervajs 2003-11-13 14:29:41 EST
i have the same problem
msi kt600, amd 2500 xp+, gigabyte radeon 9600 pro

Comment 6 cervajs 2003-11-13 14:32:01 EST
Created attachment 95954 [details]
xfree86 log, before log to the system

after log to the system (kde), system freeze
Comment 7 cervajs 2003-11-13 15:47:47 EST
with actual ati proprietary drivers xfree works
Comment 8 Tacitus 2003-11-15 14:10:01 EST
Created attachment 95995 [details]
lspci -vvn

This output obtained before going into X but I think it may not matter. 
Afterwards, it crashes too soon though.
Comment 9 Tacitus 2003-11-15 14:11:31 EST
Created attachment 95996 [details]
XFree86.0.log

Log copied after crash followed by a reboot into text mode.
Comment 10 Tacitus 2003-11-15 14:12:35 EST
Created attachment 95997 [details]
/var/log/messages

/var/log/messages across a crash followed by reboot into text mode.
Comment 11 Tacitus 2003-11-15 15:24:44 EST
Just tried the ATI proprietary drivers, and they work, I can use the
higher resolutions.  But Tux Racer is unplayably slow---my old Matrox
G400 is much faster...
Comment 12 Erik Karu 2003-12-19 13:49:20 EST
Me too! It's been over a month since last comment, is there some work
still going on behind the scene? Are there some test-RPMs I could try out?
Comment 13 Mike A. Harris 2003-12-19 21:42:32 EST
No, there is no work going on behind the scenes.  I will be working
on Radeon driver issues again some time in January probably at the
earliest.

This particular hardware is not officially supported, and I did the
work for this on my own personal time as a convenience to people who
have the hardware.  If it is a high priority to have this fixed
however, feel free to submit patches for me to review, and I can
try to set aside a few hours to do so.

Other than that, until I update this report with new information,
there is nothing new to report, and so no need to ask.

Thanks.
Comment 14 Syst3m Snip3r 2003-12-26 22:12:44 EST
Hi,

I'm new here but I have just purchased the Radeon 9600 XT on my 
Redhat 9 box. I've fully updated and installed the driver for X-Free 
from the ATI site but I still cant find any Radeon 9600 in the 
Graphic Card list on Redhat. I now cant even start up my system. I 
choose the 9700 (Thinking it was close enough) and now it brings up 
login screen, I log in and it freezes. I got into Redhat before using 
the VESA Generic card but the grpahics are really bad and not good. 
But now after I have changed I cant do anything! Any help would be 
appricated please.
Comment 15 Nigel Metheringham 2004-03-28 14:56:27 EST
I have the same problem (Radeon 9600 - I needed something fanless :-) )

Found a related posting to kernel list.
  http://seclists.org/lists/linux-kernel/2003/Dec/1510.html

It mentioned setting option "XaaNoScreenToScreenCopy" (ie edit
/etc/X11/XF86Config - you can get a text console by either pressing
Control-F1 at the X login window before the thing hangs, or add the
word "single" to the boot parameters by hitting a in grub.  When you
can get at the file to edit, find the "Device" section and add a
line with
        Option  "XaaNoScreenToScreenCopy"
within the section.

This appears to make the thing work - although performance is not
exactly blinding.
Comment 16 Nigel Metheringham 2004-03-29 07:24:50 EST
Suggest this is a duplicate of Bug #108729
Comment 17 Nigel Metheringham 2004-03-29 15:30:48 EST
Appears to be fixed in FC2 test2
[Other things crash the machine, but this doesn't :-) ]
Comment 18 Mike A. Harris 2004-03-29 16:55:42 EST
There are lots of duplicates in bugzilla, but I'm intentionally
leaving them all open for now.  I'll close the duplicates in
the future once I sweep through all X bugs doing major triage.

Comment 19 Erik Karu 2004-05-29 09:47:27 EDT
I'll make a note against "Appears to be fixed in FC2 test2"; with my
machine, FC2 (final) did not regocnize my Radeon 9600 Pro and used
VESA generic instead. Below are lspci -vvv and lspci -n.

root@localhost:~# lspci -vvv
00:00.0 Host bridge: VIA Technologies, Inc. VT8377 [KT400/KT600 AGP]
Host Bridge (rev 80)
        Subsystem: VIA Technologies, Inc. VT8377 [KT400/KT600 AGP]
Host Bridge
        Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop-
ParErr- Stepping- SERR- FastB2B-
        Status: Cap+ 66Mhz+ UDF- FastB2B- ParErr- DEVSEL=medium
>TAbort- <TAbort- <MAbort+ >SERR- <PERR-
        Latency: 8
        Region 0: Memory at b0000000 (32-bit, prefetchable)
        Capabilities: [80] AGP version 3.5
                Status: RQ=32 Iso- ArqSz=0 Cal=2 SBA+ ITACoh- GART64-
HTrans- 64bit- FW+ AGP3+ Rate=x4,x8
                Command: RQ=1 ArqSz=0 Cal=0 SBA- AGP- GART64- 64bit-
FW- Rate=<none>
        Capabilities: [c0] Power Management version 2
                Flags: PMEClk- DSI- D1- D2- AuxCurrent=0mA
PME(D0-,D1-,D2-,D3hot-,D3cold-)
                Status: D0 PME-Enable- DSel=0 DScale=0 PME-

00:01.0 PCI bridge: VIA Technologies, Inc. VT8237 PCI Bridge (prog-if
00 [Normal decode])
        Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop-
ParErr- Stepping- SERR+ FastB2B-
        Status: Cap+ 66Mhz+ UDF- FastB2B- ParErr- DEVSEL=medium
>TAbort- <TAbort- <MAbort- >SERR- <PERR-
        Latency: 0
        Bus: primary=00, secondary=01, subordinate=01, sec-latency=0
        I/O behind bridge: 0000c000-0000cfff
        Memory behind bridge: e0000000-e1ffffff
        Prefetchable memory behind bridge: c0000000-dfffffff
        Expansion ROM at 0000c000 [disabled] [size=4K]
        BridgeCtl: Parity- SERR- NoISA+ VGA+ MAbort- >Reset- FastB2B-
        Capabilities: [80] Power Management version 2
                Flags: PMEClk- DSI- D1+ D2- AuxCurrent=0mA
PME(D0-,D1-,D2-,D3hot-,D3cold-)
                Status: D0 PME-Enable- DSel=0 DScale=0 PME-

00:0f.0 IDE interface: VIA Technologies, Inc.
VT82C586A/B/VT82C686/A/B/VT823x/A/C PIPC Bus Master IDE (rev 06)
(prog-if 8a [Master SecP PriP])
        Subsystem: VIA Technologies, Inc.
VT82C586/B/VT82C686/A/B/VT8233/A/C/VT8235 PIPC Bus Master IDE
        Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop-
ParErr- Stepping- SERR- FastB2B-
        Status: Cap+ 66Mhz- UDF- FastB2B+ ParErr- DEVSEL=medium
>TAbort- <TAbort- <MAbort- >SERR- <PERR-
        Latency: 32
        Interrupt: pin A routed to IRQ 11
        Region 4: I/O ports at d000 [size=16]
        Capabilities: [c0] Power Management version 2
                Flags: PMEClk- DSI- D1- D2- AuxCurrent=0mA
PME(D0-,D1-,D2-,D3hot-,D3cold-)
                Status: D0 PME-Enable- DSel=0 DScale=0 PME-

00:11.0 ISA bridge: VIA Technologies, Inc. VT8237 ISA bridge [K8T800
South]
        Subsystem: VIA Technologies, Inc. VT8237 ISA bridge [K8T800 South]
        Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop-
ParErr- Stepping+ SERR- FastB2B-
        Status: Cap+ 66Mhz- UDF- FastB2B- ParErr- DEVSEL=medium
>TAbort- <TAbort- <MAbort- >SERR- <PERR-
        Latency: 0
        Capabilities: [c0] Power Management version 2
                Flags: PMEClk- DSI- D1- D2- AuxCurrent=0mA
PME(D0-,D1-,D2-,D3hot-,D3cold-)
                Status: D0 PME-Enable- DSel=0 DScale=0 PME-

00:11.5 Multimedia audio controller: VIA Technologies, Inc.
VT8233/A/8235/8237 AC97 Audio Controller (rev 60)
        Subsystem: Unknown device 1695:300c
        Control: I/O+ Mem- BusMaster- SpecCycle- MemWINV- VGASnoop-
ParErr- Stepping- SERR- FastB2B-
        Status: Cap+ 66Mhz- UDF- FastB2B- ParErr- DEVSEL=medium
>TAbort- <TAbort- <MAbort- >SERR- <PERR-
        Interrupt: pin C routed to IRQ 5
        Region 0: I/O ports at e400
        Capabilities: [c0] Power Management version 2
                Flags: PMEClk- DSI- D1+ D2+ AuxCurrent=0mA
PME(D0-,D1-,D2-,D3hot-,D3cold-)
                Status: D0 PME-Enable- DSel=0 DScale=0 PME-

00:12.0 Ethernet controller: VIA Technologies, Inc. VT6102 [Rhine-II]
(rev 78)
        Subsystem: Unknown device 1695:300c
        Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop-
ParErr- Stepping- SERR- FastB2B-
        Status: Cap+ 66Mhz- UDF- FastB2B- ParErr- DEVSEL=medium
>TAbort- <TAbort- <MAbort- >SERR- <PERR-
        Latency: 32 (750ns min, 2000ns max), Cache Line Size 08
        Interrupt: pin A routed to IRQ 11
        Region 0: I/O ports at e800
        Region 1: Memory at e2001000 (32-bit, non-prefetchable) [size=256]
        Capabilities: [40] Power Management version 2
                Flags: PMEClk- DSI- D1+ D2+ AuxCurrent=0mA
PME(D0+,D1+,D2+,D3hot+,D3cold+)
                Status: D0 PME-Enable- DSel=0 DScale=0 PME-

00:13.0 FireWire (IEEE 1394): VIA Technologies, Inc. IEEE 1394 Host
Controller (rev 80) (prog-if 10 [OHCI])
        Subsystem: Unknown device 1695:900e
        Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop-
ParErr- Stepping- SERR- FastB2B-
        Status: Cap+ 66Mhz- UDF- FastB2B- ParErr- DEVSEL=medium
>TAbort- <TAbort- <MAbort- >SERR- <PERR-
        Latency: 32 (8000ns max), Cache Line Size 08
        Interrupt: pin A routed to IRQ 5
        Region 0: Memory at e2002000 (32-bit, non-prefetchable)
        Region 1: I/O ports at ec00 [size=128]
        Capabilities: [50] Power Management version 2
                Flags: PMEClk- DSI- D1- D2+ AuxCurrent=0mA
PME(D0-,D1-,D2+,D3hot+,D3cold+)
                Status: D0 PME-Enable- DSel=0 DScale=0 PME-

01:00.0 VGA compatible controller: ATI Technologies Inc RV350 AP
[Radeon 9600] (prog-if 00 [VGA])
        Subsystem: PC Partner Limited GC-R9600PRO Primary [Sapphire]
        Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop-
ParErr- Stepping- SERR- FastB2B-
        Status: Cap+ 66Mhz+ UDF- FastB2B+ ParErr- DEVSEL=medium
>TAbort- <TAbort- <MAbort- >SERR- <PERR-
        Latency: 32 (2000ns min), Cache Line Size 08
        Interrupt: pin A routed to IRQ 11
        Region 0: Memory at c0000000 (32-bit, prefetchable)
        Region 1: I/O ports at c000 [size=256]
        Region 2: Memory at e1000000 (32-bit, non-prefetchable) [size=64K]
        Capabilities: [58] AGP version 3.0
                Status: RQ=256 Iso- ArqSz=0 Cal=0 SBA+ ITACoh- GART64-
HTrans- 64bit- FW+ AGP3+ Rate=x4,x8
                Command: RQ=1 ArqSz=0 Cal=0 SBA+ AGP- GART64- 64bit-
FW- Rate=<none>
        Capabilities: [50] Power Management version 2
                Flags: PMEClk- DSI- D1+ D2+ AuxCurrent=0mA
PME(D0-,D1-,D2-,D3hot-,D3cold-)
                Status: D0 PME-Enable- DSel=0 DScale=0 PME-

01:00.1 Display controller: ATI Technologies Inc RV350 AP [Radeon
9600] (Secondary)
        Subsystem: PC Partner Limited GC-R9600PRO Secondary [Sapphire]
        Control: I/O- Mem- BusMaster- SpecCycle- MemWINV- VGASnoop-
ParErr- Stepping- SERR- FastB2B-
        Status: Cap+ 66Mhz+ UDF- FastB2B+ ParErr- DEVSEL=medium
>TAbort- <TAbort- <MAbort- >SERR- <PERR-
        Region 0: Memory at d0000000 (32-bit, prefetchable) [disabled]
        Region 1: Memory at e1010000 (32-bit, non-prefetchable)
[disabled] [size=64K]
        Capabilities: [50] Power Management version 2
                Flags: PMEClk- DSI- D1+ D2+ AuxCurrent=0mA
PME(D0-,D1-,D2-,D3hot-,D3cold-)
                Status: D0 PME-Enable- DSel=0 DScale=0 PME-
root@localhost:~# lspci -n
00:00.0 Class 0600: 1106:3189 (rev 80)
00:01.0 Class 0604: 1106:b198
00:0f.0 Class 0101: 1106:0571 (rev 06)
00:11.0 Class 0601: 1106:3227
00:11.5 Class 0401: 1106:3059 (rev 60)
00:12.0 Class 0200: 1106:3065 (rev 78)
00:13.0 Class 0c00: 1106:3044 (rev 80)
01:00.0 Class 0300: 1002:4150
01:00.1 Class 0380: 1002:4170
root@localhost:~# 
Comment 20 Richard Ellis 2004-06-17 13:05:11 EDT
Same problems and experiences here. Eric's comment, above, is correct
in that Red Hat seems to work fine with this card and the VESA driver,
but you can do better: there's a proprietary driver available from ATi
that will work. The Radeon 9600 Pro was unsupported by Red Hat until
the latest update release, which contains the driver that's causing
all of the problems mentioned here. Either the driver itself is bad or
(equally likely) the installation equates used by the new hardware
detection and configuration routines aren't quite right. I have been
able to fix my own hung system, with some help from Franklin Abud of
Red Hat tech support. To emulate what I've done you will need access
to a working computer and a way to transport a 3.2 MB rpm file to a
location that Linux can reach. You need the working system to download
the proprietary driver for this card from ATi's web site. The file I
used is Red Hat specific and is called fglrx-4.3.0-3.7.6.i386.rpm
(other versions are available for earlier releases of XFree). To
acquire this and other hardware drivers before installing Red Hat, I
used a Win98 partition on my system (this is what I am replacing, but
a separate installed O/S IS handy in emergencies); other alternatives
may include using somebody else's computer. I moved downloaded rpm
files over to Linux in several ways, including copying the rpm files
to a ZIP drive (Linux had no problems reading and copying the files
from that media, although I didn't do anything special to tell it that
the ZIP disk was formatted for FAT filesystems). An even easier
approach is just to mount my Win partitions as VFAT Linux devices.
However, that approach won't be much help to people who aren't running
systems with more than one installed O/S.

So: if you have the ATi file in some form where Linux can get at it
and access to Linux Rescue mode from your boot floppy and the
installation CD-ROM disk #1, here's how to cure a hung installation
resulting from this bug. Boot from the floppy and issue the "Linux
Rescue" command. Follow instructions and once you're root, issue an
"su -" instruction because otherwise your path may not include the
directory (usually /usr/bin/X11) with the XFree configuration utility
(fglrxconfig) that you are gonna need to run. Go to the location with
the ATi rpm file and issue this command:

    rpm -Uh --force <ati_package_name>.rpm

This will overwrite the bad driver with one that works, more or less.
It will appear in the display settings applet as "unknown" (you can
rename it later when you use that applet; use ATi's lower-case "i" to
distinguish its name from that of the bad ATI Radeon 9600 Pro--note
upper-case "I" here--that has been causing all of this hoopla. I have
yet to figure out a way to enable 3D hardware acceleration but
otherwise the Radeon 9600 Pro works fine with this ATi driver. Once
it's been installed in XFree, you have one more chore before exiting
Rescue mode: issue the "fglrxconfig" command. You should get a
ATi-specific version of the program. If uncertain about some
responses, take the suggested defaults. When the configuration file is
written at the end of this routine, you're done. Remove the boot
floppy and exit rescue mode with a three-fingered reboot
(CTRL-ALT-DEL). Your Linux system should start okay (you may still
want to fiddle with stuff like terminal specs and resolutions in the
Display Settings applet).

For a Red Hat history of both use of the proprietary driver and also
encountering the bug reported here, see Red Hat Service Request 328934.
 
Comment 21 Mike A. Harris 2004-10-09 19:02:03 EDT
Radeon 9200/9600/9800, and the Pro, SE, and XT variants of these
are now officially supported in Fedora Core 2 and later OS releases.

Once you've upgraded to Fedora Core 2 or later, this hardware should
be automatically detected and configured.  If you experience problems
with the "radeon" driver in Fedora Core 2, please file a bug report
in the X.Org bugtracker located at http://bugs.freedesktop.org in
the "xorg" component.

Setting status to "CURRENTRELEASE"

Note You need to log in before you can comment on or make changes to this bug.