Bug 108729 - XFree86 causing machine to hang after logging in
XFree86 causing machine to hang after logging in
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: XFree86 (Show other bugs)
1
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-31 11:48 EST by Albert Sidelnik
Modified: 2007-11-30 17:10 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-09 19:27:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Configuration file for XFree86 (3.23 KB, text/plain)
2003-10-31 11:48 EST, Albert Sidelnik
no flags Details
XFree86 log file (33.36 KB, text/plain)
2003-10-31 11:49 EST, Albert Sidelnik
no flags Details
Output from lspci (1.12 KB, text/plain)
2003-10-31 11:49 EST, Albert Sidelnik
no flags Details
/var/log/messages (68.00 KB, text/plain)
2003-11-03 18:00 EST, Albert Sidelnik
no flags Details
XFree86 log file (33.38 KB, text/plain)
2003-11-03 18:01 EST, Albert Sidelnik
no flags Details
XF86Config File (3.23 KB, text/plain)
2003-11-03 18:02 EST, Albert Sidelnik
no flags Details
/var/log/messages (184.65 KB, text/plain)
2004-01-13 17:32 EST, Charles R. Anderson
no flags Details
/etc/X11/XF86Config (3.13 KB, text/plain)
2004-01-13 17:33 EST, Charles R. Anderson
no flags Details
/var/log/XFree86.0.log (37.15 KB, text/plain)
2004-01-13 17:34 EST, Charles R. Anderson
no flags Details

  None (edit)
Description Albert Sidelnik 2003-10-31 11:48:04 EST
Description of problem:
The instant after logging into a window manager (e.g. gnome),
the machine locks up during initialization in the spalsh screen.
This is a complete lockup (ctrl+alt+del,etc.. doesn't work). This
only happens when I have XFree86 using the Radeon 9800 driver, but works
fine in vesa mode. In Redhat 9, everything worked fine when using the drivers
ATI provided via their website. For hardware, I am using an ATI Radeon 9800 Pro
128MB. I've attached the XF86Conf, XF86.0.log file, as well as output from lspci.

Version-Release number of selected component (if applicable):
XFree86-4.3.0-42

How reproducible:
Everytime when using the Radeon settings, but works fine in VESA mode.

Steps to Reproduce:
1. Use redhat-config-XFree86 and select ATI Radeon 9800 Pro.
2. Restart X
3.
    
Actual results:
Machine locks up

Additional info:
P4 2.26, 1 GB ram, Radeon 9800 Pro 128MB
Comment 1 Albert Sidelnik 2003-10-31 11:48:47 EST
Created attachment 95630 [details]
Configuration file for XFree86
Comment 2 Albert Sidelnik 2003-10-31 11:49:12 EST
Created attachment 95631 [details]
XFree86 log file
Comment 3 Albert Sidelnik 2003-10-31 11:49:37 EST
Created attachment 95632 [details]
Output from lspci
Comment 4 Albert Sidelnik 2003-10-31 11:59:11 EST
Comment on attachment 95632 [details]
Output from lspci

00:00.0 Host bridge: Intel Corp. 82845G/GL [Brookdale-G] Chipset Host Bridge
(rev 01)
	Subsystem: Asustek Computer, Inc.: Unknown device 8093
	Flags: bus master, fast devsel, latency 0
	Memory at f8000000 (32-bit, prefetchable) [size=64M]
	Capabilities: [e4] #09 [0105]
	Capabilities: [a0] AGP version 2.0

00:01.0 PCI bridge: Intel Corp. 82845G/GL [Brookdale-G] Chipset AGP Bridge (rev
01) (prog-if 00 [Normal decode])
	Flags: bus master, 66Mhz, fast devsel, latency 64
	Bus: primary=00, secondary=01, subordinate=01, sec-latency=0
	I/O behind bridge: 0000d000-0000dfff
	Memory behind bridge: df000000-dfffffff
	Prefetchable memory behind bridge: e0000000-f7ffffff

00:1d.0 USB Controller: Intel Corp. 82801DB USB (Hub #1) (rev 01) (prog-if 00
[UHCI])
	Subsystem: Asustek Computer, Inc.: Unknown device 8089
	Flags: bus master, medium devsel, latency 0, IRQ 11
	I/O ports at b800 [size=32]

00:1d.1 USB Controller: Intel Corp. 82801DB USB (Hub #2) (rev 01) (prog-if 00
[UHCI])
	Subsystem: Asustek Computer, Inc.: Unknown device 8089
	Flags: bus master, medium devsel, latency 0, IRQ 5
	I/O ports at b400 [size=32]

00:1d.2 USB Controller: Intel Corp. 82801DB USB (Hub #3) (rev 01) (prog-if 00
[UHCI])
	Subsystem: Asustek Computer, Inc.: Unknown device 8089
	Flags: bus master, medium devsel, latency 0, IRQ 10
	I/O ports at b000 [size=32]

00:1d.7 USB Controller: Intel Corp. 82801DB USB2 (rev 01) (prog-if 20 [EHCI])
	Subsystem: Asustek Computer, Inc.: Unknown device 8089
	Flags: bus master, medium devsel, latency 0, IRQ 9
	Memory at de800000 (32-bit, non-prefetchable) [size=1K]
	Capabilities: [50] Power Management version 2
	Capabilities: [58] #0a [2080]

00:1e.0 PCI bridge: Intel Corp. 82801BA/CA/DB/EB PCI Bridge (rev 81) (prog-if
00 [Normal decode])
	Flags: bus master, fast devsel, latency 0
	Bus: primary=00, secondary=02, subordinate=02, sec-latency=32
	I/O behind bridge: 0000a000-0000afff
	Memory behind bridge: dd000000-de7fffff

00:1f.0 ISA bridge: Intel Corp. 82801DB LPC Interface Controller (rev 01)
	Flags: bus master, medium devsel, latency 0

00:1f.1 IDE interface: Intel Corp. 82801DB Ultra ATA Storage Controller (rev
01) (prog-if 8a [Master SecP PriP])
	Subsystem: Asustek Computer, Inc.: Unknown device 8089
	Flags: bus master, medium devsel, latency 0, IRQ 10
	I/O ports at <unassigned>
	I/O ports at <unassigned>
	I/O ports at <unassigned>
	I/O ports at <unassigned>
	I/O ports at f000 [size=16]
	Memory at 40000000 (32-bit, non-prefetchable) [size=1K]

01:00.0 VGA compatible controller: ATI Technologies Inc Radeon R350 [Radeon
9800] (prog-if 00 [VGA])
	Subsystem: ATI Technologies Inc: Unknown device 0002
	Flags: bus master, stepping, 66Mhz, medium devsel, latency 64, IRQ 11
	Memory at f0000000 (32-bit, prefetchable) [size=128M]
	I/O ports at d800 [size=256]
	Memory at df800000 (32-bit, non-prefetchable) [size=64K]
	Expansion ROM at effe0000 [disabled] [size=128K]
	Capabilities: [58] AGP version 2.0
	Capabilities: [50] Power Management version 2

01:00.1 Display controller: ATI Technologies Inc Radeon R350 [Radeon 9800]
(Secondary)
	Subsystem: ATI Technologies Inc: Unknown device 0003
	Flags: bus master, stepping, 66Mhz, medium devsel, latency 64
	Memory at e0000000 (32-bit, prefetchable) [size=128M]
	Memory at df000000 (32-bit, non-prefetchable) [size=64K]
	Capabilities: [50] Power Management version 2

02:08.0 Ethernet controller: Intel Corp. 82801BD PRO/100 VE (CNR) Ethernet
Controller (rev 81)
	Subsystem: Asustek Computer, Inc.: Unknown device 8071
	Flags: bus master, medium devsel, latency 32, IRQ 9
	Memory at de000000 (32-bit, non-prefetchable) [size=4K]
	I/O ports at a800 [size=64]
	Capabilities: [dc] Power Management version 2

02:0b.0 Multimedia audio controller: Creative Labs SB Audigy (rev 04)
	Subsystem: Creative Labs: Unknown device 1002
	Flags: bus master, medium devsel, latency 32, IRQ 9
	I/O ports at a400 [size=64]
	Capabilities: [dc] Power Management version 2

02:0b.1 Input device controller: Creative Labs SB Audigy MIDI/Game port (rev
04)	   Subsystem: Creative Labs: Unknown device 0060
	Flags: bus master, medium devsel, latency 32
	I/O ports at a000 [size=8]
	Capabilities: [dc] Power Management version 2

02:0b.2 FireWire (IEEE 1394): Creative Labs SB Audigy FireWire Port (rev 04)
(prog-if 10 [OHCI])
	Subsystem: Creative Labs SB Audigy FireWire Port
	Flags: bus master, medium devsel, latency 32, IRQ 9
	Memory at dd800000 (32-bit, non-prefetchable) [size=2K]
	Memory at dd000000 (32-bit, non-prefetchable) [size=16K]
	Capabilities: [44] Power Management version 2
Comment 5 Mike A. Harris 2003-11-03 14:25:06 EST
You are not using the Red Hat supplied kernel.  Before I can
investigate this matter deeper, you need to reproduce this problem
using the official Red Hat supplied binary kernel, and without
using any 3rd party kernel modules or custom compiled kernel modules
loaded into the running kernel.

Can you please try to reproduce this with the latest official Red Hat
kernel update, and then re-attach your X server log, and
/var/log/messages from that X session, and I'll see if I can
spot anything problematic.

Thanks in advance.
Comment 6 Albert Sidelnik 2003-11-03 18:00:33 EST
Created attachment 95692 [details]
/var/log/messages

Don't mind the modprobe "Can't locate module sound-slot-0".
Comment 7 Albert Sidelnik 2003-11-03 18:01:36 EST
Created attachment 95693 [details]
XFree86 log file
Comment 8 Albert Sidelnik 2003-11-03 18:02:13 EST
Created attachment 95694 [details]
XF86Config File
Comment 9 Albert Sidelnik 2003-11-03 18:09:23 EST
What is interesting is that when I apply ATI's drivers over this,
everything works fine. Should I possibly include the log/config files
from this setup as well?
Comment 10 Mike A. Harris 2003-11-03 18:41:47 EST
We don't support any proprietary video drivers, so that wouldn't
be useful.  The ATI proprietary drivers and the ones we ship
are completely different source code bases, and ATI's driver
is binary only.

Unfortunately, I don't see anything in your X log, kernel log
or config file that stands out to me.  I'll have to try to
reproduce this on real hardware in the future and then try to
debug it.  Please update this report with any new info you
come up with.  I'll update it also when I've got any new information
or requests.

Thanks
Comment 11 Tacitus 2003-11-10 01:41:38 EST
I am having the same problem with Fedora Core 1: after logging in to
the Gnome login screen, it brings up the splash where it loads a
progress bar of icons, but before putting in any icons it locks up
hard (no ctrl-alt-del etc).  If I instead try to switch to a failsafe
terminal from the Gnome login screen, it also locks up hard.

This is from a fresh install of Fedora Core 1.  The installer did not
autodetect my card, but gave me VESA.  It correctly autodetected my
monitor.  With that, I logged in fine and everything seemed to work
(albiet in low-resolution).  Then I ran the redhat X config to set it
to Radeon 9600 Pro, and 1280x1024.  After that, I always get the
lockup behavior described above.  I haven't tried the ATI drivers yet.

My hardware: Sapphire Radeon 9600 Pro UE, NEC FP2141 monitor, Pentium4
2.4C w/ HT on (am using stock nptlsmp kernel), Intel D875PBZ MB, 512MB
ECC PC3200, Audigy2, Seagate 7200.7 SATA.
Comment 12 Mike A. Harris 2003-12-18 12:59:34 EST
Related bug #109256 is probably the same issue.
Comment 13 Charles R. Anderson 2004-01-13 17:26:55 EST
I believe my issue is similar to this one, so I'm pasting it in here
instead of opening a new bug report.

XFree86 crashes during gnome splash screen on ATI Rage Mobility.

Description of problem:

Since Fedora Core 1 release, I have experienced freezes under XFree86
on my HP Omnibook 6000 with an ATI Rage Mobility chipset.  System was
fine under Red Hat Linux 9 and earlier.  When the system freezes,
ctrl-alt-backspace, ctrl-alt-delete, and Magic Sysrq keys do not work.
 System no longer responds to ping requests.  The mouse cursor doesn't
move, and caps lock/num lock no longer toggles the LEDs.

Most recently, I have tested this under FC rawhide/development, and
the freeze/crash is reproducible consistently during GNOME login,
about half way through the splash screen initialization.  Starting a
Failsafe session, then starting gnome-session manually from the xterm
that opens seems to avoid the freeze.

Turning off 2D acceleration using Option "Accel" "Off" in the
XF86Config Screen section prevents freezes, and the system is stable
with that configuration.  Likewise, using Option
"XaaNoScreenToScreenCopy" instead of the former option appears to
stablize the system.

Version-Release number of selected component (if applicable):

XFree86-4.3.0-45
kernel-2.6.1-1.34
"ati" driver

Additional info:
HP Omnibook 6000, Pentium III 600 MHz, 384 MB RAM

0000:01:00.0 VGA compatible controller: ATI Technologies Inc Rage
Mobility P/M AGP 2x (rev 64) (prog-if 00 [VGA])
        Subsystem: Hewlett-Packard Company: Unknown device 0010
Comment 14 Charles R. Anderson 2004-01-13 17:32:44 EST
Created attachment 96952 [details]
/var/log/messages
Comment 15 Charles R. Anderson 2004-01-13 17:33:16 EST
Created attachment 96953 [details]
/etc/X11/XF86Config
Comment 16 Charles R. Anderson 2004-01-13 17:34:13 EST
Created attachment 96955 [details]
/var/log/XFree86.0.log
Comment 17 Kevin Sigl 2004-02-16 00:25:28 EST
Just thought I'd pipe up and say my computer is behaving in exactly
the same manner as Charles explained. Including the option "Accel"
"Off" deal.

My system however is an x86_64 arch with a 9600 XT.
Comment 18 X-Ryl669 2004-02-28 10:04:30 EST
Same problem with me.

I've read somewhere that it seems to be related to the motherboard's 
chipset (issues with SiS648/FX and SiS745). Please tell me what is 
your mobo chipset, so that I could send you a kernel patch.
Comment 19 Chip Turner 2004-03-24 21:21:56 EST
I also am seeing this issue with a Radeon 9800 Pro on FC1 AMD64 using
the Asus K8V motherboard.  Option "XaaNoScreenToScreenCopy" fixes the
issue but is painfully slow.  When one of the lockups happens, the
following makes it into /var/log/messages:

Mar 24 21:09:52 hammer kernel: CPU 0: Machine Check Exception:
0000000000000004
Mar 24 21:09:52 hammer kernel: Northbridge Machine Check exception
b200000000070f0f 0
Mar 24 21:09:52 hammer kernel: Uncorrectable condition
Comment 20 Nigel Metheringham 2004-03-29 07:24:21 EST
Suggest this duplicates Bug #109840 
Comment 21 Mike A. Harris 2004-03-29 16:57:13 EST
There are lots of duplicates in bugzilla, but I'm intentionally
leaving them all open for now.  I'll close the duplicates in
the future once I sweep through all X bugs doing major triage.

Comment 22 Charles R. Anderson 2004-05-05 16:50:46 EDT
This problem is still there on my HP Omnibook 6000 with FC2T3 +
Development as of 20040505.  kernel-2.6.5-1.350, xorg-x11-6.7.0-0.5,
gnome-session-2.6.0-1.  The workaround of starting a Failsafe Session,
then typing "gnome-session&" still avoids the hard lockup.  After
using this workaround once, logging out (or killing X) and re-logging
in to a GNOME session normally works without locking up. 
Warm-rebooting also usually works without locking up.  Powering the
machine all the way down, then booting back up will cause the lockup
to reappear.
Comment 23 Mike A. Harris 2004-10-09 19:27:22 EDT
Radeon 9200/9600/9800, and the Pro, SE, and XT variants of these
are now officially supported in Fedora Core 2 and later OS releases.

Once you've upgraded to Fedora Core 2 or later, this hardware should
be automatically detected and configured.  If you experience problems
with the "radeon" driver in Fedora Core 2, please file a bug report
in the X.Org bugtracker located at http://bugs.freedesktop.org in
the "xorg" component.

Setting status to "CURRENTRELEASE"



Note You need to log in before you can comment on or make changes to this bug.