Bug 109884 - ppp0 can not be brought up or down for xdsl connection
ppp0 can not be brought up or down for xdsl connection
Status: CLOSED DUPLICATE of bug 109601
Product: Fedora
Classification: Fedora
Component: redhat-config-network (Show other bugs)
1
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-12 12:49 EST by Alex White
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:59:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Alex White 2003-11-12 12:49:29 EST
Description of problem: 

After using the GUI wizard for setting up xdsl connection, ppp0 can
not be shutdown with "ifdown ppp0". Nor can ppp0 be brought up with
"ifup ppp0" through "/etc/init.d/network restart".
"/etc/init.d/network stop"  "....start" reproduce error.


Version-Release number of selected component (if applicable):

Current (Fedora Core 1)

How reproducible:

Anytime redhat-config-network is used to create xdsl connection.

Steps to Reproduce:
1. Create connection using wizard for xdsl
2. Connection comes up through configuration wizard.
3. Shutdown connection via "/etc/init.d/network stop" or restart etc.
4. Watch ifdown/ifup tell you there is no ppp0 configuration.
  
Actual results:

ifdown and ifup (depending on if you are turning network off or on or
restarting it) errors out with ppp0 not having a configuration. It
then tells you how ifup/ifdown expects devices.

Expected results:

ppp0 should come up and go down cleanly.

Additional info:
Comment 1 Alex White 2003-11-12 13:00:51 EST
Here is some log information. Should have put this in originally, but
I thought there was another step. Sorry never used bugzilla before. ^_^

Start Log---

Nov 11 00:16:10 ghostlike network: Bringing up loopback interface: 
succeeded
Nov 11 00:16:12 ghostlike network: Bringing up interface eth0:  succeeded
Nov 11 00:16:15 ghostlike network: Bringing up interface eth1:  succeeded
Nov 11 00:16:15 ghostlike ifup: ./ifup: configuration for ppp0 not found.
Nov 11 00:16:15 ghostlike ifup: Usage: ifup <device name>
Nov 11 00:16:15 ghostlike network: Bringing up interface ppp0:  failed

Nov 11 17:39:28 ghostlike ifdown: usage: ifdown <device name>
Nov 11 17:39:28 ghostlike network: Shutting down interface ppp0:  failed
Nov 11 17:39:28 ghostlike network: Shutting down interface eth0: 
succeeded
Nov 11 17:39:28 ghostlike network: Shutting down interface eth1: 
succeeded
Nov 11 17:39:28 ghostlike network: Shutting down loopback interface: 
succeeded

-- End Log

I made the problem go away by simply changing the name of what
redhat-config-network made in /etc/sysconfig/network-scripts from
ifcfg-sbcglobal to ifcfg-ppp0.

Apparently the configuration script names the ppp0 connection after
your isp name. Is this actually a bug or just I should be naming my
isp ppp0 as opposed to sbcglobal. Either way, this is a work around
for users.
Comment 2 Andre Robatino 2003-11-12 14:47:51 EST
  This is a duplicate of bug #109601, which is now resolved.  Applying
the patch there to the file /etc/init.d/network fixes the problem.
Comment 3 Harald Hoyer 2003-11-25 10:22:38 EST

*** This bug has been marked as a duplicate of 109601 ***
Comment 4 Red Hat Bugzilla 2006-02-21 13:59:58 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.