Bug 109601 - /etc/init.d/network does not correctly handle xDSL connections
/etc/init.d/network does not correctly handle xDSL connections
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
: 108033 109411 109884 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-09 19:51 EST by Josi Romildo Malaquias
Modified: 2014-03-16 22:40 EDT (History)
4 users (show)

See Also:
Fixed In Version: 7.43-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-11-10 17:50:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to fix this (1.32 KB, patch)
2003-11-10 12:08 EST, Bill Nottingham
no flags Details | Diff
patch, take 2 (1.82 KB, patch)
2003-11-10 15:58 EST, Bill Nottingham
no flags Details | Diff

  None (edit)
Description Josi Romildo Malaquias 2003-11-09 19:51:02 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1)
Gecko/20031030

Description of problem:
To start up a xDSL connection, the script /etc/init.d/network calls
ifup with the device name of the connection as its argument (ppp0 in
my case), requiring the existence of a file named ifup-<device>
(ifup-ppp0 in my case) in the /etc/sysconfig/network-scripts
directory. But the internet-druid program, used to set up the
connection, creates a file ifup-<proavider name>, named after the
provider name (ifup-NetSuper in my case). As a consequence, the script
fails to bring up the connection.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Configure a xDSL connection with internet-druid, setting the
provider name to NetSuper, lets say. Also sets the connection to start
at initialization time.
2. 
3.
    

Actual Results:  At initialization time /etc/init.d/network fails to
start the connection, with a message saying that ifup did not find the
configuration file for the DEVICE used in the connection.

Expected Results:  The connection should be successfully stablished.

Additional info:

Making a symbolic link from
/etc/sysconfig/network-scripts/ifcfg-<provider name> to
/etc/sysconfig/network-scripts/ifcfg-<device name> solves the problem,
but then the connection is started twice (and the second time the
script fails because the connection is already up).
Comment 1 Andre Robatino 2003-11-10 00:14:39 EST
  This is the same as bug #109411 and bug #108033.  I applied the
patch provided in the bug #109411 bug report and it fixed it for me
(and the original reporter).
Comment 2 Bill Nottingham 2003-11-10 12:07:10 EST
*** Bug 109411 has been marked as a duplicate of this bug. ***
Comment 3 Bill Nottingham 2003-11-10 12:07:22 EST
*** Bug 108033 has been marked as a duplicate of this bug. ***
Comment 4 Bill Nottingham 2003-11-10 12:08:07 EST
Created attachment 95879 [details]
patch to fix this

Try the attached; it's a little more generic than the patch in the other bugs.
Comment 5 Andre Robatino 2003-11-10 15:12:56 EST
  Same result as with the patch in bug #109411 - works perfectly on
startup, but on shutdown there is no message

Shutting down interface [xdsl interface name] :

as there should be.
Comment 6 Bill Nottingham 2003-11-10 15:58:02 EST
Created attachment 95888 [details]
patch, take 2

This should fix one of the obvious ways that the ifdown step would get skipped.
Use this instead of the previous patch.
Comment 7 Andre Robatino 2003-11-10 17:46:03 EST
  I patched and rebooted.  It shut down the interface properly on
shutdown, and brought it up properly on startup.  I think it's fixed.
Comment 8 Bill Nottingham 2003-11-10 17:50:21 EST
Fixed in CVS, will be in 7.43-1.
Comment 9 Andre Robatino 2003-11-13 12:29:20 EST
  You might want to take another look at the patch.  The last time I
shutdown, I saw two identical shutdown messages for the xdsl
interface, the first succeeded and the second failed (since the
interface was already down).  This is the first time out of several
shutdowns where it happened.
Comment 10 Harald Hoyer 2003-11-25 10:22:40 EST
*** Bug 109884 has been marked as a duplicate of this bug. ***
Comment 11 Jef Spaleta 2004-02-02 12:15:23 EST
*** Bug 109607 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.