Bug 1098878 - OpenID login with FAS does not direct to userdashboard
Summary: OpenID login with FAS does not direct to userdashboard
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Zanata
Classification: Retired
Component: Authentication-OpenID   
(Show other bugs)
Version: 3.4
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: ---
: 3.7
Assignee: Alex Eng
QA Contact: Damian Jansen
URL:
Whiteboard:
Keywords:
: 1195855 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-05-19 06:29 UTC by David Mason
Modified: 2015-07-22 02:20 UTC (History)
5 users (show)

Fixed In Version: 3.7.0-SNAPSHOT (git-jenkins-zanata-server-github-pull-requests-3683)
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-07-22 02:20:02 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Bugzilla 1120016 None None None Never

Internal Trackers: 1120016

Description David Mason 2014-05-19 06:29:28 UTC
Description of problem:
Upon successful sign-in from the homepage, users are supposed to be directed to the user dashboard. When signing in with Fedora OpenID, users are returned to the homepage instead.

Version-Release number of selected component (if applicable):
Zanata 3.4.0-SNAPSHOT (git-server-3.3.2-349-g63aba73)

How reproducible:
Easy, always

Steps to Reproduce:
1. Navigate to the homepage of Zanata
2. Click 'Log In'
3. Select the 'Fedora' option and approve the authentication and approval

Actual results:
Zanata returns to the homepage upon successful login

Expected results:
Zanata shows user dashboard upon successful login

Comment 1 Ding-Yi Chen 2014-07-31 06:39:34 UTC
Tested with Zanata 3.4.3-SNAPSHOT (git-jenkins-zanata-server-github-pull-requests-1814)

The problem not only appear with FAS, but other OpenID as well.

Comment 2 Alex Eng 2015-06-01 02:54:23 UTC
*** Bug 1195855 has been marked as a duplicate of this bug. ***

Comment 3 Alex Eng 2015-06-01 02:55:55 UTC
Pull request:

https://github.com/zanata/zanata-server/pull/837

Comment 4 Damian Jansen 2015-06-02 04:24:52 UTC
Verified at e82fa395945f459d01891c42377770f08b96879f


Note You need to log in before you can comment on or make changes to this bug.