Bug 1098884 - Failed to create a vm from template
Summary: Failed to create a vm from template
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: oVirt
Classification: Retired
Component: ovirt-engine-core
Version: 3.5
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: ---
: 3.5.0
Assignee: Gilad Chaplik
QA Contact: Pavel Stehlik
URL:
Whiteboard: sla
Depends On:
Blocks: 1073943
TreeView+ depends on / blocked
 
Reported: 2014-05-19 06:56 UTC by Moti Asayag
Modified: 2016-02-10 19:42 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-10-17 12:39:22 UTC
oVirt Team: SLA


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 27800 master ABANDONED core: Ignore serialization of VM.getvNumaNodeList() Never
oVirt gerrit 27806 None None None Never

Description Moti Asayag 2014-05-19 06:56:53 UTC
Description of problem:
Creating a vm from template fails due to Vm entity serialization to the async_task table.

Version-Release number of selected component (if applicable):


How reproducible:
always

Steps to Reproduce:
1. Add a vm based on a template (other than the blank)


Actual results:
Vm left in image locked status forever.

Expected results:
Vm created successfully

Additional info:
Error created due to serialization attempt of VM.getNumaNodeList():

2014-05-18 14:04:22,933 ERROR [org.ovirt.engine.core.bll.CreateSnapshotFromTemplateCommand] (http--0.0.0.0-8080-1) [5fcf1348] Error during createTask for command: org.ovirt.engine.core.bll.CreateSnapshotFromTemplateCommand. Exception org.apache.commons.lang.SerializationException: org.codehaus.jackson.map.JsonMappingException: Unexpected token (VALUE_STRING), expected FIELD_NAME: missing property '@class' that is to contain type id  (for class org.ovirt.engine.core.common.businessentities.VmNumaNode)
     at [Source: java.io.StringReader@3a7418c7; line: 328, column: 25] (through reference chain: org.ovirt.engine.core.common.action.VmManagementParametersBase["vm"]->org.ovirt.engine.core.common.businessentities.VM["vNumaNodeList"]): org.apache.commons.lang.SerializationException: org.codehaus.jackson.map.JsonMappingException: Unexpected token (VALUE_STRING), expected FIELD_NAME: missing property '@class' that is to contain type id  (for class org.ovirt.engine.core.common.businessentities.VmNumaNode)
     at [Source: java.io.StringReader@3a7418c7; line: 328, column: 25] (through reference chain: org.ovirt.engine.core.common.action.VmManagementParametersBase["vm"]->org.ovirt.engine.core.common.businessentities.VM["vNumaNodeList"])
            at org.ovirt.engine.core.utils.serialization.json.JsonObjectDeserializer.readJsonString(JsonObjectDeserializer.java:86) [utils.jar:]

Comment 1 Sandro Bonazzola 2014-10-17 12:39:22 UTC
oVirt 3.5 has been released and should include the fix for this issue.


Note You need to log in before you can comment on or make changes to this bug.