Bug 1099024 - RFE: Manage storage node snapshots
Summary: RFE: Manage storage node snapshots
Status: CLOSED DUPLICATE of bug 1098071
Alias: None
Product: JBoss Operations Network
Classification: JBoss
Component: Documentation, Storage Node
Version: JON 3.2
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: ---
Assignee: Deon Ballard
QA Contact: Mike Foley
URL:
Whiteboard:
Keywords:
Depends On: 1074632 1074633
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-05-19 10:42 UTC by Heiko W. Rupp
Modified: 2018-12-05 18:37 UTC (History)
5 users (show)

(edit)
Clone Of: 1074633
(edit)
Last Closed: 2014-05-19 17:52:31 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 869703 None None None Never

Description Heiko W. Rupp 2014-05-19 10:42:37 UTC
I think we need to have documentation about the snapshots, what they are and when / how they are used.
https://access.redhat.com/site/documentation/en-US/Red_Hat_JBoss_Operations_Network/3.2/html/Admin_and_Config/storage-backup-restore.html mentions snapshots briefly and also explains that snapshots are taken nightly, but stops here. We need to add information, that they could e.g. be deleted after stored on magnetic tape and/or how long to keep them around.



+++ This bug was initially created as a clone of Bug #1074633 +++

+++ This bug was initially created as a clone of Bug #1074632 +++

Description of problem:
Snapshots are generated weekly during scheduled maintenance and when nodes are (un)deployed. A snapshot consists of hard links to SSTable files; consequently, it takes up little disk space. But when an SSTable is deleted during compaction, space will not be reclaimed if the SSTable is included in a snapshot. This can add up over time. There is currently nothing in place for managing snapshots. Here are a few possible options,

1) Move snapshots older than X to a specified location

2) Move all snapshots to a specified location

3) Delete snapshots older than X

4) Move N snapshots (from oldest to youngest) to a specified location

5) Delete N snapshots (from oldest to youngest) to a specified location

This could be done as a reoccurring operation. We could also introduce some new metrics to monitor snapshot disk usage similar to what we already have for the data directories. If the disk usage exceeds a threshold, we can fire an alert and perform one of the above actions. This is another good step we should take for providing storage node disk management.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 bkramer 2014-05-19 11:07:23 UTC
(In reply to Heiko W. Rupp from comment #0)
> I think we need to have documentation about the snapshots, what they are and
> when / how they are used.

This was already done in the https://bugzilla.redhat.com/show_bug.cgi?id=1098071.

Comment 2 Heiko W. Rupp 2014-05-19 17:52:31 UTC
Thanks bkramer - I will close this one as dup then.

*** This bug has been marked as a duplicate of bug 1098071 ***


Note You need to log in before you can comment on or make changes to this bug.