Bug 1099278 - Changing email address produces invalid email
Changing email address produces invalid email
Status: CLOSED CURRENTRELEASE
Product: Zanata
Classification: Community
Component: Component-Logic (Show other bugs)
3.4
Unspecified Unspecified
unspecified Severity high
: ---
: 3.5
Assigned To: Sean Flanigan
Zanata-QA Mailling List
:
Depends On:
Blocks: 1088122
  Show dependency treegraph
 
Reported: 2014-05-19 22:14 EDT by Sean Flanigan
Modified: 2015-01-26 18:27 EST (History)
2 users (show)

See Also:
Fixed In Version: 3.4.0-SNAPSHOT (git-server-3.3.2-353-g76254f5)
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-01-26 18:27:45 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sean Flanigan 2014-05-19 22:14:41 EDT
Description of problem:
  The email generated when changing email address is sent to the old email, and the activation link has no activation key (causing a 404).

Version-Release number of selected component (if applicable):
  3.4.0-SNAPSHOT (git-server-3.3.2-351-gdebfc4e) 

How reproducible:
Unknown

Steps to Reproduce:
1. Log in (I used Kerberos)
2. Visit Account Settings from the Dashboard
3. Submit a new email address
4. Log out

Actual results:
  Old email address receives an email with invalid activation link: https://zanata.example.com/account/validate_email/ 

Expected results:
  New email address receives an email with a working activation link, ie https://zanata.example.com/account/validate_email/${activationKey}

Additional info:

The 404 is because the key is missing.  If you add in a dummy key at the end of the URL, you get this message: "Invalid activation key But you can help us fix it!"

Regarding email activation, see also https://bugzilla.redhat.com/show_bug.cgi?id=1098863
Comment 1 Sean Flanigan 2014-05-19 23:53:45 EDT
https://github.com/zanata/zanata-server/pull/453
Comment 2 Damian Jansen 2014-05-20 00:56:34 EDT
Verified

Note You need to log in before you can comment on or make changes to this bug.