Bug 1099611 - system-config-printer should require gtk3 instead of gtk2
Summary: system-config-printer should require gtk3 instead of gtk2
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: system-config-printer
Version: 20
Hardware: x86_64
OS: Linux
unspecified
urgent
Target Milestone: ---
Assignee: Tim Waugh
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-05-20 18:14 UTC by Ahmed Kamal
Modified: 2016-01-08 08:09 UTC (History)
4 users (show)

Fixed In Version: system-config-printer-1.4.5-1.fc20
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-10 00:24:12 UTC


Attachments (Terms of Use)

Description Ahmed Kamal 2014-05-20 18:14:02 UTC
Description of problem:
system-config-printer fails to start

Version-Release number of selected component (if applicable):


How reproducible:
100% everytime

Steps to Reproduce:
1. run system-config-printer
2. You get this stack trace
/usr/lib64/python2.7/site-packages/gi/overrides/Gtk.py:49: RuntimeWarning: You have imported the Gtk 2.0 module.  Because Gtk 2.0 was not designed for use with introspection some of the interfaces and API will fail.  As such this is not supported by the pygobject development team and we encourage you to port your app to Gtk 3 or greater. PyGTK is the recomended python module to use with Gtk 2.0
  warnings.warn(warn_msg, RuntimeWarning)
Traceback (most recent call last):
  File "/usr/share/system-config-printer/newprinter.py", line 2627, in on_expNPDeviceURIs_expanded
    padding, pack_type) = parent.query_child_packing (widget)
TypeError: query_child_packing() takes exactly 6 arguments (2 given)
Traceback (most recent call last):
  File "/usr/share/system-config-printer/system-config-printer.py", line 2132, in <module>
    main(show_jobs)
  File "/usr/share/system-config-printer/system-config-printer.py", line 2106, in main
    mainwindow = GUI()
  File "/usr/share/system-config-printer/system-config-printer.py", line 428, in __init__
    [Gtk.TargetEntry.new("queue", 0, 0)],
AttributeError: type object 'TargetEntry' has no attribute 'new'

Comment 1 Jiri Popelka 2014-05-21 11:47:30 UTC
What do the following commands show ?
# rpm -q system-config-printer gtk2 gtk3 pygobject3-base gobject-introspection
# rpm -V system-config-printer gtk2 gtk3 pygobject3-base gobject-introspection

Comment 2 Ahmed Kamal 2014-05-21 13:02:36 UTC
This system is a minimal (server) install, onto which I installed system-config-printer on, along with a vnc server. Maybe it's a missing dependency thing

# rpm -q system-config-printer gtk2 gtk3 pygobject3-base gobject-introspection
system-config-printer-1.4.4-1.fc20.x86_64
gtk2-2.24.22-2.fc20.x86_64
package gtk3 is not installed
pygobject3-base-3.10.2-1.fc20.x86_64
gobject-introspection-1.38.0-1.fc20.x86_64

Comment 3 Jiri Popelka 2014-05-21 15:35:56 UTC
Ahmed, can you install gtk3 package to see if that solves the problem ?

Tim, we still require gtk2 for s-c-printer.
Shouldn't we require gtk3 instead since the move to gobject introspection (1.4.0)?

Comment 4 Tim Waugh 2014-05-21 16:07:55 UTC
Yes, I bet that's it.

Comment 5 Ahmed Kamal 2014-05-22 07:56:25 UTC
Confirmed, installing gtk3 solves it
Perhaps all other system-config-* should be looked at

Comment 6 Jiri Popelka 2014-05-22 08:50:31 UTC
Thanks

Comment 7 Fedora Update System 2014-07-04 16:32:08 UTC
system-config-printer-1.4.5-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/system-config-printer-1.4.5-1.fc20

Comment 8 Fedora Update System 2014-07-05 14:56:05 UTC
Package system-config-printer-1.4.5-1.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing system-config-printer-1.4.5-1.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-8100/system-config-printer-1.4.5-1.fc20
then log in and leave karma (feedback).

Comment 9 Fedora Update System 2014-07-10 00:24:12 UTC
system-config-printer-1.4.5-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 10 Kir Kolyshkin 2016-01-08 08:07:47 UTC
I just discovered the very same bug in CentOS 7. I started with a minimal install and then did 'yum install system-config-printer' which resulted in the same error as above.

So, the bug is not fixed in RHEL7, so I filed #1296815

Comment 11 Kir Kolyshkin 2016-01-08 08:09:13 UTC
I mean, bug #1296815


Note You need to log in before you can comment on or make changes to this bug.