Bug 1099671 - Content View package and puppet module count is stuck at 0
Summary: Content View package and puppet module count is stuck at 0
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Content Management
Version: 6.0.4
Hardware: Unspecified
OS: Unspecified
unspecified
high vote
Target Milestone: Unspecified
Assignee: Partha Aji
QA Contact: Og Maciel
URL: http://projects.theforeman.org/issues...
Whiteboard:
: 1122201 (view as bug list)
Depends On:
Blocks: GSS_Sat6Beta_Tracker, GSS_Sat6_Tracker
TreeView+ depends on / blocked
 
Reported: 2014-05-20 23:07 UTC by Mike McCune
Modified: 2019-09-26 15:45 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Release Note
Doc Text:
This is a page refresh issue. The count is updated if the user navigates to a different page and then comes back.
Clone Of:
Environment:
Last Closed: 2014-09-11 12:26:42 UTC


Attachments (Terms of Use)
screenshot (23.42 KB, image/png)
2014-05-20 23:07 UTC, Mike McCune
no flags Details
count still '0' for version 3 (30.88 KB, image/png)
2014-06-04 07:26 UTC, Sachin Ghai
no flags Details
Count 'O' after publishing the CV (37.51 KB, image/png)
2014-06-05 11:27 UTC, Sachin Ghai
no flags Details
content view publish showing zero packages (113.37 KB, image/png)
2014-08-11 15:05 UTC, sthirugn@redhat.com
no flags Details
Content View packages listed after publishing (90.75 KB, image/png)
2014-08-15 14:34 UTC, Og Maciel
no flags Details


Links
System ID Priority Status Summary Last Updated
Foreman Issue Tracker 5858 None None None 2016-04-22 16:06:40 UTC

Description Mike McCune 2014-05-20 23:07:33 UTC
Created attachment 897759 [details]
screenshot

Publishing views with repos containing packages doesn't show the correct counts in the Content View version page:

0 Packages
0 Errata ( 0 0 0 )

see attached screenshot, it should show 400+ packages.

Comment 1 RHEL Product and Program Management 2014-05-20 23:34:36 UTC
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 3 Partha Aji 2014-05-21 17:43:18 UTC
Created redmine issue http://projects.theforeman.org/issues/5858 from this bug

Comment 4 Partha Aji 2014-06-03 18:07:28 UTC
should be fixed with pulp-server-2.4.0-0.18.beta.el6.noarch and greater

Comment 5 Sachin Ghai 2014-06-04 07:24:38 UTC
verified with sat6 beta snap7 compose2 (Satellite-6.0.3-RHEL-6-20140528.4)

UI doesn't update the package/errata count as soon as CV publish is finished, you need to navigate away from that tab/page and when you come back the count will be updated. 

Will wait for next compose to verify it again. Otherwise, will re-open it.

Comment 6 Sachin Ghai 2014-06-04 07:26:19 UTC
Created attachment 902013 [details]
count still '0' for version 3

Comment 7 Sachin Ghai 2014-06-05 11:26:46 UTC
verified with sat6 beta snap8 (Satellite-6.0.3-RHEL-6-20140604.0)

I can still see the count '0' for package, errata and puppet modules.

Comment 8 Sachin Ghai 2014-06-05 11:27:23 UTC
Created attachment 902497 [details]
Count 'O' after publishing the CV

Comment 9 Sachin Ghai 2014-06-05 11:29:10 UTC
Looks like if I navigate away from version tab and come back.. then count is updated. But I think it should be updated as soon as publish is finished.

Comment 10 Partha Aji 2014-07-21 22:15:00 UTC
https://github.com/Katello/katello/pull/4467 <- should get fixed with this.

Comment 11 Brad Buckingham 2014-07-24 11:20:41 UTC
*** Bug 1122201 has been marked as a duplicate of this bug. ***

Comment 14 sthirugn@redhat.com 2014-08-11 15:04:55 UTC
Failed.

I published a new version of content view and it showed zero packages, zero errata (see screenshot)

Version Tested:
GA Snap 4 - Satellite-6.0.4-RHEL-6-20140806.0

* apr-util-ldap-1.3.9-3.el6_0.1.x86_64
* candlepin-0.9.19-1.el6_5.noarch
* candlepin-scl-1-5.el6_4.noarch
* candlepin-scl-quartz-2.1.5-5.el6_4.noarch
* candlepin-scl-rhino-1.7R3-1.el6_4.noarch
* candlepin-scl-runtime-1-5.el6_4.noarch
* candlepin-selinux-0.9.19-1.el6_5.noarch
* candlepin-tomcat6-0.9.19-1.el6_5.noarch
* elasticsearch-0.90.10-4.el6sat.noarch
* foreman-1.6.0.38-1.el6sat.noarch
* foreman-compute-1.6.0.38-1.el6sat.noarch
* foreman-gce-1.6.0.38-1.el6sat.noarch
* foreman-libvirt-1.6.0.38-1.el6sat.noarch
* foreman-ovirt-1.6.0.38-1.el6sat.noarch
* foreman-postgresql-1.6.0.38-1.el6sat.noarch
* foreman-proxy-1.6.0.23-1.el6sat.noarch
* foreman-selinux-1.6.0.4-1.el6sat.noarch
* foreman-vmware-1.6.0.38-1.el6sat.noarch
* katello-1.5.0-28.el6sat.noarch
* katello-ca-1.0-1.noarch
* katello-certs-tools-1.5.6-1.el6sat.noarch
* katello-installer-0.0.57-1.el6sat.noarch
* openldap-2.4.23-34.el6_5.1.x86_64
* pulp-katello-0.3-3.el6sat.noarch
* pulp-nodes-common-2.4.0-0.30.beta.el6sat.noarch
* pulp-nodes-parent-2.4.0-0.30.beta.el6sat.noarch
* pulp-puppet-plugins-2.4.0-0.30.beta.el6sat.noarch
* pulp-puppet-tools-2.4.0-0.30.beta.el6sat.noarch
* pulp-rpm-plugins-2.4.0-0.30.beta.el6sat.noarch
* pulp-selinux-2.4.0-0.30.beta.el6sat.noarch
* pulp-server-2.4.0-0.30.beta.el6sat.noarch
* python-ldap-2.3.10-1.el6.x86_64
* ruby193-rubygem-net-ldap-0.3.1-3.el6sat.noarch
* ruby193-rubygem-runcible-1.1.0-2.el6sat.noarch
* sssd-ldap-1.11.5.1-3.el6.x86_64

Comment 15 sthirugn@redhat.com 2014-08-11 15:05:26 UTC
Created attachment 925810 [details]
content view publish showing zero packages

Comment 16 Partha Aji 2014-08-15 02:31:33 UTC
Suresh can you give this a try on Snap 5. I could not reproduce on it. Marking this as need info, please fail it if it recurs.

Comment 17 Og Maciel 2014-08-15 14:34:39 UTC
Created attachment 927136 [details]
Content View packages listed after publishing

Comment 18 Og Maciel 2014-08-15 14:36:29 UTC
VERIFIED publishing separate content views with RHEL 5 and 6 + puppet module.

Browser:
--------
* Firefox 31.0 Mac OS

Build:
------
* Satellite-6.0.4-RHEL-6-20140813.2

Packages:
---------
* candlepin-0.9.23-1.el7.noarch
* candlepin-common-1.0.1-1.el7.noarch
* candlepin-guice-3.0-2_redhat_1.el7.noarch
* candlepin-scl-1-5.el7.noarch
* candlepin-scl-quartz-2.1.5-6.el7.noarch
* candlepin-scl-rhino-1.7R3-3.el7.noarch
* candlepin-scl-runtime-1-5.el7.noarch
* candlepin-selinux-0.9.23-1.el7.noarch
* candlepin-tomcat-0.9.23-1.el7.noarch
* elasticsearch-0.90.10-4.el7sat.noarch
* foreman-1.6.0.40-1.el7sat.noarch
* foreman-compute-1.6.0.40-1.el7sat.noarch
* foreman-gce-1.6.0.40-1.el7sat.noarch
* foreman-libvirt-1.6.0.40-1.el7sat.noarch
* foreman-ovirt-1.6.0.40-1.el7sat.noarch
* foreman-postgresql-1.6.0.40-1.el7sat.noarch
* foreman-proxy-1.6.0.27-1.el7sat.noarch
* foreman-selinux-1.6.0.6-1.el7sat.noarch
* foreman-vmware-1.6.0.40-1.el7sat.noarch
* katello-1.5.0-28.el7sat.noarch
* katello-ca-1.0-1.noarch
* katello-certs-tools-1.5.6-1.el7sat.noarch
* katello-installer-0.0.59-1.el7sat.noarch
* openldap-2.4.39-3.el7.x86_64
* pulp-katello-0.3-3.el7sat.noarch
* pulp-nodes-common-2.4.0-0.30.beta.el7sat.noarch
* pulp-nodes-parent-2.4.0-0.30.beta.el7sat.noarch
* pulp-puppet-plugins-2.4.0-0.30.beta.el7sat.noarch
* pulp-puppet-tools-2.4.0-0.30.beta.el7sat.noarch
* pulp-rpm-plugins-2.4.0-0.30.beta.el7sat.noarch
* pulp-selinux-2.4.0-0.30.beta.el7sat.noarch
* pulp-server-2.4.0-0.30.beta.el7sat.noarch
* python-ldap-2.4.6-6.el7.x86_64
* ruby193-rubygem-net-ldap-0.3.1-3.el7sat.noarch
* ruby193-rubygem-runcible-1.1.0-2.el7sat.noarch
* rubygem-hammer_cli-0.1.1-11.el7sat.noarch
* rubygem-hammer_cli_foreman-0.1.1-15.el7sat.noarch
* rubygem-hammer_cli_foreman_tasks-0.0.3-3.el7sat.noarch
* rubygem-hammer_cli_katello-0.0.4-12.el7sat.noarch

Comment 19 Bryan Kearney 2014-09-11 12:26:42 UTC
This was delivered with Satellite 6.0 which was released on 10 September 2014.


Note You need to log in before you can comment on or make changes to this bug.