Bug 1099904 - ReferenceError: taxonomy_added is not defined
Summary: ReferenceError: taxonomy_added is not defined
Status: CLOSED DUPLICATE of bug 1112346
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Users & Roles
Version: 6.0.3
Hardware: Unspecified
OS: Unspecified
unspecified
low vote
Target Milestone: Unspecified
Assignee: Stephen Benjamin
QA Contact: Katello QA List
URL:
Whiteboard:
Keywords: Triaged
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-05-21 13:19 UTC by Og Maciel
Modified: 2017-04-24 14:25 UTC (History)
3 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2014-08-28 15:30:52 UTC


Attachments (Terms of Use)

Description Og Maciel 2014-05-21 13:19:57 UTC
Description of problem:

I added a 389-DS box to provide LDAP authentication to my Satellite 6 server and then tried to log in to the web ui using a user I had previously created in the 389-DS server. Since this was the first time I had logged in as that user, the UI limited what I could see and do.

I logged off and logged back in as the admin user and tried to edit my 389-DS user so that he would have access to ACME_Corporation and Firebug showed me the following error:

  ReferenceError: taxonomy_added is not defined

It doesn't look like this prevented me from saving my changes and once I logged out and logged back in as the other user, I was then able to see the organization ACME_Corporation.

Version-Release number of selected component (if applicable):

* apr-util-ldap-1.3.9-3.el6_0.1.x86_64
* candlepin-0.9.7-1.el6_5.noarch
* candlepin-scl-1-5.el6_4.noarch
* candlepin-scl-quartz-2.1.5-5.el6_4.noarch
* candlepin-scl-rhino-1.7R3-1.el6_4.noarch
* candlepin-scl-runtime-1-5.el6_4.noarch
* candlepin-selinux-0.9.7-1.el6_5.noarch
* candlepin-tomcat6-0.9.7-1.el6_5.noarch
* elasticsearch-0.90.10-4.el6sat.noarch
* foreman-1.6.0.8-1.el6sat.noarch
* foreman-compute-1.6.0.8-1.el6sat.noarch
* foreman-gce-1.6.0.8-1.el6sat.noarch
* foreman-libvirt-1.6.0.8-1.el6sat.noarch
* foreman-ovirt-1.6.0.8-1.el6sat.noarch
* foreman-postgresql-1.6.0.8-1.el6sat.noarch
* foreman-proxy-1.6.0.5-1.el6sat.noarch
* foreman-selinux-1.6.0-2.el6sat.noarch
* foreman-vmware-1.6.0.8-1.el6sat.noarch
* katello-1.5.0-24.el6sat.noarch
* katello-ca-1.0-1.noarch
* katello-certs-tools-1.5.5-1.el6sat.noarch
* katello-installer-0.0.40-1.el6sat.noarch
* openldap-2.4.23-32.el6_4.1.x86_64
* pulp-katello-plugins-0.3-1.el6sat.noarch
* pulp-nodes-common-2.4.0-0.16.beta.el6sat.noarch
* pulp-nodes-parent-2.4.0-0.16.beta.el6sat.noarch
* pulp-puppet-plugins-2.4.0-0.16.beta.el6sat.noarch
* pulp-puppet-tools-2.4.0-0.16.beta.el6sat.noarch
* pulp-rpm-plugins-2.4.0-0.16.beta.el6sat.noarch
* pulp-selinux-2.4.0-0.16.beta.el6sat.noarch
* pulp-server-2.4.0-0.16.beta.el6sat.noarch
* python-ldap-2.3.10-1.el6.x86_64
* ruby193-rubygem-ldap_fluff-0.2.2-2.el6sat.noarch
* ruby193-rubygem-net-ldap-0.3.1-3.el6sat.noarch
* ruby193-rubygem-runcible-1.1.0-2.el6sat.noarch
* rubygem-hammer_cli-0.1.0-13.el6sat.noarch
* rubygem-hammer_cli_foreman-0.1.0-13.el6sat.noarch
* rubygem-hammer_cli_foreman_tasks-0.0.2-6.el6sat.noarch
* rubygem-hammer_cli_katello-0.0.3-24.el6sat.noarch

How reproducible:


Steps to Reproduce: Make sure you have Firebug running
1. Add a valid LDAP provider to your sat6 box with a valid user, making sure to check the option that will create new users on foreman the first time they login
2. Log in as said "LDAP user" then log out 
3. Log in as the admin user and edit the "LDAP user" by adding ACME_Corporation to it

Actual results:

Editing the user works fine but there's an error shown by firebug

Expected results:


Additional info:

Browser used was Firefox 29.0.1 on MacOS

Comment 2 Stephen Benjamin 2014-06-23 11:18:46 UTC
I can't reproduce this on Katello or latest Satellite 6.  The POST request to modify the user (should be POST 3-username) returns successful.  I don't see any errors in Firebug.

Maybe try on the latest version? katello-1.5.0-26.el6sat.

If you get the error again, can you give me the exact request that results in the error?

Comment 3 Dominic Cleal 2014-08-28 15:30:52 UTC

*** This bug has been marked as a duplicate of bug 1112346 ***


Note You need to log in before you can comment on or make changes to this bug.