Bug 110016 - needs portugues.alias?
needs portugues.alias?
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: aspell-pt (Show other bugs)
1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Eido Inoue
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-13 19:48 EST by Henrique Martins
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-28 10:27:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
A patch to create the portugues and brasileiro alias. (3.30 KB, patch)
2004-06-21 15:38 EDT, Gustavo Maciel Dias Vieira
no flags Details | Diff

  None (edit)
Description Henrique Martins 2003-11-13 19:48:04 EST
Description of problem:

ispell/aspell fails from xemacs/emacs.  After some debugging, cause is
that ispell.el (see below *) calls for "-d portugues" to specificy the
portuguese dictionary instead of "-d portuguese".  In /usr/lib/aspell
there's a portuguese.alias file but not a portugues.alias file (same
for brazilian.alias, where a brasileiro.alias file may be needed.) 
Confront this with the files that come with aspell-fr where both
french.alias and francais.alias are present.

*actually the ispell.el (version 3.3.) shipped with xemacs doesn't
even mention portuguese, but the latest stable available on the web
(version 3.6) uses "-d portugues" as well as my .emacs file did before
3.6 was available.

Also "ispell/aspell -d portugues" will fail from the command line, but
I never use it that way.

Version-Release number of selected component (if applicable):
aspell-pt-0.50-6

How reproducible:
always

Steps to Reproduce:
1. run "aspell -d portugues -c <file>"
2.
3.
  
Actual results:
Error: The file "/usr/lib/aspell/portugues" can not be opened for reading.

Expected results:
file spelled

Additional info:
creating portugues.alias as a link to portuguese.alias (and also
brasileiro.alias to brazilian.alias) in /usr/lib/aspell fixes it
Comment 1 Eido Inoue 2004-04-28 10:27:23 EDT
Portuguese has a problem with its alias file in that it uses non-ascii
in the filename-- and the non-ascii is not in UTF-8, which is required
by RHL 8.0 and later.

It (both rpm and aspell 0.50) did not like the conversion from
iso-8859-1 filename to utf-8 (could not find it), so it was
intentionally removed.

The next version of aspell, which has UTF-8 support, will restore this
functionality.
Comment 2 Gustavo Maciel Dias Vieira 2004-06-21 15:37:11 EDT
This problem has nothing to do with UTF-8.

Emacs/Xemacs (in its ispell.el module) for some strange reason expects
that Portuguese and Brazilian dictionaries will be named portugues and
brasileiro. These are simple ASCII names. The aspell-pt dictionary
really has a weird português.alias, but that's not the problem. The
problem is the missing portugues and brasileiro alias (yes, brasileiro
also, see bug #104843).

Most modern programs that use aspell probably are using the ISO
language code to especify dictionaries. Emacs/Xemacs don't.
Emacs/Xemacs will be very happy if it worked ou of the box (even
though I suppose they have been customizing it since the dawn of time :)).

I'm creating an attachment with a replacement for the current
aspell-pt-0.50-2.ascii.patch present in the source rpm. This patch
removes the ISO-8859-1 alias and creates the ASCII ones. I have sent a
similar patch upstream and I will see to it being applied.

I would love to have this patch accepted for Fedora, or at least this
bug reopened, as UTF-8 won't help here.
Comment 3 Gustavo Maciel Dias Vieira 2004-06-21 15:38:38 EDT
Created attachment 101305 [details]
A patch to create the portugues and brasileiro alias.

Note You need to log in before you can comment on or make changes to this bug.