Bug 110026 - Click to create New or to Open Contact causes crash
Summary: Click to create New or to Open Contact causes crash
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: evolution
Version: 1
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-11-14 04:25 UTC by marty diamond
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

(edit)
Clone Of:
(edit)
Last Closed: 2004-02-05 01:22:30 UTC


Attachments (Terms of Use)

Description marty diamond 2003-11-14 04:25:22 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20031007

Description of problem:
Application "evolution" (process 7463 ) has crashed
due to a fatal error.
(Segmentation fault)

Version-Release number of selected component (if applicable):
evolution-1.4.5-7

How reproducible:
Always

Steps to Reproduce:
1. Launch Evolution and click on 'Contacts folder'
2. Double click on existing contact or one click on 'new'
3. Popup window appears announcing crash/seg fault
    

Actual Results:  Popup window appears annoucing seg fault.  Click
'Close'; Evolution
window also closes.

Expected Results:  Double click on Contract should open specific
Contact's config window
so that contact info can be ammended or appended.

Additional info:


(evolution:7463): libglade-WARNING **: could not find `gnome' init
function: `glade_module_register_widgets':
/usr/lib/libgmodule-2.0.so.0: undefined symbol:
glade_module_register_widgets
 
(evolution:7463): libglade-WARNING **: Could not load support for
`bonobo': /usr/lib/libbonobo.so: undefined symbol: TC_long_struct
 
(evolution:7463): libglade-WARNING **: unknown widget class 'GnomeApp'
 
(evolution:7463): GLib-GObject-WARNING **: invalid cast from
`GtkLabel' to `GtkContainer'
 
(evolution:7463): Gtk-CRITICAL **: file gtkcontainer.c: line 1277
(gtk_container_foreach): assertion `GTK_IS_CONTAINER (container)' failed
 
(evolution:7463): GLib-GObject-WARNING **: invalid cast from
`GtkLabel' to `GnomeApp'

-----------------------------------
Evolution version installed from FTP download.  Also did a 'rpmbuild 
--rebuild evolution-1.4.5-7.src.rpm' and then install...Same crashing
occurs.  No dependency issues reported when installing
'evolution-1.4.5-7.rpm'

Comment 1 Jeremy Katz 2003-11-14 04:43:21 UTC
What versions of glib2 and libglade do you have installed?

Comment 2 marty diamond 2003-11-14 05:23:40 UTC
glib2-2.2.3-1.1

libglade-0.17-12.2



Comment 3 Jeremy Katz 2003-11-14 17:50:39 UTC
Whoops, sorry -- libglade2, not libglade?

Comment 4 marty diamond 2003-11-14 20:07:08 UTC
libglade2-2.0.1-5.1


Comment 5 marty diamond 2003-11-26 18:30:03 UTC
Probably a minor detail but Platform is:  i686
NOT i386 as I first reported.

Comment 6 marty diamond 2004-01-20 14:24:11 UTC
After backing up essential data and config on this effected FC1 I did
a _clean_ install of FC1.  Copied my existing ~/evolution directory
into my new regular user account directory and launched Evo.  The
Evolution 'Contacts' function no longer crashes Evo.  I can now
open/edit/save the Evo contacts list and Bug#110136 is no longer an issue.

Side note:  Experience in the past with the windows OS had taught me
that OS updates where always problematic and not to be attempted.  My
_upgrade_ from RH9 to FC1 was an experiment that FAILED.  The FC1
update functionality is _flawed_ and should be avoided as well.


Note You need to log in before you can comment on or make changes to this bug.