Bug 1100283 - VDSM to require kernel-2.6.32-465 on EL for NFSv4 fixes.
Summary: VDSM to require kernel-2.6.32-465 on EL for NFSv4 fixes.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: vdsm
Version: 3.5.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ovirt-3.6.0-rc
: 3.6.0
Assignee: Allon Mureinik
QA Contact: Ori Gofen
URL:
Whiteboard:
Depends On: 1075123
Blocks: 1100285
TreeView+ depends on / blocked
 
Reported: 2014-05-22 12:28 UTC by Allon Mureinik
Modified: 2016-05-26 01:52 UTC (History)
9 users (show)

Fixed In Version: v4.17.0.3
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1100285 (view as bug list)
Environment:
Last Closed: 2016-03-09 19:21:35 UTC
oVirt Team: Storage
Target Upstream Version:
scohen: Triaged+


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:0362 normal SHIPPED_LIVE vdsm 3.6.0 bug fix and enhancement update 2016-03-09 23:49:32 UTC
oVirt gerrit 36191 None None None Never

Description Allon Mureinik 2014-05-22 12:28:18 UTC
Description of problem:
bug 1075123 introduces some fixes for NFSv4, which RHEV should support.
VDSM's build should require this version

Version-Release number of selected component (if applicable):
3.5.0

How reproducible:
100%

Steps to Reproduce:
1. Install VDSM with yum

Expected results:
kernel-2.6.32-465 or above should be required.

Comment 1 Allon Mureinik 2014-05-22 12:31:05 UTC
Note that we should wait for bug 1075123 to be released.

Comment 2 Allon Mureinik 2014-09-23 11:18:02 UTC
bug 1075123 will be included in RHEL 6.6, not in time for RHEVM 3.5.0.

Comment 3 Ori Gofen 2015-05-03 11:38:44 UTC
Allon, don't I need the spec file in-order to verify this?

Comment 4 Allon Mureinik 2015-05-03 13:55:04 UTC
(In reply to Ori Gofen from comment #3)
> Allon, don't I need the spec file in-order to verify this?
Sorry, but I don't understand the question.
Can you elaborate?

Comment 5 Ori Gofen 2015-05-03 14:17:08 UTC
is there any other way to verify this bug, without actually installing vdsm on an old kernel?

Comment 6 Allon Mureinik 2015-05-03 14:34:05 UTC
(In reply to Ori Gofen from comment #5)
> is there any other way to verify this bug, without actually installing vdsm
> on an old kernel?
Sure - Just run "rpm -qR" to see the list of dependencies. E.g., on my Fedora machine:

amureini@dhcp-0-202 ~ $ rpm -qR vdsm | grep kernel
kernel >= 3.11.3-201

Comment 7 Ori Gofen 2015-05-05 12:50:56 UTC
Verified on 3.6 master

Comment 10 errata-xmlrpc 2016-03-09 19:21:35 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0362.html


Note You need to log in before you can comment on or make changes to this bug.