Bug 1100528 - These APIs also need to add to `guestfish -h` command list
Summary: These APIs also need to add to `guestfish -h` command list
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: libguestfs
Version: 7.0
Hardware: Unspecified
OS: Unspecified
low
unspecified
Target Milestone: rc
: ---
Assignee: Richard W.M. Jones
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On: 1103877
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-05-23 03:12 UTC by Lingfei Kong
Modified: 2015-03-05 13:43 UTC (History)
5 users (show)

Fixed In Version: libguestfs-1.28.1-1.1.el7
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1103877 (view as bug list)
Environment:
Last Closed: 2015-03-05 13:43:45 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:0303 normal SHIPPED_LIVE libguestfs bug fix and enhancement update 2015-03-05 17:34:44 UTC

Description Lingfei Kong 2014-05-23 03:12:05 UTC
Description of problem:
I can get 558 APIs by pressing <TAB> in guestfish interactive model, but only 511 APIs can find in `guestfish -h` command list.

The losting 47 APIs:
 add
 add-drive-opts
 add-ro
 allocate
 append
 attach-method
 autosync
 backend
 cachedir
 direct
 domain
 emacs
 exit
 grep-opts
 is-blockdev-opts
 is-chardev-opts
 is-dir-opts
 is-fifo-opts
 is-file-opts
 is-socket-opts
 less
 manual
 memsize
 mkfs-opts
 mkswap-opts
 network
 ntfsresize-opts
 path
 pgroup
 pid
 program
 q
 qemu
 recovery-proc
 run
 scratch
 selinux
 smp
 tar-in-opts
 tar-out-opts
 tmpdir
 trace
 umount-opts
 unmount
 unmount-all
 verbose
 vi


Version-Release number of selected component (if applicable):
libguestfs-1.22.6-22.el7

How reproducible:
100%

Steps to Reproduce:
1. Get all APIs by run command `guestfish -h`
2. Enter into guestfish interactive model
3. Get all the APIs by pressing <TAB> in guestfish command
4. diff the APIs you get at step 1 and step 3


Actual results:
47 APIs appear in step 3 command list and not appear in step 1 command list


Expected results:
The command list of step 1 and step 3 are the same

Additional info:

Comment 2 Richard W.M. Jones 2014-05-23 08:48:55 UTC
(In reply to Lingfei Kong from comment #0)
> Description of problem:
> I can get 558 APIs by pressing <TAB> in guestfish interactive model, but
> only 511 APIs can find in `guestfish -h` command list.
> 
> The losting 47 APIs:

The *-opts APIs should not be documented in -h output, since they
are provided for backwards compatibility only.

The others (list provided below) I believe are all aliases, so we
could document them as:

  $ guestfish -h
      Command      Description
  add          alias for 'add-drive'
  add-ro       alias for 'add-drive-ro'
  [etc]

>  add
>  add-ro
>  allocate
>  append
>  attach-method
>  autosync
>  backend
>  cachedir
>  direct
>  domain
>  emacs
>  exit
>  less
>  manual
>  memsize
>  network
>  path
>  pgroup
>  pid
>  program
>  q
>  qemu
>  recovery-proc
>  run
>  scratch
>  selinux
>  smp
>  tmpdir
>  trace
>  unmount
>  unmount-all
>  verbose
>  vi

Comment 4 Richard W.M. Jones 2014-10-20 09:42:38 UTC
This is fixed in 1.28.  I'm not sure what precise version we
fixed it in.

Comment 6 yuliu 2014-11-18 06:23:34 UTC
Version: libguestfs-1.28.1-1.11.el7.x86_64

All the APIS except the opts added.

Verified.

Comment 8 errata-xmlrpc 2015-03-05 13:43:45 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-0303.html


Note You need to log in before you can comment on or make changes to this bug.