Bug 1103877 - These APIs also need to add to `guestfish -h` command list
Summary: These APIs also need to add to `guestfish -h` command list
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Virtualization Tools
Classification: Community
Component: libguestfs
Version: unspecified
Hardware: Unspecified
OS: Unspecified
low
unspecified
Target Milestone: ---
Assignee: Pino Toscano
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 1100528 1100530
TreeView+ depends on / blocked
 
Reported: 2014-06-02 19:12 UTC by Pino Toscano
Modified: 2014-06-10 10:18 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of: 1100528
Environment:
Last Closed: 2014-06-10 10:18:31 UTC


Attachments (Terms of Use)

Description Pino Toscano 2014-06-02 19:12:49 UTC
+++ This bug was initially created as a clone of Bug #1100528 +++

Description of problem:
I can get 558 APIs by pressing <TAB> in guestfish interactive model, but only 511 APIs can find in `guestfish -h` command list.

The losting 47 APIs:
 add
 add-drive-opts
 add-ro
 allocate
 append
 attach-method
 autosync
 backend
 cachedir
 direct
 domain
 emacs
 exit
 grep-opts
 is-blockdev-opts
 is-chardev-opts
 is-dir-opts
 is-fifo-opts
 is-file-opts
 is-socket-opts
 less
 manual
 memsize
 mkfs-opts
 mkswap-opts
 network
 ntfsresize-opts
 path
 pgroup
 pid
 program
 q
 qemu
 recovery-proc
 run
 scratch
 selinux
 smp
 tar-in-opts
 tar-out-opts
 tmpdir
 trace
 umount-opts
 unmount
 unmount-all
 verbose
 vi


Version-Release number of selected component (if applicable):
libguestfs-1.22.6-22.el7

How reproducible:
100%

Steps to Reproduce:
1. Get all APIs by run command `guestfish -h`
2. Enter into guestfish interactive model
3. Get all the APIs by pressing <TAB> in guestfish command
4. diff the APIs you get at step 1 and step 3


Actual results:
47 APIs appear in step 3 command list and not appear in step 1 command list


Expected results:
The command list of step 1 and step 3 are the same

Additional info:

--- Additional comment from Richard W.M. Jones on 2014-05-23 10:48:55 CEST ---

(In reply to Lingfei Kong from comment #0)
> Description of problem:
> I can get 558 APIs by pressing <TAB> in guestfish interactive model, but
> only 511 APIs can find in `guestfish -h` command list.
> 
> The losting 47 APIs:

The *-opts APIs should not be documented in -h output, since they
are provided for backwards compatibility only.

The others (list provided below) I believe are all aliases, so we
could document them as:

  $ guestfish -h
      Command      Description
  add          alias for 'add-drive'
  add-ro       alias for 'add-drive-ro'
  [etc]

>  add
>  add-ro
>  allocate
>  append
>  attach-method
>  autosync
>  backend
>  cachedir
>  direct
>  domain
>  emacs
>  exit
>  less
>  manual
>  memsize
>  network
>  path
>  pgroup
>  pid
>  program
>  q
>  qemu
>  recovery-proc
>  run
>  scratch
>  selinux
>  smp
>  tmpdir
>  trace
>  unmount
>  unmount-all
>  verbose
>  vi

Comment 1 Pino Toscano 2014-06-02 19:25:06 UTC
Patch posted:
  https://www.redhat.com/archives/libguestfs/2014-June/msg00005.html

Comment 2 Pino Toscano 2014-06-10 10:18:31 UTC
Fixed with
https://github.com/libguestfs/libguestfs/commit/5efbc8922ff3f338deb17b42bc7b63cc1545fcc0
which is in libguestfs >= 1.27.15.


Note You need to log in before you can comment on or make changes to this bug.