Bug 1101153 - RBTools missing dependency to python-argparse
Summary: RBTools missing dependency to python-argparse
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: RBTools
Version: el6
Hardware: Unspecified
OS: Unspecified
low
unspecified
Target Milestone: ---
Assignee: Stephen Gallagher
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1120268 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-05-26 10:06 UTC by blessjah
Modified: 2015-03-23 14:08 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-03-23 14:08:31 UTC


Attachments (Terms of Use)

Description blessjah 2014-05-26 10:06:01 UTC
Description of problem:

package RBTools needs dependency to python-argpars


Steps to Reproduce:
1. make sure python-argparse are not installed
2. install rbtools
3. rbt --help

Actual results:
Traceback (most recent call last):
  File "/usr/bin/rbt", line 5, in <module>
    from pkg_resources import load_entry_point
  File "/usr/lib/python2.6/site-packages/pkg_resources.py", line 2655, in <module>
    working_set.require(__requires__)
  File "/usr/lib/python2.6/site-packages/pkg_resources.py", line 648, in require
    needed = self.resolve(parse_requirements(requirements))
  File "/usr/lib/python2.6/site-packages/pkg_resources.py", line 546, in resolve
    raise DistributionNotFound(req)
pkg_resources.DistributionNotFound: argparse

Expected results:
usage: rbt [--version] <command> [options] [<args>]

positional arguments:
  command        The RBTools command to execute, and any arguments. (See
                 below)

   [...]

Additional info:
after installing python-argparse rbtools works fine

Comment 1 Stephen Gallagher 2014-05-27 12:36:44 UTC
I'm making this change to the package git, but I'm not going to push a new version out just for this; it's been my experience that most systems have python-argparse on them for other packages.

It'll get fixed the next time I do a bugfix release (I think upstream is going to be putting out a 0.6.1 pretty soon anyway).

Comment 2 Fedora Update System 2014-06-11 19:23:52 UTC
RBTools-0.6.1-1.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/RBTools-0.6.1-1.el6

Comment 3 Fedora Update System 2014-06-11 23:35:30 UTC
Package RBTools-0.6.1-1.el6:
* should fix your issue,
* was pushed to the Fedora EPEL 6 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=epel-testing RBTools-0.6.1-1.el6'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-EPEL-2014-1618/RBTools-0.6.1-1.el6
then log in and leave karma (feedback).

Comment 4 Stephen Gallagher 2014-07-21 12:52:26 UTC
*** Bug 1120268 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.