Bug 1120268 - RevewBoard - RBTools RPM spec doesn't require python-argparse
Summary: RevewBoard - RBTools RPM spec doesn't require python-argparse
Keywords:
Status: CLOSED DUPLICATE of bug 1101153
Alias: None
Product: Fedora
Classification: Fedora
Component: ReviewBoard
Version: 19
Hardware: Unspecified
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Stephen Gallagher
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-16 15:14 UTC by Mark
Modified: 2014-07-21 12:52 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-21 12:52:26 UTC


Attachments (Terms of Use)

Description Mark 2014-07-16 15:14:35 UTC
Description of problem:
reviewboard RBTools RPM doesn't require python-argparse. It needs to. 

Version-Release number of selected component (if applicable):

$ rpm -qi RBTools-0.6-1.el6.noarch 
Name        : RBTools                      Relocations: (not relocatable)
Version     : 0.6                               Vendor: Fedora Project
Release     : 1.el6                         Build Date: Tue 08 Apr 2014 11:36:03 AM MDT
Install Date: Tue 15 Jul 2014 04:32:50 PM MDT      Build Host: buildvm-12.phx2.fedoraproject.org
Group       : Applications/Internet         Source RPM: RBTools-0.6-1.el6.src.rpm
Size        : 992951                           License: MIT
Signature   : RSA/8, Tue 08 Apr 2014 07:34:57 PM MDT, Key ID 3b49df2a0608b895
Packager    : Fedora Project
URL         : http://www.review-board.org
Summary     : Tools for use with ReviewBoard
Description :
RBTools provides client tools for interacting with a ReviewBoard
code-review server.



How reproducible:
100%

Steps to Reproduce:
1. install a minimal install
2. install RBtools RPM
3. run "rbt --help"

Actual results:
rbt --help
Traceback (most recent call last):
  File "/usr/bin/rbt", line 5, in <module>
    from pkg_resources import load_entry_point
  File "/usr/lib/python2.6/site-packages/pkg_resources.py", line 2655, in <module>
    working_set.require(__requires__)
  File "/usr/lib/python2.6/site-packages/pkg_resources.py", line 648, in require
    needed = self.resolve(parse_requirements(requirements))
  File "/usr/lib/python2.6/site-packages/pkg_resources.py", line 546, in resolve
    raise DistributionNotFound(req)
pkg_resources.DistributionNotFound: argparse


Expected results:
$ rbt --help
usage: rbt [--version] <command> [options] [<args>]

positional arguments:
  command        The RBTools command to execute, and any arguments. (See
                 below)

optional arguments:
  -v, --version  show program's version number and exit
  -h, --help

The most commonly used commands are:
  post
  patch
  close
  diff

Other commands:
  api-get
  attach
  list-repo-types
  publish
  setup-repo
  status
See 'rbt help <command>' for more information on a specific command.

Additional info:
I am not 100% sure I placed this in the correct place in bugzilla. 


rpm -q --requires RBTools-0.6-1.el6.noarch 
/usr/bin/python  
python(abi) = 2.6
python-setuptools  
python-simplejson  
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(FileDigests) <= 4.6.0-1
rpmlib(PartialHardlinkSets) <= 4.0.4-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
rpmlib(PayloadIsXz) <= 5.2-1



I content this python-argparse should be added as required in the spec.

Comment 1 Stephen Gallagher 2014-07-21 12:52:26 UTC

*** This bug has been marked as a duplicate of bug 1101153 ***


Note You need to log in before you can comment on or make changes to this bug.