Bug 110117 - play-sound fails with osscommon-failure: unable to open dev/dsp in use
play-sound fails with osscommon-failure: unable to open dev/dsp in use
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: rhythmbox (Show other bugs)
1
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Colin Walters
:
: 111954 (view as bug list)
Depends On: 130593
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-14 17:11 EST by shrek-m
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-05-13 04:57:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description shrek-m 2003-11-14 17:11:34 EST
Description of problem:
play-sound fails with osscommon-failure:
  "unable to open dev/dsp (in use ?)"
if in gnome the sound-events are enabled
via gnome-sound-properties

Version-Release number of selected component (if applicable):
rhythmbox-0.5.4-1
gnome-media-2.4.0-2

How reproducible:
always

Steps to Reproduce:
1. enable gnome sound-events
2. try to play sound with rhythmbox --> error
3. use mplayer, xine, ...  --> no problems
  
Actual results:
you are not able to play sound with rhythmbox but with other players

Expected results:
rhythmbox should play the sound

Additional info:
disable the sound-events and rhythmbox is able to play sound
Comment 1 Miloslav Trmac 2004-03-01 04:33:07 EST
*** Bug 111954 has been marked as a duplicate of this bug. ***
Comment 2 Kyrre Ness Sjøbæk 2004-04-22 14:23:28 EDT
Seen the same problem when using KDE. It then pops up six messages
stating that /dev/dsp is in use. A quick lsof | grep dsp reveals that
it is artsd who occupies the. When I kill artsd, I am naturally able
to play music with rythmbox.

But this problem will go away anyway by itself in Fedora Core 2, as it
it has a 2.6 series kernel => ALSA which has multiple-stream support,
rigth?
Comment 3 Colin Walters 2004-09-21 17:13:49 EDT
For all of you: What is the output of:
gconftool-2 -g /system/gstreamer/0.8/default/audiosink

Be sure it's "alsasink".

Once that works, we need bug #130593 to be fixed.
Comment 4 shrek-m 2004-10-06 13:32:12 EDT
i had a harddisk-crash a few month agoo.

$ date -u
Mi Okt  6 17:09:05 UTC 2004

$ cat /etc/fedora-release
Fedora Core release 2 (Tettnang)

$ rpm -q rhythmbox gnome-media
rhythmbox-0.8.3-3
gnome-media-2.6.0-1

$ gconftool-2 -g /system/gstreamer/0.8/default/audiosink
alsasink


FYI:
i am not able to hear sound with rhytmbox *and* gnome-events together 
-->
ERROR "ALSA device "default" is already in use by another program."
ERROR  "Wiedergabe konnte nicht unterbrochen werden"

eg.

$ rhythmbox
Use of deprecated SAXv1 function endElement
** (gnome-help:11439): WARNING **: Cannot open font file for font
Kochi Gothic 10
Got error opening "file:///home/admin/sound/test.ogg": Wiedergabe
konnte nicht unterbrochen werden
Comment 5 Marius Andreiana 2005-05-13 04:34:23 EDT
Fedora Core 1 has been transferred to Fedora Legacy project. Please upgrade and
close this or move this bug in Fedora Legacy product.

Note You need to log in before you can comment on or make changes to this bug.