Bug 1101553 - [HE-setup] Use vdsm api instead of vdsClient
Summary: [HE-setup] Use vdsm api instead of vdsClient
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-hosted-engine-setup
Version: 3.3.0
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: ovirt-3.6.0-rc
: 3.6.0
Assignee: Sandro Bonazzola
QA Contact: Artyom
URL:
Whiteboard:
Depends On: 1213307 1215623 1215663 1215967 1220824 1271272
Blocks: 1005923 1234915
TreeView+ depends on / blocked
 
Reported: 2014-05-27 13:58 UTC by Yedidyah Bar David
Modified: 2016-03-09 18:51 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
The tool previously used vdsClient for interacting with VDSM. Now it uses vdscli API, resulting in better error handling and more control.
Clone Of:
Environment:
Last Closed: 2016-03-09 18:51:20 UTC
oVirt Team: Integration
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1101554 high CLOSED [RFE] HE-ha: use vdsm api instead of vdsClient 2020-10-14 00:28:05 UTC
Red Hat Product Errata RHEA-2016:0375 normal SHIPPED_LIVE ovirt-hosted-engine-setup bug fix and enhancement update 2016-03-09 23:48:34 UTC
oVirt gerrit 33996 master MERGED vdsm: use vdscli instead of vdsClient Never
oVirt gerrit 37560 None ABANDONED vdsm: use vdscli instead of vdsClient Never

Internal Links: 1101554

Description Yedidyah Bar David 2014-05-27 13:58:11 UTC
Our python code interfacing with vdsm should use its api and not run vdsClient. This will allow in principle simpler code (no need to parse output), faster execution (do not run an external program) etc.

vdsClient was used up until now because it was somewhat simpler to debug and because in the past there were some issues using the api in certain cases.

I am currently opening this bug due to an expected breakage caused by future fixing of bug #1005923 . This breakage can (obviously) be solved in other ways (including asking vdsm to add an option '--force' or something like that), but it seems that moving to use only the api is the better approach in the long run.

Comment 1 Sandro Bonazzola 2014-06-12 16:08:40 UTC
Since there will be a breakage, this will be a blocker if bug #1005923 will be targeted to 3.5.0

Comment 3 Sandro Bonazzola 2015-02-20 11:08:22 UTC
Automated message: can you please update doctext or set it as not required?

Comment 4 Artyom 2015-04-21 11:26:08 UTC
Hi, Sandro what the best way to verify this bug, I believe we just need to run different deployment cases and check that all work fine?

Comment 5 Sandro Bonazzola 2015-04-24 07:36:58 UTC
Yes Artyom, just executing deployment test cases should expose errors in the migration from vdsClient to vdsm API

Comment 6 Artyom 2015-11-09 09:38:05 UTC
Verified on ovirt-hosted-engine-setup-1.3.0-1.el7ev.noarch

Comment 8 errata-xmlrpc 2016-03-09 18:51:20 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-0375.html


Note You need to log in before you can comment on or make changes to this bug.